Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма целых чисел и написанных через дробь - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма целых чисел и написанных через дробь (Формулы/Formulas)
Сумма целых чисел и написанных через дробь
barinyaolga Дата: Пятница, 28.01.2022, 10:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Подскажите пожалуйста, есть ли способы сложения целых чисел и тех, что написаны через дробь (не проценты, все числа дроби идут как целые. Да, так надо :()?

Например: 1, 3, 1/4, 8, 2, 2/9, 1/2

Как посчитать сумму целых чисел и тех, что с левой стороны дроби? (В итоге 18 должно получиться)

и

Как посчитать сумму чисел с правой стороны дроби? (В итоге 15 должно получиться)

Пы.сы. Формат ячейки для дроби приходится ставить как "тестовый". Не уверена, что это верно.

Заранее благодарю!
К сообщению приложен файл: 6707680.xlsx(8.9 Kb)


Сообщение отредактировал barinyaolga - Пятница, 28.01.2022, 10:54
 
Ответить
СообщениеДобрый день!

Подскажите пожалуйста, есть ли способы сложения целых чисел и тех, что написаны через дробь (не проценты, все числа дроби идут как целые. Да, так надо :()?

Например: 1, 3, 1/4, 8, 2, 2/9, 1/2

Как посчитать сумму целых чисел и тех, что с левой стороны дроби? (В итоге 18 должно получиться)

и

Как посчитать сумму чисел с правой стороны дроби? (В итоге 15 должно получиться)

Пы.сы. Формат ячейки для дроби приходится ставить как "тестовый". Не уверена, что это верно.

Заранее благодарю!

Автор - barinyaolga
Дата добавления - 28.01.2022 в 10:41
Nic70y Дата: Пятница, 28.01.2022, 10:44 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7733
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
barinyaolga, вы файл-Excel приложите,
текст в теле поста можно понять поразному.
для дроби приходится ставить как "тестовый". Не уверена, что это верно
лучше так '1/2


ЮMoney 41001841029809
 
Ответить
Сообщениеbarinyaolga, вы файл-Excel приложите,
текст в теле поста можно понять поразному.
для дроби приходится ставить как "тестовый". Не уверена, что это верно
лучше так '1/2

Автор - Nic70y
Дата добавления - 28.01.2022 в 10:44
barinyaolga Дата: Пятница, 28.01.2022, 10:53 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, приложила. Надеюсь, понятно, что я имею ввиду)
 
Ответить
СообщениеNic70y, приложила. Надеюсь, понятно, что я имею ввиду)

Автор - barinyaolga
Дата добавления - 28.01.2022 в 10:53
Nic70y Дата: Пятница, 28.01.2022, 11:18 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7733
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
заменил * на '
Код
=СУММПРОИЗВ(--ЛЕВБ(B2:B8;ПОИСК("/";B2:B8&"/")-1))
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПСТР(B2:B8&"/0";ПОИСК("/";B2:B8&"/0")+1;15);"/";ПСТР(1/7;2;1)))
К сообщению приложен файл: 14.xlsx(9.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениезаменил * на '
Код
=СУММПРОИЗВ(--ЛЕВБ(B2:B8;ПОИСК("/";B2:B8&"/")-1))
Код
=СУММПРОИЗВ(--ПОДСТАВИТЬ(ПСТР(B2:B8&"/0";ПОИСК("/";B2:B8&"/0")+1;15);"/";ПСТР(1/7;2;1)))

Автор - Nic70y
Дата добавления - 28.01.2022 в 11:18
barinyaolga Дата: Пятница, 28.01.2022, 12:30 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Огромное спасибо за помощь!!!!
 
Ответить
СообщениеNic70y, Огромное спасибо за помощь!!!!

Автор - barinyaolga
Дата добавления - 28.01.2022 в 12:30
sergeyvislyaev Дата: Пятница, 28.01.2022, 14:02 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Как посчитать сумму первых трех чисел в столбце
 
Ответить
СообщениеКак посчитать сумму первых трех чисел в столбце

Автор - sergeyvislyaev
Дата добавления - 28.01.2022 в 14:02
китин Дата: Пятница, 28.01.2022, 14:29 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6897
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
sergeyvislyaev,
Ваш вопрос к данной теме не относится.
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеsergeyvislyaev,
Ваш вопрос к данной теме не относится.
- Прочитайте Правила форума
- Создайте свою тему согласно п.5q Правил форума

Автор - китин
Дата добавления - 28.01.2022 в 14:29
barinyaolga Дата: Понедельник, 31.01.2022, 17:00 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, прошу прощения еще раз) Если я правильно понимаю, чтобы ваша формула работала, данные должны быть во всех ячейках. А можно, например, сделать так, чтобы она считала по мере заполнения ячеек?) Грубо говоря, если в указанном диапазоне массива будет заполнена всего одна ячейка, а остальные будут пустыми, то формула её посчитает) Пример прикрепила. Буду очень благодарна за ответ! :D
К сообщению приложен файл: 1652487.xlsx(10.1 Kb)


Сообщение отредактировал barinyaolga - Понедельник, 31.01.2022, 17:09
 
Ответить
СообщениеNic70y, прошу прощения еще раз) Если я правильно понимаю, чтобы ваша формула работала, данные должны быть во всех ячейках. А можно, например, сделать так, чтобы она считала по мере заполнения ячеек?) Грубо говоря, если в указанном диапазоне массива будет заполнена всего одна ячейка, а остальные будут пустыми, то формула её посчитает) Пример прикрепила. Буду очень благодарна за ответ! :D

Автор - barinyaolga
Дата добавления - 31.01.2022 в 17:00
Nic70y Дата: Понедельник, 31.01.2022, 17:15 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 7733
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
левая
Код
=СУММПРОИЗВ(--ЛЕВБ(0&C4:C9;ПОИСК("/";0&C4:C9&"/")-1))
правая рабочая
К сообщению приложен файл: 0536251.xlsx(10.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениелевая
Код
=СУММПРОИЗВ(--ЛЕВБ(0&C4:C9;ПОИСК("/";0&C4:C9&"/")-1))
правая рабочая

Автор - Nic70y
Дата добавления - 31.01.2022 в 17:15
barinyaolga Дата: Понедельник, 31.01.2022, 17:20 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, вы - мой герой!!! Искренне благодарю!!!
 
Ответить
СообщениеNic70y, вы - мой герой!!! Искренне благодарю!!!

Автор - barinyaolga
Дата добавления - 31.01.2022 в 17:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма целых чисел и написанных через дробь (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!