Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Установить время в зависимости от даты и дня недели - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Установить время в зависимости от даты и дня недели (Формулы/Formulas)
Установить время в зависимости от даты и дня недели
dndndn Дата: Воскресенье, 30.01.2022, 18:40 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер, помогите пожалуйста, есть таблица (прилагаю), необходимо в столбцах 1го автомобиля если выпадает дата на субботу время столбца Начало было не 8:00 а 10:00, в будни и в воскресенье осталось так как есть.
К сообщению приложен файл: 2472169.xlsx(17.6 Kb)


Сообщение отредактировал dndndn - Воскресенье, 30.01.2022, 18:40
 
Ответить
СообщениеДобрый вечер, помогите пожалуйста, есть таблица (прилагаю), необходимо в столбцах 1го автомобиля если выпадает дата на субботу время столбца Начало было не 8:00 а 10:00, в будни и в воскресенье осталось так как есть.

Автор - dndndn
Дата добавления - 30.01.2022 в 18:40
Pelena Дата: Воскресенье, 30.01.2022, 19:56 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Если использовать Ваш подход, то
Код
=ЕСЛИ(И(ДЕНЬНЕД(B15;3)<6;ЕНД(ПОИСКПОЗ(B15;$M$24:$M$42;0)));$M$15+(ДЕНЬНЕД(B15;3)=5)*200;$M$16)

А почему с настоящим форматом времени не работаете?
К сообщению приложен файл: 5068035.xlsx(17.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если использовать Ваш подход, то
Код
=ЕСЛИ(И(ДЕНЬНЕД(B15;3)<6;ЕНД(ПОИСКПОЗ(B15;$M$24:$M$42;0)));$M$15+(ДЕНЬНЕД(B15;3)=5)*200;$M$16)

А почему с настоящим форматом времени не работаете?

Автор - Pelena
Дата добавления - 30.01.2022 в 19:56
dndndn Дата: Воскресенье, 30.01.2022, 20:40 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Спасибо за помощь! Не работаю с форматом времени потому что не умею, данную формулу так же помогли создать.
 
Ответить
СообщениеPelena, Спасибо за помощь! Не работаю с форматом времени потому что не умею, данную формулу так же помогли создать.

Автор - dndndn
Дата добавления - 30.01.2022 в 20:40
dndndn Дата: Воскресенье, 30.01.2022, 21:03 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Мне необходимо изменить так же и Окончание на 15:00, Перерыв по согласованию с Заказчиком час на 0:00, Время использования ТС час. на 5:00. Попытался изменить по Вашей формуле но не получилось.
 
Ответить
СообщениеPelena, Мне необходимо изменить так же и Окончание на 15:00, Перерыв по согласованию с Заказчиком час на 0:00, Время использования ТС час. на 5:00. Попытался изменить по Вашей формуле но не получилось.

Автор - dndndn
Дата добавления - 30.01.2022 в 21:03
Pelena Дата: Воскресенье, 30.01.2022, 21:29 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Посмотрите такой вариант с форматом времени
К сообщению приложен файл: 1071971.xlsx(17.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеПосмотрите такой вариант с форматом времени

Автор - Pelena
Дата добавления - 30.01.2022 в 21:29
dndndn Дата: Вторник, 01.02.2022, 15:45 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Если в столбце - Перерыв по соласованию с Заказчиком не поставить 0:00 то оставлю такой вариант, и на этом спасибо!
 
Ответить
СообщениеPelena, Если в столбце - Перерыв по соласованию с Заказчиком не поставить 0:00 то оставлю такой вариант, и на этом спасибо!

Автор - dndndn
Дата добавления - 01.02.2022 в 15:45
dndndn Дата: Вторник, 01.02.2022, 15:53 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Pelena, Можно ли сделать так чтоб эта ячейка в сб Перерыв по соласованию с Заказчиком с прочерком вместо не подкрашивалась серым цветом?
 
Ответить
СообщениеPelena, Можно ли сделать так чтоб эта ячейка в сб Перерыв по соласованию с Заказчиком с прочерком вместо не подкрашивалась серым цветом?

Автор - dndndn
Дата добавления - 01.02.2022 в 15:53
Pelena Дата: Вторник, 01.02.2022, 17:56 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
не поставить 0:00

не совсем поняла. Так?
К сообщению приложен файл: 0226971.xlsx(17.3 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
не поставить 0:00

не совсем поняла. Так?

Автор - Pelena
Дата добавления - 01.02.2022 в 17:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Установить время в зависимости от даты и дня недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!