Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск наименьшего расстояния до точки по координатам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьшего расстояния до точки по координатам (Формулы/Formulas)
Поиск наименьшего расстояния до точки по координатам
Yalex Дата: Вторник, 01.02.2022, 17:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите пожалуйста в решении задачи. Нужны формулы, файл прилагаю.

Дано:
Имеется список станций метро с их координатами (широта, долгота) и имеется несколько точек с координатами (широта, долгота).

Задача:
Найти по координатам ближайшее метро для каждой из точек и расстояние до него. В одной ячейке вывести его название, в другой расстояние до этого метро.
К сообщению приложен файл: 3161895.xlsx(16.6 Kb)
 
Ответить
СообщениеДобрый день! Помогите пожалуйста в решении задачи. Нужны формулы, файл прилагаю.

Дано:
Имеется список станций метро с их координатами (широта, долгота) и имеется несколько точек с координатами (широта, долгота).

Задача:
Найти по координатам ближайшее метро для каждой из точек и расстояние до него. В одной ячейке вывести его название, в другой расстояние до этого метро.

Автор - Yalex
Дата добавления - 01.02.2022 в 17:19
bigor Дата: Среда, 02.02.2022, 10:28 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 679
Репутация: 139 ±
Замечаний: 0% ±

нет
Привет
А пример реальный, я не могу на эти цифры выйти
Вот что получилось у меня
ближайшая наименование
Код
=ИНДЕКС($A$2:$A$176;ПОИСКПОЗ(МИН(6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180)));6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180));0))

расстояние
Код
=НАИМЕНЬШИЙ(6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180));1)

обе массивные
К сообщению приложен файл: 3161895_1.xlsx(13.4 Kb)
 
Ответить
СообщениеПривет
А пример реальный, я не могу на эти цифры выйти
Вот что получилось у меня
ближайшая наименование
Код
=ИНДЕКС($A$2:$A$176;ПОИСКПОЗ(МИН(6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180)));6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180));0))

расстояние
Код
=НАИМЕНЬШИЙ(6371*ACOS(SIN(G2*ПИ()/180)*SIN(($B$2:$B$196)*ПИ()/180)+COS(G2*ПИ()/180)*COS(($B$2:$B$196)*ПИ()/180)*COS((($C$2:$C$196)-H2)*ПИ()/180));1)

обе массивные

Автор - bigor
Дата добавления - 02.02.2022 в 10:28
Yalex Дата: Среда, 02.02.2022, 10:51 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

bigor, я по карте проверил, работает! Благодарю!!!
 
Ответить
Сообщениеbigor, я по карте проверил, работает! Благодарю!!!

Автор - Yalex
Дата добавления - 02.02.2022 в 10:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск наименьшего расстояния до точки по координатам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!