Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбрать несколько наибольших чисел в ряду. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать несколько наибольших чисел в ряду. (Формулы/Formulas)
Выбрать несколько наибольших чисел в ряду.
jons0njack Дата: Среда, 02.02.2022, 14:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Подскажите, пожалуйста, как решить следующую задачу:
Есть ряд чисел, от 0 до 100. Допустим, нужно из этого ряда выбрать 5 наибольших чисел.

Пример:
Ряд чисел: 2; 16; 48; 11; 1; 94; 72; 67.
Формула должна проставить под пятью наибольшими значениями из этого ряда значение "1", под остальными - значение "0"

Получится так:
Ряд чисел: 2; 16; 48; 11; 1; 94; 72; 67.
0; 1; 1; 0; 0; 1; 1; 1.

Естественно, необходимо, чтобы при изменении нужно количества наибольших значений автоматически пересматривались результаты (к примеру найти не 5 а 6 наибольших значений из ряда)


Сообщение отредактировал jons0njack - Среда, 02.02.2022, 14:20
 
Ответить
СообщениеЗдравствуйте!
Подскажите, пожалуйста, как решить следующую задачу:
Есть ряд чисел, от 0 до 100. Допустим, нужно из этого ряда выбрать 5 наибольших чисел.

Пример:
Ряд чисел: 2; 16; 48; 11; 1; 94; 72; 67.
Формула должна проставить под пятью наибольшими значениями из этого ряда значение "1", под остальными - значение "0"

Получится так:
Ряд чисел: 2; 16; 48; 11; 1; 94; 72; 67.
0; 1; 1; 0; 0; 1; 1; 1.

Естественно, необходимо, чтобы при изменении нужно количества наибольших значений автоматически пересматривались результаты (к примеру найти не 5 а 6 наибольших значений из ряда)

Автор - jons0njack
Дата добавления - 02.02.2022 в 14:02
Egyptian Дата: Среда, 02.02.2022, 14:53 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 386
Репутация: 132 ±
Замечаний: 0% ±

Excel 2013/2016
Ну как-то так.
К сообщению приложен файл: 4815285.png(4.6 Kb)
 
Ответить
СообщениеНу как-то так.

Автор - Egyptian
Дата добавления - 02.02.2022 в 14:53
китин Дата: Среда, 02.02.2022, 15:14 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
jons0njack, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеjons0njack, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума

Автор - китин
Дата добавления - 02.02.2022 в 15:14
DrMini Дата: Среда, 02.02.2022, 15:26 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
jons0njack,
Здравствуйте.
к примеру найти не 5 а 6 наибольших значений из ряда

Вот ещё вариант:
Код
=ЕСЛИ(РАНГ.РВ(A1;$A$1:$H$1;0)>$L$2;0;1)
К сообщению приложен файл: 3794346.xlsx(11.0 Kb)
 
Ответить
Сообщениеjons0njack,
Здравствуйте.
к примеру найти не 5 а 6 наибольших значений из ряда

Вот ещё вариант:
Код
=ЕСЛИ(РАНГ.РВ(A1;$A$1:$H$1;0)>$L$2;0;1)

Автор - DrMini
Дата добавления - 02.02.2022 в 15:26
jons0njack Дата: Среда, 02.02.2022, 17:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, Спасибо огромное!!! hands
 
Ответить
СообщениеEgyptian, Спасибо огромное!!! hands

Автор - jons0njack
Дата добавления - 02.02.2022 в 17:17
jons0njack Дата: Среда, 02.02.2022, 17:20 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

DrMini, Спасибо огромное !!!! hands hands hands
 
Ответить
СообщениеDrMini, Спасибо огромное !!!! hands hands hands

Автор - jons0njack
Дата добавления - 02.02.2022 в 17:20
jons0njack Дата: Среда, 02.02.2022, 17:28 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

китин, прошу прощения, забыл :facepalm:
 
Ответить
Сообщениекитин, прошу прощения, забыл :facepalm:

Автор - jons0njack
Дата добавления - 02.02.2022 в 17:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбрать несколько наибольших чисел в ряду. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!