Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подскажите, по зависимостям от значений в других ячейках - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подскажите, по зависимостям от значений в других ячейках (Формулы/Formulas)
Подскажите, по зависимостям от значений в других ячейках
95009500 Дата: Пятница, 04.02.2022, 23:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 для MAC OS
Доброго времени суток.

Прошу помощи, если не трудно подскажите пожалуйста, а то у самого мозгов не хватает.

Суть вопроса в следующем.

Хочу, чтобы при выборе из выпадающего списка в ячейке А1 (месяц) например "январь" в ячейку В9 автоматически проставлялось значение из ячейки Р9 (50), при выборе из выпадающего списка в ячейке А1 (месяц) "март" в ячейку В9 автоматически проставлялось значение из ячейки Т9 (150) и т.д.

Пример таблицы во вложении
К сообщению приложен файл: 4069027.xlsx(11.0 Kb)
 
Ответить
СообщениеДоброго времени суток.

Прошу помощи, если не трудно подскажите пожалуйста, а то у самого мозгов не хватает.

Суть вопроса в следующем.

Хочу, чтобы при выборе из выпадающего списка в ячейке А1 (месяц) например "январь" в ячейку В9 автоматически проставлялось значение из ячейки Р9 (50), при выборе из выпадающего списка в ячейке А1 (месяц) "март" в ячейку В9 автоматически проставлялось значение из ячейки Т9 (150) и т.д.

Пример таблицы во вложении

Автор - 95009500
Дата добавления - 04.02.2022 в 23:34
Egyptian Дата: Суббота, 05.02.2022, 00:14 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Можно так:
Код
=INDEX(O9:X9;MATCH(A1;O9:X9;0)+1)
 
Ответить
СообщениеМожно так:
Код
=INDEX(O9:X9;MATCH(A1;O9:X9;0)+1)

Автор - Egyptian
Дата добавления - 05.02.2022 в 00:14
95009500 Дата: Суббота, 05.02.2022, 10:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 для MAC OS
Egyptian, Спасибо
 
Ответить
СообщениеEgyptian, Спасибо

Автор - 95009500
Дата добавления - 05.02.2022 в 10:21
bmv98rus Дата: Суббота, 05.02.2022, 12:59 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3944
Репутация: 724 ±
Замечаний: 0% ±

Excel 2013/2016
ну или
Код
=INDEX(P9:X9;MATCH(A1;O9:W9;0))


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениену или
Код
=INDEX(P9:X9;MATCH(A1;O9:W9;0))

Автор - bmv98rus
Дата добавления - 05.02.2022 в 12:59
95009500 Дата: Суббота, 05.02.2022, 13:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 для MAC OS
доброго времени суток, не получается у меня реализовать свою задумку с помощью этой формулы.
наверное, я своей табличкой ввел в заблуждение

прикрепляю файл, по которому будет понятно, что я хочу в итоге от этой формулы получить.

при выборе в ячейке В3 (статойл) автоматически вставлялись бы значения из столбца (N5-N35) в ячейки (В5-В35) и так далее для остальных точек реализации.
К сообщению приложен файл: 7788598.xlsx(26.4 Kb)


Сообщение отредактировал 95009500 - Суббота, 05.02.2022, 13:13
 
Ответить
Сообщениедоброго времени суток, не получается у меня реализовать свою задумку с помощью этой формулы.
наверное, я своей табличкой ввел в заблуждение

прикрепляю файл, по которому будет понятно, что я хочу в итоге от этой формулы получить.

при выборе в ячейке В3 (статойл) автоматически вставлялись бы значения из столбца (N5-N35) в ячейки (В5-В35) и так далее для остальных точек реализации.

Автор - 95009500
Дата добавления - 05.02.2022 в 13:12
Egyptian Дата: Суббота, 05.02.2022, 13:56 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Тогда, наверное, так:
Код
=INDEX($N$5:$AR$35;AGGREGATE(15;6;(ROW($A$5:$A$50)-ROW($A$4))/($M$5:$AQ$35=A5);1);MATCH($B$3;$M$3:$AS$3;0))
К сообщению приложен файл: 5785041.xlsx(26.2 Kb)
 
Ответить
СообщениеТогда, наверное, так:
Код
=INDEX($N$5:$AR$35;AGGREGATE(15;6;(ROW($A$5:$A$50)-ROW($A$4))/($M$5:$AQ$35=A5);1);MATCH($B$3;$M$3:$AS$3;0))

Автор - Egyptian
Дата добавления - 05.02.2022 в 13:56
Pelena Дата: Суббота, 05.02.2022, 15:07 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 18560
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
Вариант
Код
=ИНДЕКС($M$5:$AS$35;СТРОКА(A1);ПОИСКПОЗ($B$3;$M$3:$AS$3;0)+1)
К сообщению приложен файл: 6226091.xlsx(27.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВариант
Код
=ИНДЕКС($M$5:$AS$35;СТРОКА(A1);ПОИСКПОЗ($B$3;$M$3:$AS$3;0)+1)

Автор - Pelena
Дата добавления - 05.02.2022 в 15:07
95009500 Дата: Воскресенье, 06.02.2022, 14:35 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016 для MAC OS
спасибо большое оба варианта работают.
 
Ответить
Сообщениеспасибо большое оба варианта работают.

Автор - 95009500
Дата добавления - 06.02.2022 в 14:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подскажите, по зависимостям от значений в других ячейках (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!