Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование ячеек по цвету заливки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по цвету заливки (Формулы/Formulas)
Суммирование ячеек по цвету заливки
ZabVs Дата: Суббота, 05.02.2022, 20:53 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.
Вопрос в столбцах С и D закрашенных красным цветом. Раньше у меня там все правильно считалось по формулам (благодаря макросу) типа
Код
=СумЦвет(Выгрузка!$N$4:$N$100;B9)

Но сначала я сам закрашивал ячейки на листе ВЫГРУЗКА и после чего велся расчет по этой формуле правильно, но сегодня я сделал чтобы там нужные ячейки закрашивались сами с помощью УСЛОВНОГО ФОРМАТИРОВАНИЯ и теперь по этой формуле расчет вообще не ведется.
Что нужно сделать? Что то с формулами или с УСЛОВИЯМИ ФОРМАТИРОВАНИЯ?
Одним словом надо чтобы на листе ЗАПОЛНЕНИЕ на выделенных ячейках была сумма ячеек такого же цвета с листа ВЫГРУЗКА.
К сообщению приложен файл: 2505255.xlsm(33.1 Kb)
 
Ответить
СообщениеЗдравствуйте.
Вопрос в столбцах С и D закрашенных красным цветом. Раньше у меня там все правильно считалось по формулам (благодаря макросу) типа
Код
=СумЦвет(Выгрузка!$N$4:$N$100;B9)

Но сначала я сам закрашивал ячейки на листе ВЫГРУЗКА и после чего велся расчет по этой формуле правильно, но сегодня я сделал чтобы там нужные ячейки закрашивались сами с помощью УСЛОВНОГО ФОРМАТИРОВАНИЯ и теперь по этой формуле расчет вообще не ведется.
Что нужно сделать? Что то с формулами или с УСЛОВИЯМИ ФОРМАТИРОВАНИЯ?
Одним словом надо чтобы на листе ЗАПОЛНЕНИЕ на выделенных ячейках была сумма ячеек такого же цвета с листа ВЫГРУЗКА.

Автор - ZabVs
Дата добавления - 05.02.2022 в 20:53
Pelena Дата: Суббота, 05.02.2022, 21:17 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
В принципе справляется формула
Код
=СУММЕСЛИ(Выгрузка!$A$4:$A$100;"*"&$B5&"*";Выгрузка!N$4:N$100)

кроме двух названий
(г. Кирсанов) - лишний пробел, надо (г.Кирсанов)
(п. Гавриловка) надо (с.Гавриловка 2-я)
На мой взгляд, проще написать одинаково названия, чем закрашивать, а потом ещё и макросом считать. Не?

И да, цвета от УФ функция СумЦвет не различает
К сообщению приложен файл: 8571544.xlsm(32.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеВ принципе справляется формула
Код
=СУММЕСЛИ(Выгрузка!$A$4:$A$100;"*"&$B5&"*";Выгрузка!N$4:N$100)

кроме двух названий
(г. Кирсанов) - лишний пробел, надо (г.Кирсанов)
(п. Гавриловка) надо (с.Гавриловка 2-я)
На мой взгляд, проще написать одинаково названия, чем закрашивать, а потом ещё и макросом считать. Не?

И да, цвета от УФ функция СумЦвет не различает

Автор - Pelena
Дата добавления - 05.02.2022 в 21:17
ZabVs Дата: Суббота, 05.02.2022, 21:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

проще написать одинаково названия

Да вот с названиями там как раз и заморочка, постоянно при выгрузке ищу различия :D А вот про такое
Код
;"*"&$B5&"*";

не знал, что можно текст искать не полностью. Спасибо


Сообщение отредактировал ZabVs - Суббота, 05.02.2022, 21:44
 
Ответить
Сообщение
проще написать одинаково названия

Да вот с названиями там как раз и заморочка, постоянно при выгрузке ищу различия :D А вот про такое
Код
;"*"&$B5&"*";

не знал, что можно текст искать не полностью. Спасибо

Автор - ZabVs
Дата добавления - 05.02.2022 в 21:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование ячеек по цвету заливки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!