Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Копирование значений из столбца в ячейки таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование значений из столбца в ячейки таблицы (Формулы/Formulas)
Копирование значений из столбца в ячейки таблицы
volkodav2003 Дата: Вторник, 15.02.2022, 02:00 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Привествую всех.

Вляпался в проблему с сортировкой данных. Суть: есть выгрузка данных в виде одного столбца текста, разбитого по ячейкам. Нужно вытащить из этого столбца значения Login, Password и Domain и скопировать их в таблицу.

Пример как столбца выгрузки, так и желаемой таблицы во вложении. Голову уже сломал начисто: если с доменами проблема решается банальным фильтром по структуре текста, то логины и пароли это чертов зоопарк, ни масок ни стандартов. Не уверен даже, что это можно сделать формулой, но мало ли...
К сообщению приложен файл: Sample.xlsx(9.1 Kb)


Сообщение отредактировал volkodav2003 - Вторник, 15.02.2022, 12:10
 
Ответить
СообщениеПривествую всех.

Вляпался в проблему с сортировкой данных. Суть: есть выгрузка данных в виде одного столбца текста, разбитого по ячейкам. Нужно вытащить из этого столбца значения Login, Password и Domain и скопировать их в таблицу.

Пример как столбца выгрузки, так и желаемой таблицы во вложении. Голову уже сломал начисто: если с доменами проблема решается банальным фильтром по структуре текста, то логины и пароли это чертов зоопарк, ни масок ни стандартов. Не уверен даже, что это можно сделать формулой, но мало ли...

Автор - volkodav2003
Дата добавления - 15.02.2022 в 02:00
Pelena Дата: Вторник, 15.02.2022, 07:08 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18561
Репутация: 4204 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Если каждая группа содержит 10 ячеек, как в примере, то можно добавить столбец с номерами п/п и формулу, например, для логина
Код
=ИНДЕКС(A:A;G11*10-2)
К сообщению приложен файл: Sample-1-.xlsx(10.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если каждая группа содержит 10 ячеек, как в примере, то можно добавить столбец с номерами п/п и формулу, например, для логина
Код
=ИНДЕКС(A:A;G11*10-2)

Автор - Pelena
Дата добавления - 15.02.2022 в 07:08
Egyptian Дата: Вторник, 15.02.2022, 07:16 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=IFERROR(INDEX($A$1:$A$30;AGGREGATE(15;6;ROW($A$2:$A$30)/($A$1:$A$30=H$10);ROW(A1)));"-")
К сообщению приложен файл: 8404974.xlsx(9.4 Kb)
 
Ответить
СообщениеВариант.
Код
=IFERROR(INDEX($A$1:$A$30;AGGREGATE(15;6;ROW($A$2:$A$30)/($A$1:$A$30=H$10);ROW(A1)));"-")

Автор - Egyptian
Дата добавления - 15.02.2022 в 07:16
volkodav2003 Дата: Вторник, 15.02.2022, 12:09 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Всем большое спасибо!
 
Ответить
СообщениеВсем большое спасибо!

Автор - volkodav2003
Дата добавления - 15.02.2022 в 12:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Копирование значений из столбца в ячейки таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!