Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Несоответствие поиска по максимальному значению - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несоответствие поиска по максимальному значению (Формулы/Formulas)
Несоответствие поиска по максимальному значению
astashov_michail@tutby Дата: Вторник, 15.02.2022, 17:23 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Всем ЗДРАВСТВУЙТЕ. Ранее (12.02.22) создавал тему, но как потом выяснилось не до конца разобрался, поэтому, наверное, и сформулировал проблемку. Почему то происходит не правильная привязка по второму столбцу, если в четвёртом похожее значение.
К сообщению приложен файл: 0078643.xlsx(23.7 Kb)
 
Ответить
СообщениеВсем ЗДРАВСТВУЙТЕ. Ранее (12.02.22) создавал тему, но как потом выяснилось не до конца разобрался, поэтому, наверное, и сформулировал проблемку. Почему то происходит не правильная привязка по второму столбцу, если в четвёртом похожее значение.

Автор - astashov_michail@tutby
Дата добавления - 15.02.2022 в 17:23
Pelena Дата: Вторник, 15.02.2022, 18:38 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18548
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Можно так
Код
=ИНДЕКС($B$2:$B$25;ПОИСКПОЗ(H2&J2;$C$2:$C$25&$D$2:$D$25;0))

или так без массивного ввода
Код
=ПРОСМОТР(;-1/($C$2:$C$25=H2)/($D$2:$D$25=J2);$B$2:$B$25)

Для первого значения формулы дают разный результат, т.к. в наличии два максимальных, при этом первая формула берёт первое максимальное значение, а вторая - последнее
К сообщению приложен файл: 9623475.xlsx(19.6 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно так
Код
=ИНДЕКС($B$2:$B$25;ПОИСКПОЗ(H2&J2;$C$2:$C$25&$D$2:$D$25;0))

или так без массивного ввода
Код
=ПРОСМОТР(;-1/($C$2:$C$25=H2)/($D$2:$D$25=J2);$B$2:$B$25)

Для первого значения формулы дают разный результат, т.к. в наличии два максимальных, при этом первая формула берёт первое максимальное значение, а вторая - последнее

Автор - Pelena
Дата добавления - 15.02.2022 в 18:38
astashov_michail@tutby Дата: Вторник, 15.02.2022, 19:29 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 66
Репутация: 0 ±
Замечаний: 20% ±

Pelena, огромное СПАСИБО!!!!!!!!
 
Ответить
СообщениеPelena, огромное СПАСИБО!!!!!!!!

Автор - astashov_michail@tutby
Дата добавления - 15.02.2022 в 19:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Несоответствие поиска по максимальному значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!