Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Определить тип дня (рабочий или выходной) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить тип дня (рабочий или выходной) (Формулы/Formulas)
Определить тип дня (рабочий или выходной)
Shakal07 Дата: Среда, 23.02.2022, 12:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2k3;2k7;2k10;2k13;2k19
Здравствуйте,

Нужна помощь с формулой определить тип дня рабочий или выходной в зависимости от изменений на соответствующем листе.

Надо откорректировать/переписать формулы в ячейках в диапазоне $H$5:$AL$5 на Листе1.
На строке 6 в диапазоне тех же столбцов указано как должно быть для Января

Пробовал что-то наваять сам, но не выходит тот результат который надо

Одним словом, надо определить рабочие дни с учетом перенесенных рабочих дней.
А также выходные дни (суббота и неделя) с учетом перенесенных выходных дней (суббота, неделя), праздников и религиозных праздников.

Списки упомянутых дней в предыдущих двух предложениях указаны на листе "Изменения" и соответственно подписаны

С уважением
К сообщению приложен файл: 1189672.xlsx(45.0 Kb)


Сообщение отредактировал Shakal07 - Среда, 23.02.2022, 13:22
 
Ответить
СообщениеЗдравствуйте,

Нужна помощь с формулой определить тип дня рабочий или выходной в зависимости от изменений на соответствующем листе.

Надо откорректировать/переписать формулы в ячейках в диапазоне $H$5:$AL$5 на Листе1.
На строке 6 в диапазоне тех же столбцов указано как должно быть для Января

Пробовал что-то наваять сам, но не выходит тот результат который надо

Одним словом, надо определить рабочие дни с учетом перенесенных рабочих дней.
А также выходные дни (суббота и неделя) с учетом перенесенных выходных дней (суббота, неделя), праздников и религиозных праздников.

Списки упомянутых дней в предыдущих двух предложениях указаны на листе "Изменения" и соответственно подписаны

С уважением

Автор - Shakal07
Дата добавления - 23.02.2022 в 12:50
gling Дата: Четверг, 24.02.2022, 00:37 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Здравствуйте.
Попробуйте это
Код
СЧЁТЕСЛИ(PubHolid[Государственные праздники];N$3);"В";СЧЁТЕСЛИ(PostWeekSat[Перенесенные выходные (субботы)];N$3);"В";СЧЁТЕСЛИ(PostWeekSun[Перенесенные выходные (недели)];N$3);"В";СЧЁТЕСЛИ(ReligHolid[Религиозные праздники];N$3);
заменить на это
Код
СЧЁТЕСЛИ(Изменения!$A$2:$I$8;Лист1!N3);


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Попробуйте это
Код
СЧЁТЕСЛИ(PubHolid[Государственные праздники];N$3);"В";СЧЁТЕСЛИ(PostWeekSat[Перенесенные выходные (субботы)];N$3);"В";СЧЁТЕСЛИ(PostWeekSun[Перенесенные выходные (недели)];N$3);"В";СЧЁТЕСЛИ(ReligHolid[Религиозные праздники];N$3);
заменить на это
Код
СЧЁТЕСЛИ(Изменения!$A$2:$I$8;Лист1!N3);

Автор - gling
Дата добавления - 24.02.2022 в 00:37
Shakal07 Дата: Четверг, 24.02.2022, 12:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 29
Репутация: 0 ±
Замечаний: 0% ±

Excel 2k3;2k7;2k10;2k13;2k19
gling, Спасибо за ответ. Но к сожалению ничего не изменилось
 
Ответить
Сообщениеgling, Спасибо за ответ. Но к сожалению ничего не изменилось

Автор - Shakal07
Дата добавления - 24.02.2022 в 12:02
gling Дата: Пятница, 25.02.2022, 07:00 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
У меня в Excel 2010 ваша формула не читается по этому написал понятную мне. Для Н5
Код
=ЕСЛИ(СЧЁТЕСЛИ(Изменения!$A$2:$I$8;Лист1!H3);"В";ЕСЛИ(ДЕНЬНЕД(H$3;2)<6;"Р";"В"))


ЯД-41001506838083

Сообщение отредактировал gling - Пятница, 25.02.2022, 07:04
 
Ответить
СообщениеУ меня в Excel 2010 ваша формула не читается по этому написал понятную мне. Для Н5
Код
=ЕСЛИ(СЧЁТЕСЛИ(Изменения!$A$2:$I$8;Лист1!H3);"В";ЕСЛИ(ДЕНЬНЕД(H$3;2)<6;"Р";"В"))

Автор - gling
Дата добавления - 25.02.2022 в 07:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Определить тип дня (рабочий или выходной) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!