Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Добавление условий по соседним ячейкам в формулу СЧЕТЕСЛИМН - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление условий по соседним ячейкам в формулу СЧЕТЕСЛИМН
Добавление условий по соседним ячейкам в формулу СЧЕТЕСЛИМН
pechkin Дата: Вторник, 01.03.2022, 13:07 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 296
Репутация: 42 ±
Замечаний: 0% ±

2003
Здравствуйте! Подскажите, есть ли возможность обойтись без доп.столбца ( в файле понятней). Необходимо добавить в формулу СЧЕТЕСЛИМН,или подскажите другую, условия по значению соседних (выше или ниже на одну строку) ячеек. Спасибо!
К сообщению приложен файл: 123321.xls(29.5 Kb)


Сообщение отредактировал pechkin - Вторник, 01.03.2022, 13:08
 
Ответить
СообщениеЗдравствуйте! Подскажите, есть ли возможность обойтись без доп.столбца ( в файле понятней). Необходимо добавить в формулу СЧЕТЕСЛИМН,или подскажите другую, условия по значению соседних (выше или ниже на одну строку) ячеек. Спасибо!

Автор - pechkin
Дата добавления - 01.03.2022 в 13:07
Nic70y Дата: Вторник, 01.03.2022, 14:28 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7526
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=СУММ(((ЕСЛИОШИБКА((J7:J28*J9:J30);)+J8:J29)=0)*(I8:I29>2)*(A8:A29>=K6))
, но с оговоркой (вопрос)
см. файл
К сообщению приложен файл: 19.xls(38.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=СУММ(((ЕСЛИОШИБКА((J7:J28*J9:J30);)+J8:J29)=0)*(I8:I29>2)*(A8:A29>=K6))
, но с оговоркой (вопрос)
см. файл

Автор - Nic70y
Дата добавления - 01.03.2022 в 14:28
pechkin Дата: Среда, 02.03.2022, 08:03 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 296
Репутация: 42 ±
Замечаний: 0% ±

2003
Здравствуйте! Спасибо за ответ. Формула подходит,но при добавлении в таблицу новых значений,начиная с восьмой строки(вставить скопированные ячейки макросом) формула меняет диапазон и не работает. Возможно ли поправить? Спасибо!
К сообщению приложен файл: 19_.xls(32.5 Kb)
 
Ответить
СообщениеЗдравствуйте! Спасибо за ответ. Формула подходит,но при добавлении в таблицу новых значений,начиная с восьмой строки(вставить скопированные ячейки макросом) формула меняет диапазон и не работает. Возможно ли поправить? Спасибо!

Автор - pechkin
Дата добавления - 02.03.2022 в 08:03
Nic70y Дата: Среда, 02.03.2022, 08:19 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7526
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
вставить скопированные ячейки макросом
теперь понятно для чего у вас
Код
=ИНДЕКС():ИНДЕКС
К сообщению приложен файл: 800.xls(39.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
вставить скопированные ячейки макросом
теперь понятно для чего у вас
Код
=ИНДЕКС():ИНДЕКС

Автор - Nic70y
Дата добавления - 02.03.2022 в 08:19
pechkin Дата: Среда, 02.03.2022, 17:12 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 296
Репутация: 42 ±
Замечаний: 0% ±

2003
Спасибо!
 
Ответить
СообщениеСпасибо!

Автор - pechkin
Дата добавления - 02.03.2022 в 17:12
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Добавление условий по соседним ячейкам в формулу СЧЕТЕСЛИМН
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!