Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула в одну ячейку для копирования данных с столбца. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула в одну ячейку для копирования данных с столбца. (Формулы/Formulas)
Формула в одну ячейку для копирования данных с столбца.
Александр7034 Дата: Вторник, 01.03.2022, 13:39 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Нужна формула в одну одну ячейку для копирования данных с одной колонки на чистый новый лист. Суть в том что все расчеты, вводные, переменные у меня на первом листе. Готовый результат выводится там же в колонке на 1000 ячеек.
(в столбце C2 прописано
Код
=ЕСЛИ((ЦЕЛОЕ((СТРОКА(B2)-1)/$A$6)+1+$A$46)<=$A$14;ТЕКСТ($A$10;"000000")&ИНДЕКС($D$2:$D$31;ОСТАТ(СТРОКА(B2)-1;СЧЁТЗ($D$2:$D$31))+1)&ТЕКСТ(ЦЕЛОЕ((СТРОКА(B2)-1)/СЧЁТЗ($D$2:$D$31))+1+$A$47;"00");"")
И эта формула протянута в столбце на 1000 ячеек)
В зависимости от переменных, в колонке С для печати может быть получено от 1 до 1000 номеров. Сгенерировал 100 номеров, остальные 900 ячеек остались пустые. Так вот программа термопринтера видит что в пустых ячейках есть эта размноженная формула и принимает их за данные, отправляя на печать 100 нужных этикеток с номерами + 900 пустых этикеток. Поэтому и нужен костыль, который копировал бы только полученные данные в колонку на второй чистый лист


Сообщение отредактировал Александр7034 - Вторник, 01.03.2022, 14:18
 
Ответить
СообщениеНужна формула в одну одну ячейку для копирования данных с одной колонки на чистый новый лист. Суть в том что все расчеты, вводные, переменные у меня на первом листе. Готовый результат выводится там же в колонке на 1000 ячеек.
(в столбце C2 прописано
Код
=ЕСЛИ((ЦЕЛОЕ((СТРОКА(B2)-1)/$A$6)+1+$A$46)<=$A$14;ТЕКСТ($A$10;"000000")&ИНДЕКС($D$2:$D$31;ОСТАТ(СТРОКА(B2)-1;СЧЁТЗ($D$2:$D$31))+1)&ТЕКСТ(ЦЕЛОЕ((СТРОКА(B2)-1)/СЧЁТЗ($D$2:$D$31))+1+$A$47;"00");"")
И эта формула протянута в столбце на 1000 ячеек)
В зависимости от переменных, в колонке С для печати может быть получено от 1 до 1000 номеров. Сгенерировал 100 номеров, остальные 900 ячеек остались пустые. Так вот программа термопринтера видит что в пустых ячейках есть эта размноженная формула и принимает их за данные, отправляя на печать 100 нужных этикеток с номерами + 900 пустых этикеток. Поэтому и нужен костыль, который копировал бы только полученные данные в колонку на второй чистый лист

Автор - Александр7034
Дата добавления - 01.03.2022 в 13:39
китин Дата: Вторник, 01.03.2022, 14:17 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6804
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Александр7034, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеАлександр7034, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 01.03.2022 в 14:17
Александр7034 Дата: Вторник, 01.03.2022, 15:06 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 21
Репутация: 0 ±
Замечаний: 20% ±

Исправил. Но формула к основной сути вопроса отношения не имеет, просто написал что в ячейках вписано.
 
Ответить
СообщениеИсправил. Но формула к основной сути вопроса отношения не имеет, просто написал что в ячейках вписано.

Автор - Александр7034
Дата добавления - 01.03.2022 в 15:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула в одну ячейку для копирования данных с столбца. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!