Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Транспонирование таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование таблицы (Формулы/Formulas)
Транспонирование таблицы
Kirito Дата: Понедельник, 14.03.2022, 19:45 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Как можно транспонировать таблицы в соответствии с условиями (см. "Лист1" "Лист2"). Есть номер "Лист1" столбец "А" и у этого номера есть определенное количество условий. Необходимо растянуть номера по всем строкам в соответствии с количеством условий (см. "Лист2")
К сообщению приложен файл: 2747104.xlsx(9.8 Kb)


Сообщение отредактировал Kirito - Понедельник, 14.03.2022, 19:46
 
Ответить
СообщениеКак можно транспонировать таблицы в соответствии с условиями (см. "Лист1" "Лист2"). Есть номер "Лист1" столбец "А" и у этого номера есть определенное количество условий. Необходимо растянуть номера по всем строкам в соответствии с количеством условий (см. "Лист2")

Автор - Kirito
Дата добавления - 14.03.2022 в 19:45
прохожий2019 Дата: Понедельник, 14.03.2022, 20:39 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 908
Репутация: 250 ±
Замечаний: 0% ±

365 Beta Channel
PQ
[vba]
Код
Table.RemoveColumns(Table.UnpivotOtherColumns(Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content], {"№"}, "tmp", "Название атрибута"),{"tmp"})
[/vba]
К сообщению приложен файл: 5036959.xlsx(20.0 Kb)
 
Ответить
СообщениеPQ
[vba]
Код
Table.RemoveColumns(Table.UnpivotOtherColumns(Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content], {"№"}, "tmp", "Название атрибута"),{"tmp"})
[/vba]

Автор - прохожий2019
Дата добавления - 14.03.2022 в 20:39
Egyptian Дата: Понедельник, 14.03.2022, 22:18 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 386
Репутация: 132 ±
Замечаний: 0% ±

Excel 2013/2016
Формулами.
К сообщению приложен файл: 33333.xlsx(19.4 Kb)


Сообщение отредактировал Egyptian - Понедельник, 14.03.2022, 23:19
 
Ответить
СообщениеФормулами.

Автор - Egyptian
Дата добавления - 14.03.2022 в 22:18
Kirito Дата: Вторник, 15.03.2022, 09:10 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Egyptian, Спасибо! А как можно расширить диапазон если в строке максимум может быть 24 атрибута (столбцы с "А" до "X")? Я пробовал менять формулу не получается(


Сообщение отредактировал Kirito - Вторник, 15.03.2022, 09:14
 
Ответить
СообщениеEgyptian, Спасибо! А как можно расширить диапазон если в строке максимум может быть 24 атрибута (столбцы с "А" до "X")? Я пробовал менять формулу не получается(

Автор - Kirito
Дата добавления - 15.03.2022 в 09:10
Kirito Дата: Вторник, 15.03.2022, 09:12 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
прохожий2019, спасибо! Есть ли инструкция по работе с PQ. Как туда формулу вставить?
 
Ответить
Сообщениепрохожий2019, спасибо! Есть ли инструкция по работе с PQ. Как туда формулу вставить?

Автор - Kirito
Дата добавления - 15.03.2022 в 09:12
Egyptian Дата: Вторник, 15.03.2022, 10:21 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 386
Репутация: 132 ±
Замечаний: 0% ±

Excel 2013/2016
Kirito,
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$100;ПОИСКПОЗ(ЛОЖЬ;(СЧЁТЕСЛИ($D$1:D1;Лист1!$A$2:$A$100)=МУМНОЖ(Ч(Лист1!$B$2:$X$100>0);СТРОКА(A$1:ИНДЕКС(A:A;СЧЁТЗ(Лист1!$B$1:$AA$1)))^0));0));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$2:$X$100;ПОИСКПОЗ($D2;Лист1!$A$2:$A$100;);AGGREGATE(15;6;СТОЛБЕЦ($A$1:ИНДЕКС($1:$1;СЧЁТЗ(Лист1!$B$1:$AA$1)))/(Лист1!$B$2:$X$100>0)/(Лист1!$A$2:$A$100=$D2);СЧЁТЕСЛИ($D$2:D2;D2)));"")
К сообщению приложен файл: 4444.xlsx(19.6 Kb)


Сообщение отредактировал Egyptian - Вторник, 15.03.2022, 20:35
 
Ответить
СообщениеKirito,
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$A$2:$A$100;ПОИСКПОЗ(ЛОЖЬ;(СЧЁТЕСЛИ($D$1:D1;Лист1!$A$2:$A$100)=МУМНОЖ(Ч(Лист1!$B$2:$X$100>0);СТРОКА(A$1:ИНДЕКС(A:A;СЧЁТЗ(Лист1!$B$1:$AA$1)))^0));0));"")

Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!$B$2:$X$100;ПОИСКПОЗ($D2;Лист1!$A$2:$A$100;);AGGREGATE(15;6;СТОЛБЕЦ($A$1:ИНДЕКС($1:$1;СЧЁТЗ(Лист1!$B$1:$AA$1)))/(Лист1!$B$2:$X$100>0)/(Лист1!$A$2:$A$100=$D2);СЧЁТЕСЛИ($D$2:D2;D2)));"")

Автор - Egyptian
Дата добавления - 15.03.2022 в 10:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Транспонирование таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!