Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет по 3м критериям (поискпоз) - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет по 3м критериям (поискпоз) (Формулы/Formulas)
Расчет по 3м критериям (поискпоз)
boldinae Дата: Четверг, 17.03.2022, 10:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 40% ±

Добрый день! Прошу помочь, необходимо найти значение, удовлетворяющее трем критериям: город, дата, наименование . Использовала функции индекс и поискпоз, безуспешно :( :(
Возможно со СМЕЩ?
К сообщению приложен файл: 8228581.xlsx(15.9 Kb)


Сообщение отредактировал boldinae - Четверг, 17.03.2022, 12:47
 
Ответить
СообщениеДобрый день! Прошу помочь, необходимо найти значение, удовлетворяющее трем критериям: город, дата, наименование . Использовала функции индекс и поискпоз, безуспешно :( :(
Возможно со СМЕЩ?

Автор - boldinae
Дата добавления - 17.03.2022 в 10:28
Nic70y Дата: Четверг, 17.03.2022, 10:33 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7520
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС('Исх. данные'!C:C;ПОИСКПОЗ($C$4;'Исх. данные'!$B:$B;)+СТРОКА(A1))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС('Исх. данные'!C:C;ПОИСКПОЗ($C$4;'Исх. данные'!$B:$B;)+СТРОКА(A1))

Автор - Nic70y
Дата добавления - 17.03.2022 в 10:33
Serge_007 Дата: Четверг, 17.03.2022, 10:42 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15154
Репутация: 2503 ±
Замечаний: ±

Excel 2016
Возможно со СМЕЩ?
Можно и со СМЕЩ():
Код
=СМЕЩ('Исх. данные'!$B$4;СТРОКА(A1)+ПОИСКПОЗ($C$4;'Исх. данные'!$B$5:$B$43;);СТОЛБЕЦ(A1))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Возможно со СМЕЩ?
Можно и со СМЕЩ():
Код
=СМЕЩ('Исх. данные'!$B$4;СТРОКА(A1)+ПОИСКПОЗ($C$4;'Исх. данные'!$B$5:$B$43;);СТОЛБЕЦ(A1))

Автор - Serge_007
Дата добавления - 17.03.2022 в 10:42
китин Дата: Четверг, 17.03.2022, 11:08 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6804
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2007;2010;2016
а поизголяться?

Код
=ИНДЕКС(СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0);1;3;15);ПОИСКПОЗ($C6;СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0);;3;);0);ПОИСКПОЗ(E$5;СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0)-1;1;;15);0))
К сообщению приложен файл: 5857979.xlsx(16.1 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеа поизголяться?

Код
=ИНДЕКС(СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0);1;3;15);ПОИСКПОЗ($C6;СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0);;3;);0);ПОИСКПОЗ(E$5;СМЕЩ('Исх. данные'!$B$5;ПОИСКПОЗ('Задание 6'!$C$4;'Исх. данные'!$B$5:$B$43;0)-1;1;;15);0))

Автор - китин
Дата добавления - 17.03.2022 в 11:08
boldinae Дата: Четверг, 17.03.2022, 11:08 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 40% ±

Nic70y, Serge_007, Спасибо Вам огромное hands
 
Ответить
СообщениеNic70y, Serge_007, Спасибо Вам огромное hands

Автор - boldinae
Дата добавления - 17.03.2022 в 11:08
Egyptian Дата: Четверг, 17.03.2022, 12:57 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 311
Репутация: 107 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант на тему "усложнить")
Код
=VLOOKUP($C6,CHOOSE(MATCH($C$4,{"Тамбов","Омск","Астрахань","Волгоград","Белгород","Новосибирск"},),'Исх. данные'!$B$6:$Q$8,'Исх. данные'!$B$13:$Q$15,'Исх. данные'!$B$20:$Q$22,'Исх. данные'!$B$27:$Q$29,'Исх. данные'!$B$34:$Q$36,'Исх. данные'!$B$41:$Q$43),MATCH(E$5,'Исх. данные'!$B$26:$Q$26),0)
К сообщению приложен файл: 1144051.xlsx(17.9 Kb)
 
Ответить
СообщениеВариант на тему "усложнить")
Код
=VLOOKUP($C6,CHOOSE(MATCH($C$4,{"Тамбов","Омск","Астрахань","Волгоград","Белгород","Новосибирск"},),'Исх. данные'!$B$6:$Q$8,'Исх. данные'!$B$13:$Q$15,'Исх. данные'!$B$20:$Q$22,'Исх. данные'!$B$27:$Q$29,'Исх. данные'!$B$34:$Q$36,'Исх. данные'!$B$41:$Q$43),MATCH(E$5,'Исх. данные'!$B$26:$Q$26),0)

Автор - Egyptian
Дата добавления - 17.03.2022 в 12:57
китин Дата: Четверг, 17.03.2022, 13:22 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6804
Репутация: 1046 ±
Замечаний: 0% ±

Excel 2007;2010;2016
тему "усложнить")

Egyptian, а у меня длиннее, да еще и волатильная :p :p :p


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
тему "усложнить")

Egyptian, а у меня длиннее, да еще и волатильная :p :p :p

Автор - китин
Дата добавления - 17.03.2022 в 13:22
Egyptian Дата: Четверг, 17.03.2022, 13:33 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 311
Репутация: 107 ±
Замечаний: 0% ±

Excel 2013/2016
а у меня длиннее

Ну может самую малость. B)

да еще и волатильная

А вот с этим - да, промашка вышла :D
 
Ответить
Сообщение
а у меня длиннее

Ну может самую малость. B)

да еще и волатильная

А вот с этим - да, промашка вышла :D

Автор - Egyptian
Дата добавления - 17.03.2022 в 13:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет по 3м критериям (поискпоз) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!