Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сосчитать дубликаты строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сосчитать дубликаты строк (Формулы/Formulas)
Сосчитать дубликаты строк
stalber Дата: Пятница, 18.03.2022, 11:36 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 320
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Помогите пожалуйста, имеются строки с числами, нужно рядом сосчитать сколько повторных строк.
К сообщению приложен файл: dublikati.xlsx(10.1 Kb)
 
Ответить
СообщениеПомогите пожалуйста, имеются строки с числами, нужно рядом сосчитать сколько повторных строк.

Автор - stalber
Дата добавления - 18.03.2022 в 11:36
NikitaDvorets Дата: Пятница, 18.03.2022, 11:58 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 361
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
stalber, добрый день.
Попробуйте формулу
Код
{=СЧЁТЕСЛИМН($C$2:$C$16;$C2;$D$2:$D$16;$D2;$E$2:$E$16;$E2)}
К сообщению приложен файл: dublikati-18-03.xlsx(11.2 Kb)
 
Ответить
Сообщениеstalber, добрый день.
Попробуйте формулу
Код
{=СЧЁТЕСЛИМН($C$2:$C$16;$C2;$D$2:$D$16;$D2;$E$2:$E$16;$E2)}

Автор - NikitaDvorets
Дата добавления - 18.03.2022 в 11:58
stalber Дата: Пятница, 18.03.2022, 12:01 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 320
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Спасибо, но нужен результат подсчёта который у меня указан, с вашей формулой результат другой.
 
Ответить
СообщениеСпасибо, но нужен результат подсчёта который у меня указан, с вашей формулой результат другой.

Автор - stalber
Дата добавления - 18.03.2022 в 12:01
китин Дата: Пятница, 18.03.2022, 12:05 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
так?
Код
=СЧЁТ(ЕСЛИ($C$2:$C2&$D$2:$D2&$E$2:E2=C2&D2&E2;$D$2:$D2))-1

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 8749491.xlsx(11.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениетак?
Код
=СЧЁТ(ЕСЛИ($C$2:$C2&$D$2:$D2&$E$2:E2=C2&D2&E2;$D$2:$D2))-1

Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Автор - китин
Дата добавления - 18.03.2022 в 12:05
_Boroda_ Дата: Пятница, 18.03.2022, 12:08 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММПРОИЗВ(Ч((C$1:C1&"!"&D$1:D1&"!"&E$1:E1)=(C2&"!"&D2&"!"&E2)))

или
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(C2:E2=C1:E1))=3;H1+1;)

Результаты разные для двух последних строк
К сообщению приложен файл: dublikati_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Пятница, 18.03.2022, 12:21
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Ч((C$1:C1&"!"&D$1:D1&"!"&E$1:E1)=(C2&"!"&D2&"!"&E2)))

или
Код
=ЕСЛИ(СУММПРОИЗВ(Ч(C2:E2=C1:E1))=3;H1+1;)

Результаты разные для двух последних строк

Автор - _Boroda_
Дата добавления - 18.03.2022 в 12:08
_Boroda_ Дата: Пятница, 18.03.2022, 12:09 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
($C$2:$C2&$D$2:$D2...

Нужен разделитель. Иначе 25;6 будет равно 2;56


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
($C$2:$C2&$D$2:$D2...

Нужен разделитель. Иначе 25;6 будет равно 2;56

Автор - _Boroda_
Дата добавления - 18.03.2022 в 12:09
Nic70y Дата: Пятница, 18.03.2022, 12:18 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7723
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);H1+1;0)
К сообщению приложен файл: 9370531.xlsx(11.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);H1+1;0)

Автор - Nic70y
Дата добавления - 18.03.2022 в 12:18
stalber Дата: Пятница, 18.03.2022, 12:35 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 320
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Код
=ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);H1+1;0)

Не подумал об одной детали, мне нужно формулу скажем сразу растянуть на 100 строк, и при растягивании данные постепенно пишутся, то есть получается что формула считает пустые строки, можно сделать условие если строка пустая то формула пустоту показывает ?
К сообщению приложен файл: 22211193705312.xlsx(10.8 Kb)


Сообщение отредактировал Serge_007 - Пятница, 18.03.2022, 15:09
 
Ответить
Сообщение
Код
=ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);H1+1;0)

Не подумал об одной детали, мне нужно формулу скажем сразу растянуть на 100 строк, и при растягивании данные постепенно пишутся, то есть получается что формула считает пустые строки, можно сделать условие если строка пустая то формула пустоту показывает ?

Автор - stalber
Дата добавления - 18.03.2022 в 12:35
Nic70y Дата: Пятница, 18.03.2022, 12:45 | Сообщение № 9
Группа: Друзья
Ранг: Экселист
Сообщений: 7723
Репутация: 1852 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(C2&D2&E2="";"";ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);СУММ(H1;1);0))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(C2&D2&E2="";"";ЕСЛИ((C2=C1)*(D2=D1)*(E2=E1);СУММ(H1;1);0))

Автор - Nic70y
Дата добавления - 18.03.2022 в 12:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сосчитать дубликаты строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!