Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти числа, которые были до среднего значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти числа, которые были до среднего значения (Формулы/Formulas)
Найти числа, которые были до среднего значения
kostya03prokhorov Дата: Воскресенье, 27.03.2022, 15:40 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер, возник вопрос: как найти числа, которые были до среднего значения, но только так, чтобы они были целыми?
Я уже нашёл числа, но они дробные. :'(
 
Ответить
СообщениеДобрый вечер, возник вопрос: как найти числа, которые были до среднего значения, но только так, чтобы они были целыми?
Я уже нашёл числа, но они дробные. :'(

Автор - kostya03prokhorov
Дата добавления - 27.03.2022 в 15:40
kostya03prokhorov Дата: Воскресенье, 27.03.2022, 15:41 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Вот мой файл
К сообщению приложен файл: 8702390.xlsx(9.3 Kb)
 
Ответить
СообщениеВот мой файл

Автор - kostya03prokhorov
Дата добавления - 27.03.2022 в 15:41
_Boroda_ Дата: Понедельник, 28.03.2022, 10:20 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16359
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А так не пойдет?
Код
=ОКРУГЛ(СЛУЧМЕЖДУ($G4*(1-$B$1)/1%;$G4*(1+$B$1)/1%)%;0)

Все равно у Вас условие +-1% не соблюдается в столбце Значение 5.
Да и в других столбцах иногда тоже. СЛУЧМЕЖДУ работает с целыми числами, а Вы ей подсовываете дробные
Понажимайте в моем файле F9 и посмотрите на табличку справа, там раскрашиваются косяки
К сообщению приложен файл: 8702390_1.xlsx(10.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Понедельник, 28.03.2022, 10:25
 
Ответить
СообщениеА так не пойдет?
Код
=ОКРУГЛ(СЛУЧМЕЖДУ($G4*(1-$B$1)/1%;$G4*(1+$B$1)/1%)%;0)

Все равно у Вас условие +-1% не соблюдается в столбце Значение 5.
Да и в других столбцах иногда тоже. СЛУЧМЕЖДУ работает с целыми числами, а Вы ей подсовываете дробные
Понажимайте в моем файле F9 и посмотрите на табличку справа, там раскрашиваются косяки

Автор - _Boroda_
Дата добавления - 28.03.2022 в 10:20
kostya03prokhorov Дата: Понедельник, 28.03.2022, 16:15 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, большое спасибо, это то что нужно!
Я такой процент поставил лишь для того, чтобы значения между строками были как можно дальше друг от друга.
 
Ответить
Сообщение_Boroda_, большое спасибо, это то что нужно!
Я такой процент поставил лишь для того, чтобы значения между строками были как можно дальше друг от друга.

Автор - kostya03prokhorov
Дата добавления - 28.03.2022 в 16:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти числа, которые были до среднего значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!