Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение всех значений через запятую при совпадении данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение всех значений через запятую при совпадении данных (Формулы/Formulas)
Заполнение всех значений через запятую при совпадении данных
zingeroud Дата: Среда, 30.03.2022, 12:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
Добрый день.
Суть задачи сравнить построчно две таблицы и заполнить все значения (через запятую или колонкой) в отдельную колонку при условии их совпадения.
Составить формулу, которая заполнить через запятую или столбиком все значения в колонку J Листа 1 из листа 2 колонки В, сравнив колонку В листа 1 и колонку А листа 2.
Пробовал через ВПР но эта функция возвращает одно значение, а мне нужен массив.
К сообщению приложен файл: _3.5.1.xls(272.0 Kb)


Сообщение отредактировал zingeroud - Среда, 30.03.2022, 12:25
 
Ответить
СообщениеДобрый день.
Суть задачи сравнить построчно две таблицы и заполнить все значения (через запятую или колонкой) в отдельную колонку при условии их совпадения.
Составить формулу, которая заполнить через запятую или столбиком все значения в колонку J Листа 1 из листа 2 колонки В, сравнив колонку В листа 1 и колонку А листа 2.
Пробовал через ВПР но эта функция возвращает одно значение, а мне нужен массив.

Автор - zingeroud
Дата добавления - 30.03.2022 в 12:17
_Boroda_ Дата: Среда, 30.03.2022, 12:37 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
На лист2 формулу в С2
Код
=B2&ЕСЛИ(A2=A3;", "&C3;"")

А потом и ВПР заработает
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист2!A$2:C$2937;3;);"")
К сообщению приложен файл: _3.5.1_1.xlsb(266.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНа лист2 формулу в С2
Код
=B2&ЕСЛИ(A2=A3;", "&C3;"")

А потом и ВПР заработает
Код
=ЕСЛИОШИБКА(ВПР(B2;Лист2!A$2:C$2937;3;);"")

Автор - _Boroda_
Дата добавления - 30.03.2022 в 12:37
Nic70y Дата: Среда, 30.03.2022, 12:45 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7523
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
или столбиком
так?
Код
=ЕСЛИ(ИНДЕКС(Лист2!$A:$A;ПОИСКПОЗ($B2;Лист2!$A:$A;)+СТОЛБЕЦ(A1)-1)=$B2;ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ($B2;Лист2!$A:$A;)+СТОЛБЕЦ(A1)-1);"")
К сообщению приложен файл: _3.5.2.xls(345.0 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
или столбиком
так?
Код
=ЕСЛИ(ИНДЕКС(Лист2!$A:$A;ПОИСКПОЗ($B2;Лист2!$A:$A;)+СТОЛБЕЦ(A1)-1)=$B2;ИНДЕКС(Лист2!$B:$B;ПОИСКПОЗ($B2;Лист2!$A:$A;)+СТОЛБЕЦ(A1)-1);"")

Автор - Nic70y
Дата добавления - 30.03.2022 в 12:45
zingeroud Дата: Среда, 30.03.2022, 17:24 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 20% ±

Excel 2010
В сообщении 2 получилось как надо, все данные вписались в одну ячейку, в вашем варианте только первое совпадение


Сообщение отредактировал Serge_007 - Среда, 30.03.2022, 21:38
 
Ответить
СообщениеВ сообщении 2 получилось как надо, все данные вписались в одну ячейку, в вашем варианте только первое совпадение

Автор - zingeroud
Дата добавления - 30.03.2022 в 17:24
Nic70y Дата: Среда, 30.03.2022, 17:27 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7523
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
в вашем варианте только первое совпадение
нет. тяните столбец вправо. это просто вариант, с допами уже предложил _Boroda_


ЮMoney 41001841029809
 
Ответить
Сообщение
в вашем варианте только первое совпадение
нет. тяните столбец вправо. это просто вариант, с допами уже предложил _Boroda_

Автор - Nic70y
Дата добавления - 30.03.2022 в 17:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение всех значений через запятую при совпадении данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!