Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сбор данных из таблицы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из таблицы (Формулы/Formulas)
Сбор данных из таблицы
Aleksei-7445144 Дата: Вторник, 05.04.2022, 09:04 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Прошу помощи.
Задача следующая - Есть таблица в которую поступают данные какого числа и в какое время работал сотрудник и на каком станке. Сверху таблицы(отмечено оранж.) - заложенный план в каждый час. Нужно вычислить эффективность работы сотрудника на каждом станке относительно заложенного плана.
Приблизительный вид сделал в таблице (отметил зелен. цветом) - все данные в данной таблице посчитаны вручную для примера того что хотелось бы сделать через формулы.
Подскажите пжл возможно ли вытащить подобное из данного массива данных или подскажите как можно изменить таблицу чтобы получить необходимые данные?
Заранее большое спасибо!!!!!
К сообщению приложен файл: ____.xlsx(55.8 Kb)
 
Ответить
СообщениеДобрый день! Прошу помощи.
Задача следующая - Есть таблица в которую поступают данные какого числа и в какое время работал сотрудник и на каком станке. Сверху таблицы(отмечено оранж.) - заложенный план в каждый час. Нужно вычислить эффективность работы сотрудника на каждом станке относительно заложенного плана.
Приблизительный вид сделал в таблице (отметил зелен. цветом) - все данные в данной таблице посчитаны вручную для примера того что хотелось бы сделать через формулы.
Подскажите пжл возможно ли вытащить подобное из данного массива данных или подскажите как можно изменить таблицу чтобы получить необходимые данные?
Заранее большое спасибо!!!!!

Автор - Aleksei-7445144
Дата добавления - 05.04.2022 в 09:04
_Boroda_ Дата: Вторник, 05.04.2022, 10:02 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16135
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
План так
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60)*(C$9:Z$54<>0)*C$4:Z$4)

или так (у Вас по-разному посчитано)
Код
=СУММПРОИЗВ((G$7:AD$52=$B60)*(G$8:AD$53=$C60)*G$4:AD$4)

Факт так
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60)*Ч(+C$9:Z$54))
К сообщению приложен файл: _1.xlsx(56.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПлан так
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60)*(C$9:Z$54<>0)*C$4:Z$4)

или так (у Вас по-разному посчитано)
Код
=СУММПРОИЗВ((G$7:AD$52=$B60)*(G$8:AD$53=$C60)*G$4:AD$4)

Факт так
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60)*Ч(+C$9:Z$54))

Автор - _Boroda_
Дата добавления - 05.04.2022 в 10:02
Aleksei-7445144 Дата: Вторник, 05.04.2022, 10:47 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Спасибо большое за ответ, буду изучать
 
Ответить
Сообщение_Boroda_, Спасибо большое за ответ, буду изучать

Автор - Aleksei-7445144
Дата добавления - 05.04.2022 в 10:47
Aleksei-7445144 Дата: Вторник, 05.04.2022, 14:11 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Все работает, спасибо большое!!!!
Прошу прощения за наглость, а не подскажите еще, как посчитать количество совпадений(часов). Т.е. нужно понимать Сколько совпадений за период было между Сидоров=Станок1
 
Ответить
Сообщение_Boroda_, Все работает, спасибо большое!!!!
Прошу прощения за наглость, а не подскажите еще, как посчитать количество совпадений(часов). Т.е. нужно понимать Сколько совпадений за период было между Сидоров=Станок1

Автор - Aleksei-7445144
Дата добавления - 05.04.2022 в 14:11
_Boroda_ Дата: Вторник, 05.04.2022, 14:24 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16135
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Убейте последний кусок в формуле
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеУбейте последний кусок в формуле
Код
=СУММПРОИЗВ((C$7:Z$52=$B60)*(C$8:Z$53=$C60))

Автор - _Boroda_
Дата добавления - 05.04.2022 в 14:24
Aleksei-7445144 Дата: Вторник, 05.04.2022, 14:27 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 15
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, спасибо большое
 
Ответить
Сообщение_Boroda_, спасибо большое

Автор - Aleksei-7445144
Дата добавления - 05.04.2022 в 14:27
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сбор данных из таблицы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!