Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вставка значение после ВПР - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка значение после ВПР (Формулы/Formulas)
Вставка значение после ВПР
Den115 Дата: Среда, 06.04.2022, 17:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Подскажите, пожалуйста, формулу или порядок действий, который будет выполнять следующий момент:
Есть два массива информации: №1 состоящий из 30000 строк и №2 состоящий из 40000 строк.
Через ВПР получается так: из массива №1 через ВПР найдены 4000 строк, которые есть в массиве №2 и они расположены в абсолютно разных местах одного столбца.
Мне необходимо получить значение соседней ячейки справа от найденной в массиве № 2
Т.е. Ячейка А150 в массиве №1 соответствует ячейке А2967 в массиве №2, и мне необходимо получить значение ячейки В2967. Простым ЕСЛИ(ВПР...);B2967;) не получается, так как при протягивании данной формулы массив №2 читается ячейка+1, что в данному случае не правильно.
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, формулу или порядок действий, который будет выполнять следующий момент:
Есть два массива информации: №1 состоящий из 30000 строк и №2 состоящий из 40000 строк.
Через ВПР получается так: из массива №1 через ВПР найдены 4000 строк, которые есть в массиве №2 и они расположены в абсолютно разных местах одного столбца.
Мне необходимо получить значение соседней ячейки справа от найденной в массиве № 2
Т.е. Ячейка А150 в массиве №1 соответствует ячейке А2967 в массиве №2, и мне необходимо получить значение ячейки В2967. Простым ЕСЛИ(ВПР...);B2967;) не получается, так как при протягивании данной формулы массив №2 читается ячейка+1, что в данному случае не правильно.

Автор - Den115
Дата добавления - 06.04.2022 в 17:06
Serge_007 Дата: Среда, 06.04.2022, 17:16 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15405
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Здравствуйте

из массива №1 через ВПР найдены 4000 строк
Функция ВПР() возвращает только одно значение

при протягивании данной формулы массив №2 читается ячейка+1
Что значит "ячейка+1"?

Ячейка А150 в массиве №1 соответствует ячейке А2967 в массиве №2, и мне необходимо получить значение ячейки В2967
В данном случае =ВПР(А150;$массив№2;2;0) вернет именно значение ячейки В2967
В чем проблема-то?
Может Вы ссылки абсолютные не проставили?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

из массива №1 через ВПР найдены 4000 строк
Функция ВПР() возвращает только одно значение

при протягивании данной формулы массив №2 читается ячейка+1
Что значит "ячейка+1"?

Ячейка А150 в массиве №1 соответствует ячейке А2967 в массиве №2, и мне необходимо получить значение ячейки В2967
В данном случае =ВПР(А150;$массив№2;2;0) вернет именно значение ячейки В2967
В чем проблема-то?
Может Вы ссылки абсолютные не проставили?

Автор - Serge_007
Дата добавления - 06.04.2022 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вставка значение после ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!