Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод топ-3 повторяющихся значений по убыванию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод топ-3 повторяющихся значений по убыванию (Формулы/Formulas)
Вывод топ-3 повторяющихся значений по убыванию
alexeicozlov Дата: Четверг, 07.04.2022, 11:41 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, подскажите, пожалуйста, как в данном примере вывести топ 3 наиболее часто встречающихся значений при условии того, что в строке могут быть пустые ячейки.
Спасибо!
К сообщению приложен файл: TEST.xlsx(17.8 Kb)
 
Ответить
СообщениеДобрый день, подскажите, пожалуйста, как в данном примере вывести топ 3 наиболее часто встречающихся значений при условии того, что в строке могут быть пустые ячейки.
Спасибо!

Автор - alexeicozlov
Дата добавления - 07.04.2022 в 11:41
Nic70y Дата: Четверг, 07.04.2022, 11:56 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7523
Репутация: 1778 ±
Замечаний: 0% ±

Excel 2010
вариант, формула массива:
Код
=ЕСЛИОШИБКА(--ПСТР(-ИНДЕКС($B3:$AU3;ПОИСКПОЗ(НАИБОЛЬШИЙ(СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3);СУММ(СЧЁТЕСЛИ($AV3:AV3;$B3:$AU3);1));СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3);));2;15);AV3)
К сообщению приложен файл: 3206532.xlsx(11.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениевариант, формула массива:
Код
=ЕСЛИОШИБКА(--ПСТР(-ИНДЕКС($B3:$AU3;ПОИСКПОЗ(НАИБОЛЬШИЙ(СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3);СУММ(СЧЁТЕСЛИ($AV3:AV3;$B3:$AU3);1));СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3);));2;15);AV3)

Автор - Nic70y
Дата добавления - 07.04.2022 в 11:56
_Boroda_ Дата: Четверг, 07.04.2022, 12:06 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А если одинаковое количество?
Код
=ИНДЕКС($B3:$AU3;ПОИСКПОЗ(НАИБОЛЬШИЙ(СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3)+$B3:$AU3%%%%;1+СУММ(СЧЁТЕСЛИ($B3:$AU3;$AV3:AV3)));СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3)+$B3:$AU3%%%%;))
К сообщению приложен файл: TEST_1.xlsx(11.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА если одинаковое количество?
Код
=ИНДЕКС($B3:$AU3;ПОИСКПОЗ(НАИБОЛЬШИЙ(СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3)+$B3:$AU3%%%%;1+СУММ(СЧЁТЕСЛИ($B3:$AU3;$AV3:AV3)));СЧЁТЕСЛИ($B3:$AU3;$B3:$AU3)+$B3:$AU3%%%%;))

Автор - _Boroda_
Дата добавления - 07.04.2022 в 12:06
alexeicozlov Дата: Четверг, 07.04.2022, 12:16 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое!
 
Ответить
СообщениеСпасибо большое!

Автор - alexeicozlov
Дата добавления - 07.04.2022 в 12:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод топ-3 повторяющихся значений по убыванию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!