Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма по последней недели - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по последней недели (Формулы/Formulas)
Сумма по последней недели
TurboRadost Дата: Среда, 13.04.2022, 11:20 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Как можно и можно ли упаковать подсчет результатов по последней недели в одну формулу без дополнительных столбцов? В таблицу каждый день добавляются строки с разными датами, нужно в итогах таблицы вывести параметр сумма по последней недели на этот год. Приложил файл с костылями как я смог это сделать, но хочется больше эстетики и аскетизма в формулах.

A64 это ячейка с результатом C:C это дополнительный столбец от которого хочется избавиться.
К сообщению приложен файл: 1393951.xlsx(12.7 Kb)
 
Ответить
СообщениеДобрый день.
Как можно и можно ли упаковать подсчет результатов по последней недели в одну формулу без дополнительных столбцов? В таблицу каждый день добавляются строки с разными датами, нужно в итогах таблицы вывести параметр сумма по последней недели на этот год. Приложил файл с костылями как я смог это сделать, но хочется больше эстетики и аскетизма в формулах.

A64 это ячейка с результатом C:C это дополнительный столбец от которого хочется избавиться.

Автор - TurboRadost
Дата добавления - 13.04.2022 в 11:20
_Boroda_ Дата: Среда, 13.04.2022, 11:31 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Последняя неделя - это
1. с понедельника по сегодня
2. с понедельника по воскресенье (та неделя, где сегодняшняя дата)
3. от сегодняшней даты 7 дней назад
Какой вариант нужен?
И да, НОМНЕДЕЛИ без второго аргумента начинает отсчет с воскресенья, Вам так и нужно?

Добавлено
С понедельника по воскресенье
Код
=СУММЕСЛИМН(A2:A999;B2:B999;">"&СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2);B2:B999;"<"&СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)+8)
К сообщению приложен файл: 1393951_1.xlsx(13.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 13.04.2022, 11:37
 
Ответить
СообщениеПоследняя неделя - это
1. с понедельника по сегодня
2. с понедельника по воскресенье (та неделя, где сегодняшняя дата)
3. от сегодняшней даты 7 дней назад
Какой вариант нужен?
И да, НОМНЕДЕЛИ без второго аргумента начинает отсчет с воскресенья, Вам так и нужно?

Добавлено
С понедельника по воскресенье
Код
=СУММЕСЛИМН(A2:A999;B2:B999;">"&СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2);B2:B999;"<"&СЕГОДНЯ()-ДЕНЬНЕД(СЕГОДНЯ();2)+8)

Автор - _Boroda_
Дата добавления - 13.04.2022 в 11:31
TurboRadost Дата: Среда, 13.04.2022, 11:40 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Нужна последняя календарная неделя с понедельника по воскресенье
 
Ответить
Сообщение_Boroda_, Нужна последняя календарная неделя с понедельника по воскресенье

Автор - TurboRadost
Дата добавления - 13.04.2022 в 11:40
_Boroda_ Дата: Среда, 13.04.2022, 11:46 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16137
Репутация: 6259 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Выше написал уже


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВыше написал уже

Автор - _Boroda_
Дата добавления - 13.04.2022 в 11:46
TurboRadost Дата: Среда, 13.04.2022, 12:05 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 45
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо.
 
Ответить
Сообщение_Boroda_, Спасибо.

Автор - TurboRadost
Дата добавления - 13.04.2022 в 12:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма по последней недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!