Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перебор ячеек в Excel - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перебор ячеек в Excel (Формулы/Formulas)
Перебор ячеек в Excel
BreadMan Дата: Четверг, 21.04.2022, 02:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 40% ±

Всем привет! Такой вопрос:
Нужно перебирать значения ячеек от A2 до A1000 сравнивая их с ячейкой B3, пока они совпадают - выдавать результат, как только совпадение прекратилось, останавливать перебор.

Подробно:
Есть 2 вкладки - Работа и ЗП. Во вкладе 'Работа' ячейки с датами и именами промоутеров:

Во вкладке 'ЗП' список с именами промоутеров:


Мне нужно чтоб при выборе даты (ячейка "B3") во вкладке 'ЗП', список 'Промик' заполнялся сам. Тоесть, если я выбираю дату 19.04.22, нужно чтоб формула начинала перебор всех дат во вкладе 'Работа', и все промоутеры которые выходили в этот день отображались в списке промоутеров во вкладке "ЗП" (в моем случае, имена - Данил (1030), Даниил, Саша).

Надеюсь понятно объяснил :)
Буду очень благодарен, если кто-то поможет разобраться с этим.


Сообщение отредактировал BreadMan - Четверг, 21.04.2022, 02:10
 
Ответить
СообщениеВсем привет! Такой вопрос:
Нужно перебирать значения ячеек от A2 до A1000 сравнивая их с ячейкой B3, пока они совпадают - выдавать результат, как только совпадение прекратилось, останавливать перебор.

Подробно:
Есть 2 вкладки - Работа и ЗП. Во вкладе 'Работа' ячейки с датами и именами промоутеров:

Во вкладке 'ЗП' список с именами промоутеров:


Мне нужно чтоб при выборе даты (ячейка "B3") во вкладке 'ЗП', список 'Промик' заполнялся сам. Тоесть, если я выбираю дату 19.04.22, нужно чтоб формула начинала перебор всех дат во вкладе 'Работа', и все промоутеры которые выходили в этот день отображались в списке промоутеров во вкладке "ЗП" (в моем случае, имена - Данил (1030), Даниил, Саша).

Надеюсь понятно объяснил :)
Буду очень благодарен, если кто-то поможет разобраться с этим.

Автор - BreadMan
Дата добавления - 21.04.2022 в 02:04
китин Дата: Четверг, 21.04.2022, 08:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
ВПР, ИНДЕКС+ПОИСКПОЗ. точнее при наличии файла примера


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеВПР, ИНДЕКС+ПОИСКПОЗ. точнее при наличии файла примера

Автор - китин
Дата добавления - 21.04.2022 в 08:26
BreadMan Дата: Четверг, 21.04.2022, 11:22 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 40% ±

китин, да, что-то я тупанул, сразу не скинул. Вот исходный файл:

ИСХОДНИК
 
Ответить
Сообщениекитин, да, что-то я тупанул, сразу не скинул. Вот исходный файл:

ИСХОДНИК

Автор - BreadMan
Дата добавления - 21.04.2022 в 11:22
_Boroda_ Дата: Четверг, 21.04.2022, 11:30 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16363
Репутация: 6352 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не, сюда файл положите.
1. Не все (и я в том числе) могут по ссылкам ходить
2. Завтра у кого-нибудь будет такой же вопрос, а ссылка сломается. Как он смотреть будет?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе, сюда файл положите.
1. Не все (и я в том числе) могут по ссылкам ходить
2. Завтра у кого-нибудь будет такой же вопрос, а ссылка сломается. Как он смотреть будет?

Автор - _Boroda_
Дата добавления - 21.04.2022 в 11:30
китин Дата: Четверг, 21.04.2022, 11:31 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
BreadMan, Вот лично мне мой добрый и отзывчивый сисадмин не дает возможности выходить в облачные хранилища. ниииизя говорит


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеBreadMan, Вот лично мне мой добрый и отзывчивый сисадмин не дает возможности выходить в облачные хранилища. ниииизя говорит

Автор - китин
Дата добавления - 21.04.2022 в 11:31
BreadMan Дата: Четверг, 21.04.2022, 11:39 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 40% ±

китин,
Прошу прощения, господа. Надеюсь, сейчас все правильно сделал
К сообщению приложен файл: 1326855.xlsx(398.7 Kb)
 
Ответить
Сообщениекитин,
Прошу прощения, господа. Надеюсь, сейчас все правильно сделал

Автор - BreadMan
Дата добавления - 21.04.2022 в 11:39
Serge_007 Дата: Четверг, 21.04.2022, 11:43 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
сисадмин не дает возможности выходить в облачные хранилища
Дело даже не в этом
Дело в том, что ТС не читает правила даже после получения замечания


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
сисадмин не дает возможности выходить в облачные хранилища
Дело даже не в этом
Дело в том, что ТС не читает правила даже после получения замечания

Автор - Serge_007
Дата добавления - 21.04.2022 в 11:43
китин Дата: Четверг, 21.04.2022, 11:57 | Сообщение № 8
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Код
=ЕСЛИОШИБКА(ИНДЕКС(Работа!$B$2:$B$150;НАИМЕНЬШИЙ(ЕСЛИ(Работа!$A$2:$A$150=ЗП!$B$3;СТРОКА(Работа!$A$2:$A$150)-1);СТРОКА(A1)));"")
К сообщению приложен файл: 4846385.xlsx(391.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеФормула массива. Вводится одновременным нажатием Ctrl+Shift+Enter

Код
=ЕСЛИОШИБКА(ИНДЕКС(Работа!$B$2:$B$150;НАИМЕНЬШИЙ(ЕСЛИ(Работа!$A$2:$A$150=ЗП!$B$3;СТРОКА(Работа!$A$2:$A$150)-1);СТРОКА(A1)));"")

Автор - китин
Дата добавления - 21.04.2022 в 11:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перебор ячеек в Excel (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!