Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Требуется правка формулы для вычисления средних значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Требуется правка формулы для вычисления средних значений (Формулы/Formulas)
Требуется правка формулы для вычисления средних значений
remis8423 Дата: Среда, 27.04.2022, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Написал формулу для вычисления средних значений из нескольких таблиц. Считает среднее значение, включая нулевые значения... Нужно, чтобы считала без нулевых клеток.

Код
=СРЗНАЧ(ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('110'!B4:AW4;'110'!B4:AW4;"<>0";'110'!$B$3:$AW$3;$B$3);0);ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('61'!B4:AW4;'61'!B4:AW4;"<>0";'61'!$B$3:$AW$3;$B$3);0);ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('62'!B4:AW4;'62'!B4:AW4;"<>0";'62'!$B$3:$AW$3;$B$3);0))


Сообщение отредактировал remis8423 - Среда, 27.04.2022, 16:36
 
Ответить
СообщениеНаписал формулу для вычисления средних значений из нескольких таблиц. Считает среднее значение, включая нулевые значения... Нужно, чтобы считала без нулевых клеток.

Код
=СРЗНАЧ(ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('110'!B4:AW4;'110'!B4:AW4;"<>0";'110'!$B$3:$AW$3;$B$3);0);ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('61'!B4:AW4;'61'!B4:AW4;"<>0";'61'!$B$3:$AW$3;$B$3);0);ЕСЛИОШИБКА(СРЗНАЧЕСЛИМН('62'!B4:AW4;'62'!B4:AW4;"<>0";'62'!$B$3:$AW$3;$B$3);0))

Автор - remis8423
Дата добавления - 27.04.2022 в 16:33
bigor Дата: Среда, 27.04.2022, 17:08 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
Таблица нужна, что бы не гадать где что находится
 
Ответить
СообщениеТаблица нужна, что бы не гадать где что находится

Автор - bigor
Дата добавления - 27.04.2022 в 17:08
remis8423 Дата: Четверг, 28.04.2022, 08:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

Вот таблица
К сообщению приложен файл: 9737230.xlsx(164.8 Kb)
 
Ответить
СообщениеВот таблица

Автор - remis8423
Дата добавления - 28.04.2022 в 08:02
remis8423 Дата: Четверг, 28.04.2022, 09:02 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

bigor, Таблицу выложил, посмотрите пожалуйста.
 
Ответить
Сообщениеbigor, Таблицу выложил, посмотрите пожалуйста.

Автор - remis8423
Дата добавления - 28.04.2022 в 09:02
bigor Дата: Четверг, 28.04.2022, 09:14 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 681
Репутация: 139 ±
Замечаний: 0% ±

нет
Ваша формула считает среднее от средних по каждому листу. Это не тоже что среднее значение по листам.
Предлагаю вариант среднего без учета 0
Код
=(SUMIF($'110'.$B$3:$AW$3;$B$3;$'110'.B4:AW4)+SUMIF($'61'.$B$3:$AW$3;$B$3;$'61'.B4:AW4)+SUMIF($'62'.$B$3:$AW$3;$B$3;$'62'.B4:AW4))/(COUNTIFS($'110'.$B$3:$AW$3;$B$3;$'110'.B4:AW4;">0")+COUNTIFS($'61'.$B$3:$AW$3;$B$3;$'61'.B4:AW4;">0")+COUNTIFS($'62'.$B$3:$AW$3;$B$3;$'62'.B4:AW4;">0"))
К сообщению приложен файл: 9737230_1.xlsx(139.4 Kb)
 
Ответить
СообщениеВаша формула считает среднее от средних по каждому листу. Это не тоже что среднее значение по листам.
Предлагаю вариант среднего без учета 0
Код
=(SUMIF($'110'.$B$3:$AW$3;$B$3;$'110'.B4:AW4)+SUMIF($'61'.$B$3:$AW$3;$B$3;$'61'.B4:AW4)+SUMIF($'62'.$B$3:$AW$3;$B$3;$'62'.B4:AW4))/(COUNTIFS($'110'.$B$3:$AW$3;$B$3;$'110'.B4:AW4;">0")+COUNTIFS($'61'.$B$3:$AW$3;$B$3;$'61'.B4:AW4;">0")+COUNTIFS($'62'.$B$3:$AW$3;$B$3;$'62'.B4:AW4;">0"))

Автор - bigor
Дата добавления - 28.04.2022 в 09:14
remis8423 Дата: Четверг, 28.04.2022, 10:55 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 48
Репутация: 0 ±
Замечаний: 0% ±

bigor, спасибо!


Сообщение отредактировал remis8423 - Четверг, 28.04.2022, 13:11
 
Ответить
Сообщениеbigor, спасибо!

Автор - remis8423
Дата добавления - 28.04.2022 в 10:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Требуется правка формулы для вычисления средних значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!