Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Количество дней помесячно в диапазоне нескольких периодов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество дней помесячно в диапазоне нескольких периодов (Формулы/Formulas)
Количество дней помесячно в диапазоне нескольких периодов
stakhnyuk Дата: Среда, 04.05.2022, 19:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Подскажите, пожалуйста, как можно посчитать количество дней помесячно в диапазоне дат, но только не между двумя датами, а между 4-6 и т.д. + есть еще такой фактор как конечная дата (списание товара).
Смысл следующий - оборудование сдается в аренду, приходит на склад и уходит со склада, а в финале идет списание, необходимо понимать сколько оборудование проводит времени на складе в месяц.
Формулу для расчета между 2 датами нашел, но для полноценной картины, т.е. когда появляются новые даты, а еще и есть финальная дата "списание" этого не хватает.
Прикрепляю файл с примером из чего необходимо произвести расчет и какие условия могут возникнуть.
Расчет необходимо произвести без использования макросов.
Заранее спасибо за ответы!
К сообщению приложен файл: -___.xlsx(18.1 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, как можно посчитать количество дней помесячно в диапазоне дат, но только не между двумя датами, а между 4-6 и т.д. + есть еще такой фактор как конечная дата (списание товара).
Смысл следующий - оборудование сдается в аренду, приходит на склад и уходит со склада, а в финале идет списание, необходимо понимать сколько оборудование проводит времени на складе в месяц.
Формулу для расчета между 2 датами нашел, но для полноценной картины, т.е. когда появляются новые даты, а еще и есть финальная дата "списание" этого не хватает.
Прикрепляю файл с примером из чего необходимо произвести расчет и какие условия могут возникнуть.
Расчет необходимо произвести без использования макросов.
Заранее спасибо за ответы!

Автор - stakhnyuk
Дата добавления - 04.05.2022 в 19:51
Pelena Дата: Среда, 04.05.2022, 22:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18551
Репутация: 4200 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=СУММПРОИЗВ(--ТЕКСТ((КОНМЕСЯЦА(G$2;0)-ТЕКСТ((КОНМЕСЯЦА(G$2;0)-ЕСЛИ(($C3:$E3=0)*($B3:$D3>0);$F3;$C3:$E3));"0;\0")+1)*($C$2:$E$2="Со склада")-(ТЕКСТ(($B3:$D3-G$2);"0;\0")+G$2)*($B$2:$D$2="На склад");"0;\0"))
К сообщению приложен файл: 9339455.xlsx(20.8 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММПРОИЗВ(--ТЕКСТ((КОНМЕСЯЦА(G$2;0)-ТЕКСТ((КОНМЕСЯЦА(G$2;0)-ЕСЛИ(($C3:$E3=0)*($B3:$D3>0);$F3;$C3:$E3));"0;\0")+1)*($C$2:$E$2="Со склада")-(ТЕКСТ(($B3:$D3-G$2);"0;\0")+G$2)*($B$2:$D$2="На склад");"0;\0"))

Автор - Pelena
Дата добавления - 04.05.2022 в 22:05
stakhnyuk Дата: Четверг, 05.05.2022, 21:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое!!!
То что и было необходимо.
В пример не включил случай когда нет даты списания, из этой ситуации вышел подстановкой текущей даты, вдруг кому-то пригодится.
 
Ответить
СообщениеСпасибо большое!!!
То что и было необходимо.
В пример не включил случай когда нет даты списания, из этой ситуации вышел подстановкой текущей даты, вдруг кому-то пригодится.

Автор - stakhnyuk
Дата добавления - 05.05.2022 в 21:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Количество дней помесячно в диапазоне нескольких периодов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!