Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Зависимые от нескольких ячеек выпадающие списки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависимые от нескольких ячеек выпадающие списки (Формулы/Formulas)
Зависимые от нескольких ячеек выпадающие списки
CoreyDoor Дата: Понедельник, 23.05.2022, 17:52 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Пытаюсь создать зависимые выпадающие списки для того, чтобы конечный клиент мог выбрать только доступные значения. Значения должны зависеть друг от друга и исключать возможность выбора позиции, неодоступных для того или иного значения. Изначально идеей было сделать подобное с помощью формулы =двссыл и диспетчера имён. Но по ходу решения поставленной задачи столкнулся с проблемой большого количества данных и необходимостью автоматизации процесса создания новых имён. Часть данных отображена на Листе1.
У меня вообще нет идей как автоматически проставить имена, поэтому нужно либо изменить изначальную формулу или подход к созданию списков, вообще. Мне нужен толчок в правильную сторону.
P.s. Также пытался решить проблему в другом файле с помощью формулы
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D6:D8;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D15:D25;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D27:D85;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D88:D99;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D101:D111;0));0;RX!E105:E108));RX!E90:E99));RX!E47:E57));RX!E18:E22));RX!E2:E13)
, что казалось мне гениальным, но столкнулся с проблемой ограничения символов в проверке вводимых значений.
P.s.s. Если количество данных небольшое, по сравнению с другими, то называйте меня хлюпиком и гоните, но помогите с файлом, пожалуйста.
P.s.s.s. Формулы справа на главном листе сами превратились в массив после обновления администратором, но это отдельная тема для обсуждения. Если знаете как мне с этим помочь ответьте сюда, пожалуйста: http://www.excelworld.ru/forum/2-49901-1
К сообщению приложен файл: ____v2_.xlsx(37.0 Kb)


Сообщение отредактировал Serge_007 - Понедельник, 23.05.2022, 17:57
 
Ответить
СообщениеДобрый день!
Пытаюсь создать зависимые выпадающие списки для того, чтобы конечный клиент мог выбрать только доступные значения. Значения должны зависеть друг от друга и исключать возможность выбора позиции, неодоступных для того или иного значения. Изначально идеей было сделать подобное с помощью формулы =двссыл и диспетчера имён. Но по ходу решения поставленной задачи столкнулся с проблемой большого количества данных и необходимостью автоматизации процесса создания новых имён. Часть данных отображена на Листе1.
У меня вообще нет идей как автоматически проставить имена, поэтому нужно либо изменить изначальную формулу или подход к созданию списков, вообще. Мне нужен толчок в правильную сторону.
P.s. Также пытался решить проблему в другом файле с помощью формулы
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D6:D8;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D15:D25;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D27:D85;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D88:D99;0));(ЕСЛИ(ЕНД(ПОИСКПОЗ(A14&C14;RX!D101:D111;0));0;RX!E105:E108));RX!E90:E99));RX!E47:E57));RX!E18:E22));RX!E2:E13)
, что казалось мне гениальным, но столкнулся с проблемой ограничения символов в проверке вводимых значений.
P.s.s. Если количество данных небольшое, по сравнению с другими, то называйте меня хлюпиком и гоните, но помогите с файлом, пожалуйста.
P.s.s.s. Формулы справа на главном листе сами превратились в массив после обновления администратором, но это отдельная тема для обсуждения. Если знаете как мне с этим помочь ответьте сюда, пожалуйста: http://www.excelworld.ru/forum/2-49901-1

Автор - CoreyDoor
Дата добавления - 23.05.2022 в 17:52
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Зависимые от нескольких ячеек выпадающие списки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!