Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка данных с диапазона ячеек по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных с диапазона ячеек по условию (Формулы/Formulas)
Выборка данных с диапазона ячеек по условию
Yurio22 Дата: Среда, 25.05.2022, 17:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 20% ±

Excel 2016
Есть таблица с овощами, каждый день используется 3 вида овощей. Нужно перенести выбранные название овощей в отдельные ячейки
К сообщению приложен файл: 3009836.xlsx(9.7 Kb)


Сообщение отредактировал Yurio22 - Среда, 25.05.2022, 17:24
 
Ответить
СообщениеЕсть таблица с овощами, каждый день используется 3 вида овощей. Нужно перенести выбранные название овощей в отдельные ячейки

Автор - Yurio22
Дата добавления - 25.05.2022 в 17:17
Nic70y Дата: Среда, 25.05.2022, 17:24 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7745
Репутация: 1858 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(C$2:J$2;ПОИСКПОЗ("+";C3:J3;))
Код
=ИНДЕКС($C$2:$J$2;ПОИСКПОЗ("+";ИНДЕКС($C3:$J3;ПОИСКПОЗ(K3;$C$2:$J$2;)+1):J3;)+ПОИСКПОЗ(K3;$C$2:$J$2;))
К сообщению приложен файл: 2896611.xlsx(10.4 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(C$2:J$2;ПОИСКПОЗ("+";C3:J3;))
Код
=ИНДЕКС($C$2:$J$2;ПОИСКПОЗ("+";ИНДЕКС($C3:$J3;ПОИСКПОЗ(K3;$C$2:$J$2;)+1):J3;)+ПОИСКПОЗ(K3;$C$2:$J$2;))

Автор - Nic70y
Дата добавления - 25.05.2022 в 17:24
_Boroda_ Дата: Среда, 25.05.2022, 17:30 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16373
Репутация: 6355 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС($C$2:$J$2;ПОИСКПОЗ(НАИМЕНЬШИЙ($C3:$J3;K$2);$C3:$J3;))

Не, так не покатит
Вот так
Код
=ИНДЕКС($A$2:$J$2;НАИБОЛЬШИЙ(($C3:$J3>0)*СТОЛБЕЦ($C:$J);K$2))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер
К сообщению приложен файл: 3009836_2.xlsx(10.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Среда, 25.05.2022, 17:35
 
Ответить
Сообщение
Код
=ИНДЕКС($C$2:$J$2;ПОИСКПОЗ(НАИМЕНЬШИЙ($C3:$J3;K$2);$C3:$J3;))

Не, так не покатит
Вот так
Код
=ИНДЕКС($A$2:$J$2;НАИБОЛЬШИЙ(($C3:$J3>0)*СТОЛБЕЦ($C:$J);K$2))

Формула массива. Вводится одновременным нажатием Контрл Шифт Ентер

Автор - _Boroda_
Дата добавления - 25.05.2022 в 17:30
Egyptian Дата: Среда, 25.05.2022, 18:50 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 395
Репутация: 134 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=INDEX($C$2:$J$2;AGGREGATE(15;6;(COLUMN($C2:$J2)-COLUMN($C2)+1)/(ISNUMBER($C3:$J3));K$2))

И я так понимаю, в пятой строке, в столбце К вместо патиссона должен быть перец?
К сообщению приложен файл: 2667503.xlsx(10.5 Kb)
 
Ответить
СообщениеВариант.
Код
=INDEX($C$2:$J$2;AGGREGATE(15;6;(COLUMN($C2:$J2)-COLUMN($C2)+1)/(ISNUMBER($C3:$J3));K$2))

И я так понимаю, в пятой строке, в столбце К вместо патиссона должен быть перец?

Автор - Egyptian
Дата добавления - 25.05.2022 в 18:50
msi2102 Дата: Среда, 25.05.2022, 19:19 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 205
Репутация: 79 ±
Замечаний: 0% ±

Excel 2007
Если офис 2019 и выше то можно так:
в ячейку K3, и протянуть вниз
Код
=ФИЛЬТР($C$2:$J$2;C3:J3)
К сообщению приложен файл: 3452811.xlsx(11.2 Kb)


Сообщение отредактировал msi2102 - Среда, 25.05.2022, 19:19
 
Ответить
СообщениеЕсли офис 2019 и выше то можно так:
в ячейку K3, и протянуть вниз
Код
=ФИЛЬТР($C$2:$J$2;C3:J3)

Автор - msi2102
Дата добавления - 25.05.2022 в 19:19
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка данных с диапазона ячеек по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!