Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчитать количество ячеек с одинаковым текстом - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать количество ячеек с одинаковым текстом (Формулы/Formulas)
Подсчитать количество ячеек с одинаковым текстом
R3ACT4 Дата: Четверг, 02.06.2022, 08:47 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток всем. Дана таблица следующего вида (см. файл "пример"). В общей сумме необходимо объединить две такие таблицы(от разных аналитических программ) в одну, дабы сравнить совпадают ли данные по "Магазинам" в этих двух таблицах. Но для начала достаточно будет просто вывести в отдельный столбец количество "контрактов" по каждому "магазину" и общую сумму каждого магазина.
К сообщению приложен файл: 1979675.xlsx(8.8 Kb)
 
Ответить
СообщениеДоброго времени суток всем. Дана таблица следующего вида (см. файл "пример"). В общей сумме необходимо объединить две такие таблицы(от разных аналитических программ) в одну, дабы сравнить совпадают ли данные по "Магазинам" в этих двух таблицах. Но для начала достаточно будет просто вывести в отдельный столбец количество "контрактов" по каждому "магазину" и общую сумму каждого магазина.

Автор - R3ACT4
Дата добавления - 02.06.2022 в 08:47
and_evg Дата: Четверг, 02.06.2022, 09:23 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 410
Репутация: 71 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
Вариант сводной таблицей
К сообщению приложен файл: 8653754.xlsx(12.1 Kb)
 
Ответить
СообщениеДобрый день.
Вариант сводной таблицей

Автор - and_evg
Дата добавления - 02.06.2022 в 09:23
DrMini Дата: Четверг, 02.06.2022, 09:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
R3ACT4,
Может так?
Код
=СУММЕСЛИ($A$2:$A$11;D2;$B$2:$B$11)
К сообщению приложен файл: 3174789.xlsx(9.4 Kb)
 
Ответить
СообщениеR3ACT4,
Может так?
Код
=СУММЕСЛИ($A$2:$A$11;D2;$B$2:$B$11)

Автор - DrMini
Дата добавления - 02.06.2022 в 09:25
bigor Дата: Четверг, 02.06.2022, 09:27 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 144 ±
Замечаний: 0% ±

нет
Еще вариант формулой
выбираем уникальные
Код
=IFERROR(INDEX($A$2:$A$17;AGGREGATE(15;6;(ROW($A$2:$A$17)-1)/(MATCH($A$2:$A$17;$A$2:$A$17;0)=ROW($A$2:$A$17)-ROW($A$2)+1);ROWS($B$2:$B2)));"")

считаем сумму
Код
=SUMIF($A$2:$A$11;$D2;$B$2:$B$11)
К сообщению приложен файл: 1979675_1.xlsx(5.8 Kb)
 
Ответить
СообщениеЕще вариант формулой
выбираем уникальные
Код
=IFERROR(INDEX($A$2:$A$17;AGGREGATE(15;6;(ROW($A$2:$A$17)-1)/(MATCH($A$2:$A$17;$A$2:$A$17;0)=ROW($A$2:$A$17)-ROW($A$2)+1);ROWS($B$2:$B2)));"")

считаем сумму
Код
=SUMIF($A$2:$A$11;$D2;$B$2:$B$11)

Автор - bigor
Дата добавления - 02.06.2022 в 09:27
R3ACT4 Дата: Четверг, 02.06.2022, 10:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

DrMini, я так и сделал, но надо еще рядом добавить строку с количеством контрактов для каждого магазина.
 
Ответить
СообщениеDrMini, я так и сделал, но надо еще рядом добавить строку с количеством контрактов для каждого магазина.

Автор - R3ACT4
Дата добавления - 02.06.2022 в 10:22
R3ACT4 Дата: Четверг, 02.06.2022, 10:24 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

and_evg, идеальный вариант, хотело бы поподробнее узнать как Вы это осуществили.
 
Ответить
Сообщениеand_evg, идеальный вариант, хотело бы поподробнее узнать как Вы это осуществили.

Автор - R3ACT4
Дата добавления - 02.06.2022 в 10:24
китин Дата: Четверг, 02.06.2022, 10:47 | Сообщение № 7
Группа: Модераторы
Ранг: Экселист
Сообщений: 6907
Репутация: 1057 ±
Замечаний: 0% ±

Excel 2007;2010;2016
PQ всемогущий
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Сгруппированные строки" = Table.Group(Источник, {"НАИМЕНОВАНИЕ ОРГАНИЗАЦИИ"}, {{"Количество", each Table.RowCount(_), type number}, {"Сумма контракта", each List.Sum([#"ЦЕНА КОНТРАКТА "]), type number}})
in
    #"Сгруппированные строки"
[/vba]
К сообщению приложен файл: 4466891.xlsx(16.9 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеPQ всемогущий
[vba]
Код
let
    Источник = Excel.CurrentWorkbook(){[Name="Таблица1"]}[Content],
    #"Сгруппированные строки" = Table.Group(Источник, {"НАИМЕНОВАНИЕ ОРГАНИЗАЦИИ"}, {{"Количество", each Table.RowCount(_), type number}, {"Сумма контракта", each List.Sum([#"ЦЕНА КОНТРАКТА "]), type number}})
in
    #"Сгруппированные строки"
[/vba]

Автор - китин
Дата добавления - 02.06.2022 в 10:47
DrMini Дата: Четверг, 02.06.2022, 11:01 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
надо еще рядом добавить строку с количеством контрактов для каждого магазина.

Может так?
Код
=СЧЁТЕСЛИ($A$2:$A$11;D2)
К сообщению приложен файл: 8441933.xlsx(9.5 Kb)
 
Ответить
Сообщение
надо еще рядом добавить строку с количеством контрактов для каждого магазина.

Может так?
Код
=СЧЁТЕСЛИ($A$2:$A$11;D2)

Автор - DrMini
Дата добавления - 02.06.2022 в 11:01
R3ACT4 Дата: Четверг, 02.06.2022, 11:09 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

DrMini, хороший вариант для 10-15 позиций) Но у меня там где-то 15 контрактов от одного поставщика, где то 2, а всего их 5000. Боюсь устану выделять фрагменты таблицы, разобрался с вариантов сводной таблицы.
 
Ответить
СообщениеDrMini, хороший вариант для 10-15 позиций) Но у меня там где-то 15 контрактов от одного поставщика, где то 2, а всего их 5000. Боюсь устану выделять фрагменты таблицы, разобрался с вариантов сводной таблицы.

Автор - R3ACT4
Дата добавления - 02.06.2022 в 11:09
DrMini Дата: Четверг, 02.06.2022, 14:03 | Сообщение № 10
Группа: Проверенные
Ранг: Ветеран
Сообщений: 883
Репутация: 71 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Боюсь устану выделять фрагменты таблицы

А если вот так сделать:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$5000; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($D$1:D1; $A$2:$A$5000); 0; 0); 0)); "")

Код
=СУММЕСЛИ($A$2:$A$5000;D2;$B$2:$B$5000)

Код
=СЧЁТЕСЛИ($A$2:$A$5000;D2)

[p.s.]в примере сделал до 20 строк[/p.s.]
К сообщению приложен файл: 3462821.xlsx(9.8 Kb)
 
Ответить
Сообщение
Боюсь устану выделять фрагменты таблицы

А если вот так сделать:
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$5000; ПОИСКПОЗ(0; ИНДЕКС(СЧЁТЕСЛИ($D$1:D1; $A$2:$A$5000); 0; 0); 0)); "")

Код
=СУММЕСЛИ($A$2:$A$5000;D2;$B$2:$B$5000)

Код
=СЧЁТЕСЛИ($A$2:$A$5000;D2)

[p.s.]в примере сделал до 20 строк[/p.s.]

Автор - DrMini
Дата добавления - 02.06.2022 в 14:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчитать количество ячеек с одинаковым текстом (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!