Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка дат по критерию из определенного диапазона - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка дат по критерию из определенного диапазона (Формулы/Formulas)
Выборка дат по критерию из определенного диапазона
ponomortema Дата: Пятница, 03.06.2022, 09:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день уважаемые! Столкнулся с одной проблемкой. Есть массив данных (точка отбора, дата и некоторые полученные значения к ним (замеров в реальности очень много)), не могу написать нормальную формулу чтобы она выбирала только те даты для соответствующей точки, что указаны в диапазоне. Сейчас она выбирает в принципе все даты, что есть. Все пояснения есть в файле) Заранее благодарю за помощь)
К сообщению приложен файл: 5607404.xlsx(18.9 Kb)
 
Ответить
СообщениеДобрый день уважаемые! Столкнулся с одной проблемкой. Есть массив данных (точка отбора, дата и некоторые полученные значения к ним (замеров в реальности очень много)), не могу написать нормальную формулу чтобы она выбирала только те даты для соответствующей точки, что указаны в диапазоне. Сейчас она выбирает в принципе все даты, что есть. Все пояснения есть в файле) Заранее благодарю за помощь)

Автор - ponomortema
Дата добавления - 03.06.2022 в 09:57
_Boroda_ Дата: Пятница, 03.06.2022, 10:59 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16212
Репутация: 6296 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=ИНДЕКС($C$5:$C$30;ПОИСКПОЗ(;ЕСЛИ((O$7=$B$5:$B$30)*($C$5:$C$30<=$M$5)*($C$5:$C$30>=$M$4);СЧЁТЕСЛИ(O$8:O8;$C$5:$C$30));))
К сообщению приложен файл: 5607404_1.xlsx(19.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=ИНДЕКС($C$5:$C$30;ПОИСКПОЗ(;ЕСЛИ((O$7=$B$5:$B$30)*($C$5:$C$30<=$M$5)*($C$5:$C$30>=$M$4);СЧЁТЕСЛИ(O$8:O8;$C$5:$C$30));))

Автор - _Boroda_
Дата добавления - 03.06.2022 в 10:59
ponomortema Дата: Пятница, 03.06.2022, 13:26 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Огромное спасибо , все работает!
 
Ответить
СообщениеОгромное спасибо , все работает!

Автор - ponomortema
Дата добавления - 03.06.2022 в 13:26
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка дат по критерию из определенного диапазона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!