Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка таблицы по двум столбцам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка таблицы по двум столбцам (Формулы/Formulas)
Сортировка таблицы по двум столбцам
Kvazar Дата: Понедельник, 20.06.2022, 12:25 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня.
Столкнулся с проблемой сортировки таблицы, изучение материала не помогло, что то упускаю.

Суть проблемы.
В наличии таблица объектов с установленным на них оборудовании.
В столбце "F" указан год поверки оборуд

Мне необходимо отсортировать таблицу так чтобы отображались только те адреса на которых есть поверка в 2022 году (значение в столбце "F" = 2022) хотя бы для одного оборудования , при этом должно отображаться все оборудование на каждом адресе даже те у которых значение в столбце "F" отсутствует.
К сообщению приложен файл: 2917614.xls(33.5 Kb)
 
Ответить
СообщениеДоброго дня.
Столкнулся с проблемой сортировки таблицы, изучение материала не помогло, что то упускаю.

Суть проблемы.
В наличии таблица объектов с установленным на них оборудовании.
В столбце "F" указан год поверки оборуд

Мне необходимо отсортировать таблицу так чтобы отображались только те адреса на которых есть поверка в 2022 году (значение в столбце "F" = 2022) хотя бы для одного оборудования , при этом должно отображаться все оборудование на каждом адресе даже те у которых значение в столбце "F" отсутствует.

Автор - Kvazar
Дата добавления - 20.06.2022 в 12:25
_Boroda_ Дата: Понедельник, 20.06.2022, 12:38 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16306
Репутация: 6328 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Отсортировать или отфильтровать?
В допстолбец формулу
Код
=СЧЁТЕСЛИМН(C$2:C$69;C2;F$2:F$69;2022)>0

bkb
Код
=СУММПРОИЗВ((C$2:C$69=C2)*(F$2:F$69=2022))>0

И фильтруйте по ИСТИНА
К сообщению приложен файл: 2917614_1.xls(39.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОтсортировать или отфильтровать?
В допстолбец формулу
Код
=СЧЁТЕСЛИМН(C$2:C$69;C2;F$2:F$69;2022)>0

bkb
Код
=СУММПРОИЗВ((C$2:C$69=C2)*(F$2:F$69=2022))>0

И фильтруйте по ИСТИНА

Автор - _Boroda_
Дата добавления - 20.06.2022 в 12:38
Kvazar Дата: Вторник, 21.06.2022, 04:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо за ответ.
Не совсем то получилось.

Да, нужна фильтрация одновременно по столбцам "В" и "F",
условия:
1. Если для определенного адреса в столбце "В" есть значение 2022 в столбце "F" - эта строка отображается (это просто, обычный фильтр по 2022);
2. Также должны отобразиться все строки в таблице со значением этого адреса даже если в столбце "F" пусто. Проблема в этом пункте..

Т.е. в примере (в прикрепленной таблице) должны скрыться только строки выделенные зеленым.
К сообщению приложен файл: 1037107.xls(38.0 Kb)
 
Ответить
СообщениеСпасибо за ответ.
Не совсем то получилось.

Да, нужна фильтрация одновременно по столбцам "В" и "F",
условия:
1. Если для определенного адреса в столбце "В" есть значение 2022 в столбце "F" - эта строка отображается (это просто, обычный фильтр по 2022);
2. Также должны отобразиться все строки в таблице со значением этого адреса даже если в столбце "F" пусто. Проблема в этом пункте..

Т.е. в примере (в прикрепленной таблице) должны скрыться только строки выделенные зеленым.

Автор - Kvazar
Дата добавления - 21.06.2022 в 04:57
_Boroda_ Дата: Вторник, 21.06.2022, 10:14 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16306
Репутация: 6328 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СЧЁТЕСЛИМН(B$2:B$69;B2;F$2:F$69;2022)>0

Я по оборудованию сделал. А Вам по адресам нужно. Ну переписали бы диапазоны в формуле
К сообщению приложен файл: 1037107_1.xls(41.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИМН(B$2:B$69;B2;F$2:F$69;2022)>0

Я по оборудованию сделал. А Вам по адресам нужно. Ну переписали бы диапазоны в формуле

Автор - _Boroda_
Дата добавления - 21.06.2022 в 10:14
Kvazar Дата: Среда, 22.06.2022, 07:00 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое.

Разобрался в работе формулы. Это то что нужно.
Никогда бы не додумался использовать эту формулу)).
 
Ответить
СообщениеСпасибо большое.

Разобрался в работе формулы. Это то что нужно.
Никогда бы не додумался использовать эту формулу)).

Автор - Kvazar
Дата добавления - 22.06.2022 в 07:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка таблицы по двум столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!