Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в строке 3-го или 5-го значения "с конца" - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в строке 3-го или 5-го значения "с конца" (Формулы/Formulas)
Поиск в строке 3-го или 5-го значения "с конца"
mkotik Дата: Пятница, 24.06.2022, 00:59 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, Уважаемые Знатоки!
Есть строка данных, в которой может быть текст и нулевые значения.
Столкнулся с проблемой поиска в строке n-последних значений, не равных 0 или тексту.
Если с последним значением в строке решений на форуме много, то, например, с 3-им или 5-ым значением "с конца" решений не нашёл.
Может кто-нибудь сталкивался с таким вопросом?
Файл приложил.
Заранее благодарен за ответ!
С Уважением, Игорь
К сообщению приложен файл: ____.xlsx(10.5 Kb)


Сообщение отредактировал mkotik - Пятница, 24.06.2022, 01:06
 
Ответить
СообщениеДобрый вечер, Уважаемые Знатоки!
Есть строка данных, в которой может быть текст и нулевые значения.
Столкнулся с проблемой поиска в строке n-последних значений, не равных 0 или тексту.
Если с последним значением в строке решений на форуме много, то, например, с 3-им или 5-ым значением "с конца" решений не нашёл.
Может кто-нибудь сталкивался с таким вопросом?
Файл приложил.
Заранее благодарен за ответ!
С Уважением, Игорь

Автор - mkotik
Дата добавления - 24.06.2022 в 00:59
Egyptian Дата: Пятница, 24.06.2022, 02:24 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 425
Репутация: 140 ±
Замечаний: 0% ±

Excel 2013/2016
mkotik, С небольшими правками вашей же формулы:
Код
=INDEX(A3:L3;LARGE(IF(ISNUMBER(A3:L3)*(A3:L3>0);COLUMN(A3:L3));2))

Ну и еще вариант. Меняете в конце единицу на нужное значение.
Код
=INDEX(A2:L2;AGGREGATE(14;6;COLUMN(A2:L2)*A2:L2/A2:L2;1))
К сообщению приложен файл: 6054957.xlsx(10.6 Kb)


Сообщение отредактировал Egyptian - Пятница, 24.06.2022, 02:38
 
Ответить
Сообщениеmkotik, С небольшими правками вашей же формулы:
Код
=INDEX(A3:L3;LARGE(IF(ISNUMBER(A3:L3)*(A3:L3>0);COLUMN(A3:L3));2))

Ну и еще вариант. Меняете в конце единицу на нужное значение.
Код
=INDEX(A2:L2;AGGREGATE(14;6;COLUMN(A2:L2)*A2:L2/A2:L2;1))

Автор - Egyptian
Дата добавления - 24.06.2022 в 02:24
mkotik Дата: Пятница, 24.06.2022, 11:24 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 178
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Egyptian, спасибо Большое и доброго дня!
 
Ответить
СообщениеEgyptian, спасибо Большое и доброго дня!

Автор - mkotik
Дата добавления - 24.06.2022 в 11:24
scriptapplications Дата: Пятница, 24.06.2022, 12:39 | Сообщение № 4
Группа: Проверенные
Ранг: Участник
Сообщений: 64
Репутация: 12 ±
Замечаний: 0% ±

mkotik, нет смысла делать разные формулы для разных строчек одного столбца, это может быть источником ошибок,(например, добавление строки перед первой строкой потребует переписать формулы всего столбца), лучше растянуть одну.
Если число может быть и отрицательным формула для строки 2
Код
=ИНДЕКС(A2:L2;НАИБОЛЬШИЙ(ЕСЛИ(ЕЧИСЛО(A2:L2)*(A2:L2<>0);СТОЛБЕЦ(A2:L2));СТРОКА()-СТРОКА($A$2)+1))

Затем растягивается до конца таблицы


Сообщение отредактировал scriptapplications - Пятница, 24.06.2022, 12:51
 
Ответить
Сообщениеmkotik, нет смысла делать разные формулы для разных строчек одного столбца, это может быть источником ошибок,(например, добавление строки перед первой строкой потребует переписать формулы всего столбца), лучше растянуть одну.
Если число может быть и отрицательным формула для строки 2
Код
=ИНДЕКС(A2:L2;НАИБОЛЬШИЙ(ЕСЛИ(ЕЧИСЛО(A2:L2)*(A2:L2<>0);СТОЛБЕЦ(A2:L2));СТРОКА()-СТРОКА($A$2)+1))

Затем растягивается до конца таблицы

Автор - scriptapplications
Дата добавления - 24.06.2022 в 12:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в строке 3-го или 5-го значения "с конца" (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!