Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос данных на другую страницу начинающихся на букве - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на другую страницу начинающихся на букве (Формулы/Formulas)
Перенос данных на другую страницу начинающихся на букве
Glasees Дата: Среда, 29.06.2022, 05:08 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Есть файл. На 1 листе таблица, которая будет обновляться. потом идут листы с именами.
В эти листы надо переносить данные с таблицы, начинающиеся на начальную букву Имени.
Подскажите как это записать в формуле
К сообщению приложен файл: 12.xlsx(18.9 Kb)
 
Ответить
СообщениеДобрый день. Есть файл. На 1 листе таблица, которая будет обновляться. потом идут листы с именами.
В эти листы надо переносить данные с таблицы, начинающиеся на начальную букву Имени.
Подскажите как это записать в формуле

Автор - Glasees
Дата добавления - 29.06.2022 в 05:08
Serge_007 Дата: Среда, 29.06.2022, 12:40 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15298
Репутация: 2518 ±
Замечаний: ±

Excel 2016
Здравствуйте

ереносить данные с таблицы, начинающиеся на начальную букву Имени
Например имена Анфиса и Анастасия на одну и ту же букву начинаются
Как быть в этом случае?


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

ереносить данные с таблицы, начинающиеся на начальную букву Имени
Например имена Анфиса и Анастасия на одну и ту же букву начинаются
Как быть в этом случае?

Автор - Serge_007
Дата добавления - 29.06.2022 в 12:40
scriptapplications Дата: Среда, 29.06.2022, 18:58 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 7 ±
Замечаний: 0% ±

Glasees, для листа на букву A (третий символ от начала строки) :
Код
=ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;3;1)="А";СТРОКА(Лист1!B:B);СЧЁТЗ(Лист1!B:B)+1);СТРОКА()-СТРОКА($B$2)+1))

Для ускорения расчёта вместо B:B лучше задать реальный диапазон
Для других листов "A" надо заменить на первую букву имени
К сообщению приложен файл: 12_1.xlsx(21.6 Kb)


Сообщение отредактировал scriptapplications - Среда, 29.06.2022, 19:01
 
Ответить
СообщениеGlasees, для листа на букву A (третий символ от начала строки) :
Код
=ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;3;1)="А";СТРОКА(Лист1!B:B);СЧЁТЗ(Лист1!B:B)+1);СТРОКА()-СТРОКА($B$2)+1))

Для ускорения расчёта вместо B:B лучше задать реальный диапазон
Для других листов "A" надо заменить на первую букву имени

Автор - scriptapplications
Дата добавления - 29.06.2022 в 18:58
Glasees Дата: Пятница, 01.07.2022, 00:51 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Цитата scriptapplications, 29.06.2022 в 18:58, в сообщении № 3 ()
Для ускорения расчёта вместо B:B лучше задать реальный диапазон


Добрый вечер, не работает формула. пробовала менять букву.
Файл немного поправила. формулу поменяла. но результата нет
К сообщению приложен файл: 12.xlsm(24.1 Kb)
 
Ответить
Сообщение
Цитата scriptapplications, 29.06.2022 в 18:58, в сообщении № 3 ()
Для ускорения расчёта вместо B:B лучше задать реальный диапазон


Добрый вечер, не работает формула. пробовала менять букву.
Файл немного поправила. формулу поменяла. но результата нет

Автор - Glasees
Дата добавления - 01.07.2022 в 00:51
scriptapplications Дата: Пятница, 01.07.2022, 16:35 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 7 ±
Замечаний: 0% ±

Glasees, уберите из формулы знаки "@"
Должно быть так:
Код
=ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;3;1)="А";СТРОКА(Лист1!B:B);СЧЁТЗ(Лист1!B:B)+100);СТРОКА()-СТРОКА($B$2)+1))

Или так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;2;1)="А";СТРОКА(Лист1!B:B);10^8);СТРОКА()-СТРОКА($B$2)+1));"---")
К сообщению приложен файл: 12_2.xlsm(27.1 Kb)


Сообщение отредактировал scriptapplications - Пятница, 01.07.2022, 23:23
 
Ответить
СообщениеGlasees, уберите из формулы знаки "@"
Должно быть так:
Код
=ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;3;1)="А";СТРОКА(Лист1!B:B);СЧЁТЗ(Лист1!B:B)+100);СТРОКА()-СТРОКА($B$2)+1))

Или так
Код
=ЕСЛИОШИБКА(ИНДЕКС(Лист1!B:$B;НАИМЕНЬШИЙ(ЕСЛИ(ПСТР(Лист1!B:B;2;1)="А";СТРОКА(Лист1!B:B);10^8);СТРОКА()-СТРОКА($B$2)+1));"---")

Автор - scriptapplications
Дата добавления - 01.07.2022 в 16:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос данных на другую страницу начинающихся на букве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!