Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение данных с разных листов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение данных с разных листов (Формулы/Formulas)
Автозаполнение данных с разных листов
snogin Дата: Среда, 29.06.2022, 13:43 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Прошу помочь с формулой с автозаполнениями данных (файл исходный во вложении):
есть общий список ФИО (их будет много) и колонки с 4 зачетами
- на втором листе общий список ФИО (их тоже много) и результаты в % по пройденным зачетам.

Необходимо чтобы данные со второго листа (с % по прохождению зачетов) подтягивались на первый лист.
Данные по зачетам со второго листа могут отсутствовать по конкретному ФИО или зачету - в этом случае в соответствующей ячейке на первом листе ничего не должно отображаться.
К сообщению приложен файл: 3232803.xlsx(16.1 Kb)
 
Ответить
СообщениеПрошу помочь с формулой с автозаполнениями данных (файл исходный во вложении):
есть общий список ФИО (их будет много) и колонки с 4 зачетами
- на втором листе общий список ФИО (их тоже много) и результаты в % по пройденным зачетам.

Необходимо чтобы данные со второго листа (с % по прохождению зачетов) подтягивались на первый лист.
Данные по зачетам со второго листа могут отсутствовать по конкретному ФИО или зачету - в этом случае в соответствующей ячейке на первом листе ничего не должно отображаться.

Автор - snogin
Дата добавления - 29.06.2022 в 13:43
_Boroda_ Дата: Среда, 29.06.2022, 14:15 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16306
Репутация: 6328 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(Лист1!$C$2:$C$999;Лист1!$A$2:$A$999;$A2;Лист1!$B$2:$B$999;"*"&ПСТР(B$1;7;99))
К сообщению приложен файл: 3232803_1.xlsx(10.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(Лист1!$C$2:$C$999;Лист1!$A$2:$A$999;$A2;Лист1!$B$2:$B$999;"*"&ПСТР(B$1;7;99))

Автор - _Boroda_
Дата добавления - 29.06.2022 в 14:15
snogin Дата: Среда, 29.06.2022, 18:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, а как можно сделать, чтобы отображалось не 0% (если нет данных на листе), а была пустая ячейка?
 
Ответить
Сообщение_Boroda_, а как можно сделать, чтобы отображалось не 0% (если нет данных на листе), а была пустая ячейка?

Автор - snogin
Дата добавления - 29.06.2022 в 18:02
bigor Дата: Четверг, 30.06.2022, 08:57 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 670
Репутация: 136 ±
Замечаний: 0% ±

нет
а была пустая ячейка?

Код
=IFERROR(1/(1/SUMIFS($Лист1.$C$2:$C$999;$Лист1.$A$2:$A$999;$A3;$Лист1.$B$2:$B$999;"*"&MID(F$1;7;99)));"")
:)
 
Ответить
Сообщение
а была пустая ячейка?

Код
=IFERROR(1/(1/SUMIFS($Лист1.$C$2:$C$999;$Лист1.$A$2:$A$999;$A3;$Лист1.$B$2:$B$999;"*"&MID(F$1;7;99)));"")
:)

Автор - bigor
Дата добавления - 30.06.2022 в 08:57
_Boroda_ Дата: Четверг, 30.06.2022, 09:16 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16306
Репутация: 6328 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Зачем же так жестоко? :D
Поставьте формат ячеек
0%;;
К сообщению приложен файл: 3232803_2.xlsx(11.9 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЗачем же так жестоко? :D
Поставьте формат ячеек
0%;;

Автор - _Boroda_
Дата добавления - 30.06.2022 в 09:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение данных с разных листов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!