Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формулыСУММЕСЛИМН и МАКСЕСЛИ в Excel в старых версиях с ЕСЛИ - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формулыСУММЕСЛИМН и МАКСЕСЛИ в Excel в старых версиях с ЕСЛИ (Формулы/Formulas)
формулыСУММЕСЛИМН и МАКСЕСЛИ в Excel в старых версиях с ЕСЛИ
prettyodd Дата: Среда, 13.07.2022, 10:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Добрый день!
Прошу помощи, не работают две формулы в старой версии Excel:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B16:F16;"Не обнаружено")=5;"Не обнаружено";СУММЕСЛИМН(B16:F16;B16:F16;">=0,05"))
– в графе «Сумма примесей» ячейка G16, и
Код
=ЕСЛИ(СЧЁТЕСЛИ(D16:F16;"Не обнаружено")=3;"Не обнаружено";МАКСЕСЛИ(D16:F16;D16:F16;">=0,05"))
– в графе «Максимальная ЕНП» ячейка H16 ,
я специально приложила заполненную таблицу в Excel ( во вложении).
Помогите пожалуйста, решить проблему, чтобы формула была рабочая.
К сообщению приложен файл: __.xlsx(12.6 Kb)


Сообщение отредактировал Serge_007 - Среда, 13.07.2022, 10:55
 
Ответить
СообщениеДобрый день!
Прошу помощи, не работают две формулы в старой версии Excel:
Код
=ЕСЛИ(СЧЁТЕСЛИ(B16:F16;"Не обнаружено")=5;"Не обнаружено";СУММЕСЛИМН(B16:F16;B16:F16;">=0,05"))
– в графе «Сумма примесей» ячейка G16, и
Код
=ЕСЛИ(СЧЁТЕСЛИ(D16:F16;"Не обнаружено")=3;"Не обнаружено";МАКСЕСЛИ(D16:F16;D16:F16;">=0,05"))
– в графе «Максимальная ЕНП» ячейка H16 ,
я специально приложила заполненную таблицу в Excel ( во вложении).
Помогите пожалуйста, решить проблему, чтобы формула была рабочая.

Автор - prettyodd
Дата добавления - 13.07.2022 в 10:54
Nic70y Дата: Среда, 13.07.2022, 11:15 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7725
Репутация: 1853 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(СЧЁТЕСЛИ(B16:F16;"Не обнаружено")=5;"Не обнаружено";СУММЕСЛИ(B16:F16;">=0,05"))
Код
=ЕСЛИ(СЧЁТЕСЛИ(D16:F16;"Не обнаружено")=3;"Не обнаружено";ЕСЛИ(МАКС(D16:F16)>=0,05;МАКС(D16:F16);0))


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(СЧЁТЕСЛИ(B16:F16;"Не обнаружено")=5;"Не обнаружено";СУММЕСЛИ(B16:F16;">=0,05"))
Код
=ЕСЛИ(СЧЁТЕСЛИ(D16:F16;"Не обнаружено")=3;"Не обнаружено";ЕСЛИ(МАКС(D16:F16)>=0,05;МАКС(D16:F16);0))

Автор - Nic70y
Дата добавления - 13.07.2022 в 11:15
prettyodd Дата: Пятница, 15.07.2022, 21:07 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Спасибо большое, только почему-то первая формула все равно не работает.
 
Ответить
СообщениеСпасибо большое, только почему-то первая формула все равно не работает.

Автор - prettyodd
Дата добавления - 15.07.2022 в 21:07
Gustav Дата: Пятница, 15.07.2022, 22:03 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2136
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
А если такую первую попробовать?
Код
=ЕСЛИ(СУММ(ЕСЛИ(B16:F16="Не обнаружено";1))=5;"Не обнаружено";СУММ(ЕСЛИ(B16:F16>=0,05;B16:F16)))

Это формула массива, т.е. ввод в ячейку нужно завершить клавиатурной комбинацией Ctrl+Shift+Enter.

P.S. Какая же у вас версия Excel, если СУММЕСЛИ еще не работает? И неужели при этом уже работает СЧЁТЕСЛИ?


Мой tip box - яд 41001663842605

Сообщение отредактировал Gustav - Пятница, 15.07.2022, 22:08
 
Ответить
СообщениеА если такую первую попробовать?
Код
=ЕСЛИ(СУММ(ЕСЛИ(B16:F16="Не обнаружено";1))=5;"Не обнаружено";СУММ(ЕСЛИ(B16:F16>=0,05;B16:F16)))

Это формула массива, т.е. ввод в ячейку нужно завершить клавиатурной комбинацией Ctrl+Shift+Enter.

P.S. Какая же у вас версия Excel, если СУММЕСЛИ еще не работает? И неужели при этом уже работает СЧЁТЕСЛИ?

Автор - Gustav
Дата добавления - 15.07.2022 в 22:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формулыСУММЕСЛИМН и МАКСЕСЛИ в Excel в старых версиях с ЕСЛИ (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!