Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сопоставить значения в разных диапазонах, но с одинак позиц - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить значения в разных диапазонах, но с одинак позиц (Формулы/Formulas)
Сопоставить значения в разных диапазонах, но с одинак позиц
CHEVRYACHOK Дата: Пятница, 22.07.2022, 03:08 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый вечер!
Вроде бы и много похожих тем на форуме, но для себя решение не смог найти или что-то не так делаю.
Есть два диапазона с данными, в одном значения идут на увеличение, во втором разные.
Диапазоны одинаковые и значения находятся в одних и тех же местах.
Задача собрать их в две строки
1-я строка значения из первого диапазона по возрастанию, здесь я использовал фор-лу НАИМЕНЬШИЙ, возможно есть другие варианты, но и этот вроде работает
2-я строка значения из второго диапазона, которые соответствуют расположению значений из первого диапазона.
Файл прикладываю, там нагляднее.
К сообщению приложен файл: Test.xlsx(11.9 Kb)
 
Ответить
СообщениеДобрый вечер!
Вроде бы и много похожих тем на форуме, но для себя решение не смог найти или что-то не так делаю.
Есть два диапазона с данными, в одном значения идут на увеличение, во втором разные.
Диапазоны одинаковые и значения находятся в одних и тех же местах.
Задача собрать их в две строки
1-я строка значения из первого диапазона по возрастанию, здесь я использовал фор-лу НАИМЕНЬШИЙ, возможно есть другие варианты, но и этот вроде работает
2-я строка значения из второго диапазона, которые соответствуют расположению значений из первого диапазона.
Файл прикладываю, там нагляднее.

Автор - CHEVRYACHOK
Дата добавления - 22.07.2022 в 03:08
bigor Дата: Пятница, 22.07.2022, 09:15 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 144 ±
Замечаний: 0% ±

нет
Доброе утро
Так пробовали
Код
=SUMPRODUCT(($B$4:$I$7=B9)*($B$12:$I$15))
?
 
Ответить
СообщениеДоброе утро
Так пробовали
Код
=SUMPRODUCT(($B$4:$I$7=B9)*($B$12:$I$15))
?

Автор - bigor
Дата добавления - 22.07.2022 в 09:15
_Boroda_ Дата: Пятница, 22.07.2022, 09:27 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Повторы в первой таблице могут быть?
Если нет, то еще вариант
Код
=СУММЕСЛИ($B4:$I7;B9;$B12:$I15)

Если да, то немного посложнее формула будет. Кстати, сверху и слева таблиц (столбец А и строка 3) какие данные есть? Это может пригодиться


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПовторы в первой таблице могут быть?
Если нет, то еще вариант
Код
=СУММЕСЛИ($B4:$I7;B9;$B12:$I15)

Если да, то немного посложнее формула будет. Кстати, сверху и слева таблиц (столбец А и строка 3) какие данные есть? Это может пригодиться

Автор - _Boroda_
Дата добавления - 22.07.2022 в 09:27
CHEVRYACHOK Дата: Пятница, 22.07.2022, 12:56 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Повторы в первой таблице могут быть?

Да, очень редко, но бывают.
Сверху и слева нет никаких данных (пустые).
 
Ответить
Сообщение
Повторы в первой таблице могут быть?

Да, очень редко, но бывают.
Сверху и слева нет никаких данных (пустые).

Автор - CHEVRYACHOK
Дата добавления - 22.07.2022 в 12:56
CHEVRYACHOK Дата: Пятница, 22.07.2022, 12:57 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СУММПРОИЗВ(($B$4:$I$7=B9)*($B$12:$I$15))

выдает ошибку
 
Ответить
Сообщение
=СУММПРОИЗВ(($B$4:$I$7=B9)*($B$12:$I$15))

выдает ошибку

Автор - CHEVRYACHOK
Дата добавления - 22.07.2022 в 12:57
bigor Дата: Пятница, 22.07.2022, 13:20 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 144 ±
Замечаний: 0% ±

нет
выдает ошибку
, в Excel, действительно, пока не пробежишься по пустым ячейкам с Delete, выдает ошибку.
 
Ответить
Сообщение
выдает ошибку
, в Excel, действительно, пока не пробежишься по пустым ячейкам с Delete, выдает ошибку.

Автор - bigor
Дата добавления - 22.07.2022 в 13:20
_Boroda_ Дата: Пятница, 22.07.2022, 13:30 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16499
Репутация: 6422 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
пока не пробежишься по пустым ячейкам с Delete, выдает ошибку.


Не обязательно. Можно так написать
Код
=СУММПРОИЗВ(($B$4:$I$7=B9)*Ч(+$B$12:$I$15))

или так
Код
=СУММПРОИЗВ(--($B$4:$I$7=B9);$B$12:$I$15)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
пока не пробежишься по пустым ячейкам с Delete, выдает ошибку.


Не обязательно. Можно так написать
Код
=СУММПРОИЗВ(($B$4:$I$7=B9)*Ч(+$B$12:$I$15))

или так
Код
=СУММПРОИЗВ(--($B$4:$I$7=B9);$B$12:$I$15)

Автор - _Boroda_
Дата добавления - 22.07.2022 в 13:30
bigor Дата: Пятница, 22.07.2022, 13:35 | Сообщение № 8
Группа: Проверенные
Ранг: Ветеран
Сообщений: 703
Репутация: 144 ±
Замечаний: 0% ±

нет
_Boroda_, можно было, но мне Ваша
Код
=СУММЕСЛИ($B4:$I7;B9;$B12:$I15)
больше нравится
 
Ответить
Сообщение_Boroda_, можно было, но мне Ваша
Код
=СУММЕСЛИ($B4:$I7;B9;$B12:$I15)
больше нравится

Автор - bigor
Дата добавления - 22.07.2022 в 13:35
CHEVRYACHOK Дата: Пятница, 22.07.2022, 15:15 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 109
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СУММПРОИЗВ(($B$4:$I$7=B9)*Ч(+$B$12:$I$15))

=СУММПРОИЗВ(--($B$4:$I$7=B9);$B$12:$I$15)

в таких вариантах все норм )
 
Ответить
Сообщение
=СУММПРОИЗВ(($B$4:$I$7=B9)*Ч(+$B$12:$I$15))

=СУММПРОИЗВ(--($B$4:$I$7=B9);$B$12:$I$15)

в таких вариантах все норм )

Автор - CHEVRYACHOK
Дата добавления - 22.07.2022 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сопоставить значения в разных диапазонах, но с одинак позиц (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!