Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сгенерировать число с контрольной суммой. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сгенерировать число с контрольной суммой. (Формулы/Formulas)
Сгенерировать число с контрольной суммой.
wehy Дата: Воскресенье, 24.07.2022, 16:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Подскажите есть ли функция в excel, расчета контрольной суммы десятеричной цифры? Нужно что бы исключить ошибку при передаче данных. По телефону диктую данные, на месте их забивают в таблицу, и если CRC неверная, то хоть будут знать об ошибке ввода.


Сообщение отредактировал wehy - Воскресенье, 24.07.2022, 21:10
 
Ответить
СообщениеЗдравствуйте. Подскажите есть ли функция в excel, расчета контрольной суммы десятеричной цифры? Нужно что бы исключить ошибку при передаче данных. По телефону диктую данные, на месте их забивают в таблицу, и если CRC неверная, то хоть будут знать об ошибке ввода.

Автор - wehy
Дата добавления - 24.07.2022 в 16:51
Russel Дата: Вторник, 26.07.2022, 13:28 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1385
Репутация: 317 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
На сколько я знаю, готовой функции нет. Можно придумать алгоритм и написать на стандартных функциях.


QIWI 9173973973
 
Ответить
СообщениеДобрый день!
На сколько я знаю, готовой функции нет. Можно придумать алгоритм и написать на стандартных функциях.

Автор - Russel
Дата добавления - 26.07.2022 в 13:28
msi2102 Дата: Вторник, 26.07.2022, 14:00 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 90 ±
Замечаний: 0% ±

Excel 2007
Попробуйте такой:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A1;СТРОКА(1:20);1);0))
К сообщению приложен файл: _1.xlsx(9.7 Kb)
 
Ответить
СообщениеПопробуйте такой:
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(A1;СТРОКА(1:20);1);0))

Автор - msi2102
Дата добавления - 26.07.2022 в 14:00
Serge_007 Дата: Вторник, 26.07.2022, 14:19 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
msi2102, например для 1234678, 1234687 и 12346870 результат будет одинаковый - 31


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеmsi2102, например для 1234678, 1234687 и 12346870 результат будет одинаковый - 31

Автор - Serge_007
Дата добавления - 26.07.2022 в 14:19
msi2102 Дата: Вторник, 26.07.2022, 14:30 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 90 ±
Замечаний: 0% ±

Excel 2007
результат будет одинаковый - 31
Ну так, ТС алгоритм расчета, этой контрольной суммы, не показал, в каком виде данные, тоже, поэтому, только полет мысли. Ну если не нравится первый вариант, тогда такой
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(СУММ(ЦЕЛОЕ(A1/1000);A1-ЦЕЛОЕ(A1/1000)*1000);СТРОКА(1:3);1);0))
К сообщению приложен файл: 2758527.xlsx(9.4 Kb)


Сообщение отредактировал msi2102 - Вторник, 26.07.2022, 14:31
 
Ответить
Сообщение
результат будет одинаковый - 31
Ну так, ТС алгоритм расчета, этой контрольной суммы, не показал, в каком виде данные, тоже, поэтому, только полет мысли. Ну если не нравится первый вариант, тогда такой
Код
=СУММ(ЕСЛИОШИБКА(--ПСТР(СУММ(ЦЕЛОЕ(A1/1000);A1-ЦЕЛОЕ(A1/1000)*1000);СТРОКА(1:3);1);0))

Автор - msi2102
Дата добавления - 26.07.2022 в 14:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сгенерировать число с контрольной суммой. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!