Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выбор цены в зависимости от даты продаж, как найти формулу. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор цены в зависимости от даты продаж, как найти формулу. (Формулы/Formulas)
Выбор цены в зависимости от даты продаж, как найти формулу.
ksucha-popova Дата: Суббота, 30.07.2022, 09:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Помогите решить задачу, все что знала использовала. Дано список продаж по датам и список товара с ценой закупа, по месяцам с детализацией по датам. Файл с ценой каждый месяц обновляется добавлением текущим месяцем (нарастанием) поскольку некоторые продажи могут подписаться через несколько месяцев. Цена закупа меняется постоянно. По имеющимся таблицам нужно посчитать себестоимость каждой продажи в зависимости от даты. Благодарю заранее.
К сообщению приложен файл: 9752939.xlsx(14.5 Kb)
 
Ответить
СообщениеДобрый день. Помогите решить задачу, все что знала использовала. Дано список продаж по датам и список товара с ценой закупа, по месяцам с детализацией по датам. Файл с ценой каждый месяц обновляется добавлением текущим месяцем (нарастанием) поскольку некоторые продажи могут подписаться через несколько месяцев. Цена закупа меняется постоянно. По имеющимся таблицам нужно посчитать себестоимость каждой продажи в зависимости от даты. Благодарю заранее.

Автор - ksucha-popova
Дата добавления - 30.07.2022 в 09:12
Nic70y Дата: Суббота, 30.07.2022, 09:40 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7666
Репутация: 1833 ±
Замечаний: 0% ±

Excel 2010
формула массива
Код
=ЕСЛИОШИБКА(--ПСТР(-продажи!C3*ИНДЕКС(цены!$A$3:$L$9999;ПОИСКПОЗ(C$2;цены!$A$3:$A$9999;);ПОИСКПОЗ($B3;ЕСЛИ(цены!$B$2:$M$2="дата посл поступ";ИНДЕКС(цены!$B$3:$M$9999;ПОИСКПОЗ(C$2;цены!$A$3:$A$9999;);))));2;15);"")
К сообщению приложен файл: 26.xlsx(14.6 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ЕСЛИОШИБКА(--ПСТР(-продажи!C3*ИНДЕКС(цены!$A$3:$L$9999;ПОИСКПОЗ(C$2;цены!$A$3:$A$9999;);ПОИСКПОЗ($B3;ЕСЛИ(цены!$B$2:$M$2="дата посл поступ";ИНДЕКС(цены!$B$3:$M$9999;ПОИСКПОЗ(C$2;цены!$A$3:$A$9999;);))));2;15);"")

Автор - Nic70y
Дата добавления - 30.07.2022 в 09:40
прохожий2019 Дата: Суббота, 30.07.2022, 10:25 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 897
Репутация: 216 ±
Замечаний: 0% ±

365 Beta Channel
[vba]
Код
=LET(x;СВЕРНСТРОК(ИНДЕКС(цены!$B$3:$I$5;ПОИСКПОЗ(C$2;цены!$A$3:$A$5;););2);y;продажи!C3;ЕСЛИ(y;y*ПРОСМОТР($B3;ИНДЕКС(x;;2);ИНДЕКС(x;;1));""))
[/vba]
К сообщению приложен файл: 1562723.xlsx(15.0 Kb)
 
Ответить
Сообщение[vba]
Код
=LET(x;СВЕРНСТРОК(ИНДЕКС(цены!$B$3:$I$5;ПОИСКПОЗ(C$2;цены!$A$3:$A$5;););2);y;продажи!C3;ЕСЛИ(y;y*ПРОСМОТР($B3;ИНДЕКС(x;;2);ИНДЕКС(x;;1));""))
[/vba]

Автор - прохожий2019
Дата добавления - 30.07.2022 в 10:25
ksucha-popova Дата: Суббота, 30.07.2022, 12:23 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Огромное спасибо. Работает. Вы гении!!! hands
 
Ответить
СообщениеОгромное спасибо. Работает. Вы гении!!! hands

Автор - ksucha-popova
Дата добавления - 30.07.2022 в 12:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выбор цены в зависимости от даты продаж, как найти формулу. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!