Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вытащить названия строк по максимальным значениям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить названия строк по максимальным значениям (Формулы/Formulas)
Вытащить названия строк по максимальным значениям
kaiyrkz0 Дата: Пятница, 05.08.2022, 10:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

2007
Добрый день! Как вытащить наибольшие значения из списка фамилии, если значения некоторых фамилии одинаковы, но ставится первый наденны. Как сделать так что бы фамилии с одинаковыми значениями выходили оба. Вытащить названия строк по максимальным значениям при совпадении значении.
К сообщению приложен файл: 5826825.xlsx(454.4 Kb)
 
Ответить
СообщениеДобрый день! Как вытащить наибольшие значения из списка фамилии, если значения некоторых фамилии одинаковы, но ставится первый наденны. Как сделать так что бы фамилии с одинаковыми значениями выходили оба. Вытащить названия строк по максимальным значениям при совпадении значении.

Автор - kaiyrkz0
Дата добавления - 05.08.2022 в 10:30
Nic70y Дата: Пятница, 05.08.2022, 12:08 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7646
Репутация: 1827 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС($A$3:$A$1845;ЕСЛИ(K2=K1;ПОИСКПОЗ(K2;ИНДЕКС(B$3:B$11845;ПОИСКПОЗ(K23;$A$3:$A$1845;)+1):B$11845;)+ПОИСКПОЗ(K23;$A$3:$A$1845;);ПОИСКПОЗ(K2;B$3:B$1845;)))
К сообщению приложен файл: 27.xlsx(463.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС($A$3:$A$1845;ЕСЛИ(K2=K1;ПОИСКПОЗ(K2;ИНДЕКС(B$3:B$11845;ПОИСКПОЗ(K23;$A$3:$A$1845;)+1):B$11845;)+ПОИСКПОЗ(K23;$A$3:$A$1845;);ПОИСКПОЗ(K2;B$3:B$1845;)))

Автор - Nic70y
Дата добавления - 05.08.2022 в 12:08
_Boroda_ Дата: Пятница, 05.08.2022, 13:53 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16306
Репутация: 6328 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант без участия таблицы сверху
Формула массива (вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС($A:$A;100-ОСТАТ(НАИБОЛЬШИЙ(B$3:B$99-СТРОКА($3:$99)%;СТРОКА(K1));1)/1%+0,1)

Но у Ника на больших объемах гораздо шустрее будет
К сообщению приложен файл: 27_2.xlsx(14.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант без участия таблицы сверху
Формула массива (вводится одновременным нажатием Контрл Шифт Ентер
Код
=ИНДЕКС($A:$A;100-ОСТАТ(НАИБОЛЬШИЙ(B$3:B$99-СТРОКА($3:$99)%;СТРОКА(K1));1)/1%+0,1)

Но у Ника на больших объемах гораздо шустрее будет

Автор - _Boroda_
Дата добавления - 05.08.2022 в 13:53
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вытащить названия строк по максимальным значениям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!