Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как сделать в экселе вхождение ключевых слов в текст? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать в экселе вхождение ключевых слов в текст? (Формулы/Formulas)
Как сделать в экселе вхождение ключевых слов в текст?
noviktamw Дата: Вторник, 16.08.2022, 12:05 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
Как сделать в экселе вхождение ключевых слов в текст?
Есть 2 списока строк. Нужно проверить точное вхождение ключа.

Пример:
Мяч для игры
Маша
Детский мяч
Дикая кошка

Во втором столбце ключи:
Мяч
Кошка
Собака

Итого нужно чтобы так:
Мяч-2
Кошка-1
Собака-0
Пример как это онлайн работает :http://textmania.ru/service/free/keywords-occurenses
Онлайн сервисы не тянут. У меня 600 тысяч строк в столбце.


Сообщение отредактировал noviktamw - Вторник, 16.08.2022, 12:07
 
Ответить
СообщениеКак сделать в экселе вхождение ключевых слов в текст?
Есть 2 списока строк. Нужно проверить точное вхождение ключа.

Пример:
Мяч для игры
Маша
Детский мяч
Дикая кошка

Во втором столбце ключи:
Мяч
Кошка
Собака

Итого нужно чтобы так:
Мяч-2
Кошка-1
Собака-0
Пример как это онлайн работает :http://textmania.ru/service/free/keywords-occurenses
Онлайн сервисы не тянут. У меня 600 тысяч строк в столбце.

Автор - noviktamw
Дата добавления - 16.08.2022 в 12:05
Serge_007 Дата: Вторник, 16.08.2022, 12:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15403
Репутация: 2536 ±
Замечаний: ±

Excel 2016
Как сделать в экселе вхождение ключевых слов в текст?
С помощью функций НАЙТИ() или ПОИСК()

Подробнее - при соблюдении правил форума


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Как сделать в экселе вхождение ключевых слов в текст?
С помощью функций НАЙТИ() или ПОИСК()

Подробнее - при соблюдении правил форума

Автор - Serge_007
Дата добавления - 16.08.2022 в 12:09
_Boroda_ Дата: Вторник, 16.08.2022, 12:09 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16355
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СЧЁТЕСЛИ(A$2:A$5;"*"&D2&"*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(A$2:A$5;"*"&D2&"*")

Автор - _Boroda_
Дата добавления - 16.08.2022 в 12:09
msi2102 Дата: Вторник, 16.08.2022, 12:20 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 79 ±
Замечаний: 0% ±

Excel 2007
Так будет учитывать если в одной ячейке будет повторяться искомое значение
Код
=СУММ((ДЛСТР($A$1:$A$4)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН($A$1:$A$4);СТРОЧН(A8);"")))/ДЛСТР(A8))
К сообщению приложен файл: 15.xlsx(10.1 Kb)


Сообщение отредактировал msi2102 - Вторник, 16.08.2022, 12:39
 
Ответить
СообщениеТак будет учитывать если в одной ячейке будет повторяться искомое значение
Код
=СУММ((ДЛСТР($A$1:$A$4)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН($A$1:$A$4);СТРОЧН(A8);"")))/ДЛСТР(A8))

Автор - msi2102
Дата добавления - 16.08.2022 в 12:20
_Boroda_ Дата: Вторник, 16.08.2022, 12:32 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16355
Репутация: 6351 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
ТРАНСП
- ?

Я подумал, что, поскольку это ключи, то неважно, сколько раз ключ в одной фразе встречается. Но не уверен )))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
ТРАНСП
- ?

Я подумал, что, поскольку это ключи, то неважно, сколько раз ключ в одной фразе встречается. Но не уверен )))

Автор - _Boroda_
Дата добавления - 16.08.2022 в 12:32
msi2102 Дата: Вторник, 16.08.2022, 12:37 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 79 ±
Замечаний: 0% ±

Excel 2007
Забыл удалить :), сейчас поправлю. Меня что-то понесло в начале не в ту степь


Сообщение отредактировал msi2102 - Вторник, 16.08.2022, 12:41
 
Ответить
СообщениеЗабыл удалить :), сейчас поправлю. Меня что-то понесло в начале не в ту степь

Автор - msi2102
Дата добавления - 16.08.2022 в 12:37
noviktamw Дата: Вторник, 16.08.2022, 13:55 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
Так будет учитывать если в одной ячейке будет повторяться искомое значение


Спасибо)

Пытался протянуть вашу формулу. Не получилось для Столбца D. Где учитывается полное кол-во вхождений ключа в строки.
 
Ответить
Сообщение
Так будет учитывать если в одной ячейке будет повторяться искомое значение


Спасибо)

Пытался протянуть вашу формулу. Не получилось для Столбца D. Где учитывается полное кол-во вхождений ключа в строки.

Автор - noviktamw
Дата добавления - 16.08.2022 в 13:55
noviktamw Дата: Вторник, 16.08.2022, 13:55 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
файл
К сообщению приложен файл: 15-2.xlsx(106.6 Kb)
 
Ответить
Сообщениефайл

Автор - noviktamw
Дата добавления - 16.08.2022 в 13:55
msi2102 Дата: Вторник, 16.08.2022, 14:26 | Сообщение № 9
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 198
Репутация: 79 ±
Замечаний: 0% ±

Excel 2007
Если при открытии файла у Вас будут стоять в формуле собаки (@), их нужно удалить и протянуть
=СУММ((ДЛСТР(@$A$1:$A$6000)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(@$A$1:$A$6000);СТРОЧН(B1);"")))/ДЛСТР(B1))
И у Вас только в первой ячейке диапазон $A$1:$A$6000, в остальных $A$1:$A$4
К сообщению приложен файл: 6033825.xlsx(106.2 Kb)


Сообщение отредактировал msi2102 - Вторник, 16.08.2022, 14:29
 
Ответить
СообщениеЕсли при открытии файла у Вас будут стоять в формуле собаки (@), их нужно удалить и протянуть
=СУММ((ДЛСТР(@$A$1:$A$6000)-ДЛСТР(ПОДСТАВИТЬ(СТРОЧН(@$A$1:$A$6000);СТРОЧН(B1);"")))/ДЛСТР(B1))
И у Вас только в первой ячейке диапазон $A$1:$A$6000, в остальных $A$1:$A$4

Автор - msi2102
Дата добавления - 16.08.2022 в 14:26
noviktamw Дата: Вторник, 23.08.2022, 17:57 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
Если не сложно, в третьем столбце просьба сделать уникальное полное совпадение двух ячеек.
Пример приложил.

Если при открытии файла у Вас будут стоять в формуле собаки (@), их нужно удалить и протянуть
 
Ответить
СообщениеЕсли не сложно, в третьем столбце просьба сделать уникальное полное совпадение двух ячеек.
Пример приложил.

Если при открытии файла у Вас будут стоять в формуле собаки (@), их нужно удалить и протянуть

Автор - noviktamw
Дата добавления - 23.08.2022 в 17:57
noviktamw Дата: Вторник, 23.08.2022, 17:58 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
файл
К сообщению приложен файл: 6233479.xlsx(104.5 Kb)
 
Ответить
Сообщениефайл

Автор - noviktamw
Дата добавления - 23.08.2022 в 17:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как сделать в экселе вхождение ключевых слов в текст? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!