Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автоматический подбор цены в зависимости от условия - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический подбор цены в зависимости от условия (Формулы/Formulas)
Автоматический подбор цены в зависимости от условия
Cesar Дата: Пятница, 19.08.2022, 05:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Добрый день.
Подскажите необходимую формулы для автоматического подбора цены/коэффициента в зависимости от названия(класса) товара.
Класс 1 имеет "**" в описании. Коэффициент для класса 1 - 0.8
Класс 2 имеет "*" в описании. Коэффициент для класса 2 - 0.5
Класс 3 не имеет никаких ‘*’ в описании. Коэффициент для класса 3 - 0.3.
К примеру,
**Стул
*Стол
Кровать
Такий позиций больше 1000
Какая в данном случае нужна формула, которая автоматически бы подставляла нужный кф под нужный класс товара. Мне подсказали формулу( пример одной ячейки
Код
=IF((LEN(C101)-LEN(SUBSTITUTE(C101,"*","")))=2,0.8)
. Она соответсвенно меняется через раз. Но она срабатывает не всегдаю
Благодарю заранее.
К сообщению приложен файл: 4155888.xlsx(16.4 Kb)


Сообщение отредактировал Serge_007 - Пятница, 19.08.2022, 09:16
 
Ответить
СообщениеДобрый день.
Подскажите необходимую формулы для автоматического подбора цены/коэффициента в зависимости от названия(класса) товара.
Класс 1 имеет "**" в описании. Коэффициент для класса 1 - 0.8
Класс 2 имеет "*" в описании. Коэффициент для класса 2 - 0.5
Класс 3 не имеет никаких ‘*’ в описании. Коэффициент для класса 3 - 0.3.
К примеру,
**Стул
*Стол
Кровать
Такий позиций больше 1000
Какая в данном случае нужна формула, которая автоматически бы подставляла нужный кф под нужный класс товара. Мне подсказали формулу( пример одной ячейки
Код
=IF((LEN(C101)-LEN(SUBSTITUTE(C101,"*","")))=2,0.8)
. Она соответсвенно меняется через раз. Но она срабатывает не всегдаю
Благодарю заранее.

Автор - Cesar
Дата добавления - 19.08.2022 в 05:10
scriptapplications Дата: Пятница, 19.08.2022, 08:32 | Сообщение № 2
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 11 ±
Замечаний: 0% ±

Cesar, растяните формулу
Код
=ИНДЕКС({0,3;0,5;0,8};ДЛСТР(B2)-ДЛСТР(ПОДСТАВИТЬ(B2;"*";""))+1)

Со строки 2 на всю таблицу.
Название в колонке B не должно содержать звёздочек, кроме первых символов, обозначающих класс.
Если в названии могут встречаться другие звёздочки, то формула для строки 2 выглядит так:
Код
=ЕСЛИ(ПСТР(B2;1;2)="**";0,8;ЕСЛИ(ПСТР(B2;1;1)="*";0,5;0,3))
К сообщению приложен файл: 4155888_1.xlsx(26.4 Kb)


Сообщение отредактировал scriptapplications - Пятница, 19.08.2022, 09:17
 
Ответить
СообщениеCesar, растяните формулу
Код
=ИНДЕКС({0,3;0,5;0,8};ДЛСТР(B2)-ДЛСТР(ПОДСТАВИТЬ(B2;"*";""))+1)

Со строки 2 на всю таблицу.
Название в колонке B не должно содержать звёздочек, кроме первых символов, обозначающих класс.
Если в названии могут встречаться другие звёздочки, то формула для строки 2 выглядит так:
Код
=ЕСЛИ(ПСТР(B2;1;2)="**";0,8;ЕСЛИ(ПСТР(B2;1;1)="*";0,5;0,3))

Автор - scriptapplications
Дата добавления - 19.08.2022 в 08:32
_Boroda_ Дата: Пятница, 19.08.2022, 11:09 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16367
Репутация: 6355 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=0,3+0,2*(ЛЕВБ(A2)="*")+0,3*(ЛЕВБ(A2;2)="**")

Код
=0,3+0,2*(ЛЕВБ(A2)="*")+0,3*(ПСТР(A2;2;1)="*")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=0,3+0,2*(ЛЕВБ(A2)="*")+0,3*(ЛЕВБ(A2;2)="**")

Код
=0,3+0,2*(ЛЕВБ(A2)="*")+0,3*(ПСТР(A2;2;1)="*")

Автор - _Boroda_
Дата добавления - 19.08.2022 в 11:09
Cesar Дата: Суббота, 20.08.2022, 03:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 20% ±

Спасибо большое за помощь, все формулы работают!
Если еще возможно спросить, что если вдруг появляются дополнительные условия и "*" становятся больше или появляются новые обозначения товаров, то данные формулы все еще могут работать или нужны уже все по-другому делать? И тогда просто мы просто по фильтру будем все выделять и переписывать выше написанные формулы?
 
Ответить
СообщениеСпасибо большое за помощь, все формулы работают!
Если еще возможно спросить, что если вдруг появляются дополнительные условия и "*" становятся больше или появляются новые обозначения товаров, то данные формулы все еще могут работать или нужны уже все по-другому делать? И тогда просто мы просто по фильтру будем все выделять и переписывать выше написанные формулы?

Автор - Cesar
Дата добавления - 20.08.2022 в 03:54
scriptapplications Дата: Суббота, 20.08.2022, 10:38 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 11 ±
Замечаний: 0% ±

[sup]Cesar, при увеличении количества звёзд проще всего изменить формулу с функцией ИНДЕКС.
Придётся в список коэффициентов добавить новые, через (точку с запятой ) и формула примет вид:
Код
=ИНДЕКС({0,3;0,5;0,8,;... };ДЛСТР(B2)-ДЛСТР(ПОДСТАВИТЬ(B2;"*";""))+1)

Где точки означают новые коэффициенты.
Остальные формулы, тоже, придётся дописывать.


Сообщение отредактировал scriptapplications - Суббота, 20.08.2022, 10:45
 
Ответить
Сообщение[sup]Cesar, при увеличении количества звёзд проще всего изменить формулу с функцией ИНДЕКС.
Придётся в список коэффициентов добавить новые, через (точку с запятой ) и формула примет вид:
Код
=ИНДЕКС({0,3;0,5;0,8,;... };ДЛСТР(B2)-ДЛСТР(ПОДСТАВИТЬ(B2;"*";""))+1)

Где точки означают новые коэффициенты.
Остальные формулы, тоже, придётся дописывать.

Автор - scriptapplications
Дата добавления - 20.08.2022 в 10:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автоматический подбор цены в зависимости от условия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!