Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание данных из книги в книгу с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание данных из книги в книгу с условием (Формулы/Formulas)
Подтягивание данных из книги в книгу с условием
swipsa Дата: Четверг, 25.08.2022, 09:24 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Есть несколько файлов с таблицами. Один из них содержит исходные данные для остальных. Данные даны в два столбца - номер партии и жирность.
Как можно сделать так, что бы в остальных книгах при вводе в ячейку данных "№ партии" (зеленая ячейка), рядом в следующей ячейке (синяя ячейка) автоматически появлялось значение жирности из книги "исходные данные"?
То есть если я ставлю номер партии 2, то рядом жирность подтягивается 3,6; если ставлю 12, то подтягивается рядом 3,5.
К сообщению приложен файл: _..xls(38.5 Kb) · 7736642.xls(33.5 Kb)


Сообщение отредактировал swipsa - Четверг, 25.08.2022, 09:25
 
Ответить
СообщениеЗдравствуйте! Есть несколько файлов с таблицами. Один из них содержит исходные данные для остальных. Данные даны в два столбца - номер партии и жирность.
Как можно сделать так, что бы в остальных книгах при вводе в ячейку данных "№ партии" (зеленая ячейка), рядом в следующей ячейке (синяя ячейка) автоматически появлялось значение жирности из книги "исходные данные"?
То есть если я ставлю номер партии 2, то рядом жирность подтягивается 3,6; если ставлю 12, то подтягивается рядом 3,5.

Автор - swipsa
Дата добавления - 25.08.2022 в 09:24
NikitaDvorets Дата: Четверг, 25.08.2022, 14:30 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 364
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
swipsa, добрый день.
Цитата
Как можно сделать так, что бы в остальных книгах при вводе в ячейку данных "№ партии" (зеленая ячейка), рядом в следующей ячейке (синяя ячейка) автоматически появлялось значение жирности из книги "исходные данные"?


Вариант: макросом управления событием Private Sub Worksheet_Change(ByVal Target As Range), размещенным в каждом из файлов с таблицей;
считывающим файл с исходными данными и записывающим параметр жирности (синяя ячейка) в исходную таблицу.
 
Ответить
Сообщениеswipsa, добрый день.
Цитата
Как можно сделать так, что бы в остальных книгах при вводе в ячейку данных "№ партии" (зеленая ячейка), рядом в следующей ячейке (синяя ячейка) автоматически появлялось значение жирности из книги "исходные данные"?


Вариант: макросом управления событием Private Sub Worksheet_Change(ByVal Target As Range), размещенным в каждом из файлов с таблицей;
считывающим файл с исходными данными и записывающим параметр жирности (синяя ячейка) в исходную таблицу.

Автор - NikitaDvorets
Дата добавления - 25.08.2022 в 14:30
Sancho Дата: Пятница, 26.08.2022, 08:36 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 276
Репутация: 19 ±
Замечаний: 0% ±

2007, 2010, 2013
swipsa, добрый день!
Может быть пример не совсем удачный, потому что в файле с таблицей номера партий представлены в формате текста, а в исходных данных номера партий в формате цифр, и в то же время в исходнике нет партий 10А2, 15А2
. Поэтому предполагаю что настоящий файлы содержат значения подобные 10А2 15А2 и для этого случая достаточно будет формулы
Код
=ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0))

Если я в своих рассуждениях не прав и файлы содержат цифры в формате текста и текст, а в источнике цифры в формате цифр и текст, то
Код
=ЕСЛИ(ЕОШИБКА(C3*1);ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0));ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3*1;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0)))
К сообщению приложен файл: 8020107.xls(42.5 Kb)


Сообщение отредактировал Sancho - Пятница, 26.08.2022, 08:38
 
Ответить
Сообщениеswipsa, добрый день!
Может быть пример не совсем удачный, потому что в файле с таблицей номера партий представлены в формате текста, а в исходных данных номера партий в формате цифр, и в то же время в исходнике нет партий 10А2, 15А2
. Поэтому предполагаю что настоящий файлы содержат значения подобные 10А2 15А2 и для этого случая достаточно будет формулы
Код
=ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0))

Если я в своих рассуждениях не прав и файлы содержат цифры в формате текста и текст, а в источнике цифры в формате цифр и текст, то
Код
=ЕСЛИ(ЕОШИБКА(C3*1);ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0));ИНДЕКС([ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$B$1:$B$347;ПОИСКПОЗ(C3*1;[ВАША ССЫЛКА НА ФАЙЛ ИСТОЧНИК]Лист1!$A$1:$A$347;0)))

Автор - Sancho
Дата добавления - 26.08.2022 в 08:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание данных из книги в книгу с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!