Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/По статусу ячеек из одной таблицы покрасить ячейки из других - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » По статусу ячеек из одной таблицы покрасить ячейки из других (Формулы/Formulas)
По статусу ячеек из одной таблицы покрасить ячейки из других
egorus Дата: Четверг, 25.08.2022, 12:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Можно ли сделать следующее7
В таблице "Номенклатура" есть столбик "Завершен".
Там можно или что-то писать или сделать чек-бокс.
А в таблице "Отгрузки" и в сводной таблице все строки, где есть ячейки А из таблицы Номенклатура с отмеченным статусов "Выполнен" окрасились бы в другой цвет?
Типа, как я сейчас это сделал вручную.
К сообщению приложен файл: 9787377.xlsx(34.4 Kb)
 
Ответить
СообщениеМожно ли сделать следующее7
В таблице "Номенклатура" есть столбик "Завершен".
Там можно или что-то писать или сделать чек-бокс.
А в таблице "Отгрузки" и в сводной таблице все строки, где есть ячейки А из таблицы Номенклатура с отмеченным статусов "Выполнен" окрасились бы в другой цвет?
Типа, как я сейчас это сделал вручную.

Автор - egorus
Дата добавления - 25.08.2022 в 12:50
Gustav Дата: Четверг, 25.08.2022, 18:45 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2136
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Для листа "Отгрузки" формула для УФ такая:
Код
=И(A1<>"";ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($D1;Номенклатура!$A:$A;0))="да")
Применяется к:
Код
=$1:$1048576


Для сводной таблицы на Лист2, конечно, можно применить УФ, но оно будет не очень устойчивым и при перестройке сводной таблицы может "разорваться". Попробуйте для Лист2 аналогичную формулу (только с другой колонкой для ПОИСКПОЗ):
Код
=И(A1<>"";ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($A1;Номенклатура!$A:$A;0))="да")
либо еще проще:
Код
=ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($A1;Номенклатура!$A:$A;0))="да"

УФ применяется к такому же диапазону, как и на листе "Отгрузки", т.е. ко всему листу (по крайней мере, в начале). Ну, а что потом будете получаться, увидите сами.


Мой tip box - яд 41001663842605
 
Ответить
СообщениеДля листа "Отгрузки" формула для УФ такая:
Код
=И(A1<>"";ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($D1;Номенклатура!$A:$A;0))="да")
Применяется к:
Код
=$1:$1048576


Для сводной таблицы на Лист2, конечно, можно применить УФ, но оно будет не очень устойчивым и при перестройке сводной таблицы может "разорваться". Попробуйте для Лист2 аналогичную формулу (только с другой колонкой для ПОИСКПОЗ):
Код
=И(A1<>"";ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($A1;Номенклатура!$A:$A;0))="да")
либо еще проще:
Код
=ИНДЕКС(Номенклатура!$F:$F;ПОИСКПОЗ($A1;Номенклатура!$A:$A;0))="да"

УФ применяется к такому же диапазону, как и на листе "Отгрузки", т.е. ко всему листу (по крайней мере, в начале). Ну, а что потом будете получаться, увидите сами.

Автор - Gustav
Дата добавления - 25.08.2022 в 18:45
egorus Дата: Пятница, 26.08.2022, 10:24 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Я в таблице Номенклатура убрал сверху какие-то ненужные строчки.
Для таблицы Номенклатура и Отгрузки немного поменял формулу, чтобы окрашивались именно нужные строки после этого удаления.
А в сводной таблице на одну строку съезжает.

Можете посмотреть?

А, получилось. Вместо А1 написал А2
К сообщению приложен файл: 8607266.xlsx(38.0 Kb)


Сообщение отредактировал egorus - Пятница, 26.08.2022, 10:34
 
Ответить
СообщениеЯ в таблице Номенклатура убрал сверху какие-то ненужные строчки.
Для таблицы Номенклатура и Отгрузки немного поменял формулу, чтобы окрашивались именно нужные строки после этого удаления.
А в сводной таблице на одну строку съезжает.

Можете посмотреть?

А, получилось. Вместо А1 написал А2

Автор - egorus
Дата добавления - 26.08.2022 в 10:24
egorus Дата: Пятница, 26.08.2022, 10:35 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Где почитать, про все эти диапазоны, индексы, ячейки, для чайника?
Чтобы были понятны Ваши эти формулы?
 
Ответить
СообщениеГде почитать, про все эти диапазоны, индексы, ячейки, для чайника?
Чтобы были понятны Ваши эти формулы?

Автор - egorus
Дата добавления - 26.08.2022 в 10:35
Gustav Дата: Пятница, 26.08.2022, 12:09 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2136
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Где почитать

На главную страницу сайта зайдите: http://www.excelworld.ru/

Там над плиткой "Форум":
и "Статьи об Excel": http://www.excelworld.ru/index/publ/0-49
и "Справочники": http://www.excelworld.ru/index/spravochniki/0-48
и "Библиотека": http://www.excelworld.ru/index/bibl/0-5
и "Видеосалон": http://www.excelworld.ru/index/video/0-6


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
Где почитать

На главную страницу сайта зайдите: http://www.excelworld.ru/

Там над плиткой "Форум":
и "Статьи об Excel": http://www.excelworld.ru/index/publ/0-49
и "Справочники": http://www.excelworld.ru/index/spravochniki/0-48
и "Библиотека": http://www.excelworld.ru/index/bibl/0-5
и "Видеосалон": http://www.excelworld.ru/index/video/0-6

Автор - Gustav
Дата добавления - 26.08.2022 в 12:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » По статусу ячеек из одной таблицы покрасить ячейки из других (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!