Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Частичное совпадение при сравнении 2-х столбцов - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Частичное совпадение при сравнении 2-х столбцов (Формулы/Formulas)
Частичное совпадение при сравнении 2-х столбцов
noviktamw Дата: Вторник, 30.08.2022, 17:37 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
Как сделать чтобы Эксель находил не полное совпадение а частичное в ячейках столбца. Например по стоп слову “град” находил и волгоград, калининград и т.д.?

Строк в столбце более 200к
Стоп (мусорных) слов более 3к.
К сообщению приложен файл: 2222.xlsx(444.8 Kb)
 
Ответить
СообщениеКак сделать чтобы Эксель находил не полное совпадение а частичное в ячейках столбца. Например по стоп слову “град” находил и волгоград, калининград и т.д.?

Строк в столбце более 200к
Стоп (мусорных) слов более 3к.

Автор - noviktamw
Дата добавления - 30.08.2022 в 17:37
msi2102 Дата: Вторник, 30.08.2022, 17:51 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 205
Репутация: 79 ±
Замечаний: 0% ±

Excel 2007
Попробуйте так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК('Стоп слова'!$A$1:$A$2098;A1);'Стоп слова'!$A$1:$A$2098);"")
К сообщению приложен файл: 9973307.xlsx(115.0 Kb)


Сообщение отредактировал msi2102 - Вторник, 30.08.2022, 17:51
 
Ответить
СообщениеПопробуйте так
Код
=ЕСЛИОШИБКА(ПРОСМОТР(2;1/ПОИСК('Стоп слова'!$A$1:$A$2098;A1);'Стоп слова'!$A$1:$A$2098);"")

Автор - msi2102
Дата добавления - 30.08.2022 в 17:51
noviktamw Дата: Пятница, 02.09.2022, 11:16 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 40% ±

Excel 2016
Попробуйте так

Тормозит. Но работает.

Спасибо)
 
Ответить
Сообщение
Попробуйте так

Тормозит. Но работает.

Спасибо)

Автор - noviktamw
Дата добавления - 02.09.2022 в 11:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Частичное совпадение при сравнении 2-х столбцов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!