Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Преобразование списка оборудования - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование списка оборудования (Формулы/Formulas)
Преобразование списка оборудования
NikitaDvorets Дата: Пятница, 02.09.2022, 14:59 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 365
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
Уважаемые эксперты!

Возникла задача на преобразование списка оборудования по нескольким условиям .

Пояснение к задаче.

Имеется список оборудования (столбец "А") прилагаемого файла.

Каждая позиция может начинаться:
(1) с 6-ти значного артикула. В этом случае требуется отделить артикул и оставить в результирующем столбце только называние оборудования.
(2) с кода вида: ##.##.?? В этом случае требуется отделить код и оставить в результирующем столбце только называние оборудования.
(3) Артикул и код отсутствуют. В этом случае требуется оставить в результирующем столбце только называние оборудования.

Попытка воспользоваться формулой в столбце "B":
Код
=ПРАВСИМВ(A2;ДЛСТР(A2)-6)
не позволяет полностью решить задачу.

Вопрос
Существует ли возможность разработать универсальную формулу, которая преобразует перечень в столбце "А" только в названия оборудования?
К сообщению приложен файл: ___31.08.2022_v.xlsx(71.5 Kb)
 
Ответить
СообщениеУважаемые эксперты!

Возникла задача на преобразование списка оборудования по нескольким условиям .

Пояснение к задаче.

Имеется список оборудования (столбец "А") прилагаемого файла.

Каждая позиция может начинаться:
(1) с 6-ти значного артикула. В этом случае требуется отделить артикул и оставить в результирующем столбце только называние оборудования.
(2) с кода вида: ##.##.?? В этом случае требуется отделить код и оставить в результирующем столбце только называние оборудования.
(3) Артикул и код отсутствуют. В этом случае требуется оставить в результирующем столбце только называние оборудования.

Попытка воспользоваться формулой в столбце "B":
Код
=ПРАВСИМВ(A2;ДЛСТР(A2)-6)
не позволяет полностью решить задачу.

Вопрос
Существует ли возможность разработать универсальную формулу, которая преобразует перечень в столбце "А" только в названия оборудования?

Автор - NikitaDvorets
Дата добавления - 02.09.2022 в 14:59
Serge_007 Дата: Пятница, 02.09.2022, 15:20 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15418
Репутация: 2538 ±
Замечаний: ±

Excel 2016
Так можно:
Код
=ЕСЛИ((ЕЧИСЛО(ПОИСК("??.";A2)+ЛЕВБ(A2)))>0;ПСТР(A2;7;99);A2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТак можно:
Код
=ЕСЛИ((ЕЧИСЛО(ПОИСК("??.";A2)+ЛЕВБ(A2)))>0;ПСТР(A2;7;99);A2)

Автор - Serge_007
Дата добавления - 02.09.2022 в 15:20
NikitaDvorets Дата: Пятница, 02.09.2022, 15:59 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 365
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
Цитата
Так можно:
Благодарю за поддержку. Но у меня эта формула вырезает первые 4 символа для случая №3.
 
Ответить
Сообщение
Цитата
Так можно:
Благодарю за поддержку. Но у меня эта формула вырезает первые 4 символа для случая №3.

Автор - NikitaDvorets
Дата добавления - 02.09.2022 в 15:59
Serge_007 Дата: Пятница, 02.09.2022, 16:16 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15418
Репутация: 2538 ±
Замечаний: ±

Excel 2016
Да, не обратил внимания
Тогда так:
Код
=ЕСЛИ((ЕЧИСЛО(ПОИСК("??.";A2))+ЕЧИСЛО(-ЛЕВБ(A2)))>0;ПСТР(A2;7;99);A2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеДа, не обратил внимания
Тогда так:
Код
=ЕСЛИ((ЕЧИСЛО(ПОИСК("??.";A2))+ЕЧИСЛО(-ЛЕВБ(A2)))>0;ПСТР(A2;7;99);A2)

Автор - Serge_007
Дата добавления - 02.09.2022 в 16:16
NikitaDvorets Дата: Пятница, 02.09.2022, 17:05 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 365
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
Serge_007, это почти универсальная формула, благодарю.
Но меня немного озадачила "пропажа" весов из перечня оборудования (выделено красным шрифтом).
Файл прилагаю.
К сообщению приложен файл: 9625872.xlsx(72.9 Kb)
 
Ответить
СообщениеSerge_007, это почти универсальная формула, благодарю.
Но меня немного озадачила "пропажа" весов из перечня оборудования (выделено красным шрифтом).
Файл прилагаю.

Автор - NikitaDvorets
Дата добавления - 02.09.2022 в 17:05
Serge_007 Дата: Пятница, 02.09.2022, 17:17 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15418
Репутация: 2538 ±
Замечаний: ±

Excel 2016
Замени в формуле "??." на "??.??."


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗамени в формуле "??." на "??.??."

Автор - Serge_007
Дата добавления - 02.09.2022 в 17:17
NikitaDvorets Дата: Пятница, 02.09.2022, 20:31 | Сообщение № 7
Группа: Проверенные
Ранг: Обитатель
Сообщений: 365
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
Благодарю сердечно!
Цитата
Замени в формуле "??." на "??.??.??"
- работает.
Тему можно закрыть.
 
Ответить
СообщениеБлагодарю сердечно!
Цитата
Замени в формуле "??." на "??.??.??"
- работает.
Тему можно закрыть.

Автор - NikitaDvorets
Дата добавления - 02.09.2022 в 20:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Преобразование списка оборудования (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!