Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск всех совпадений и их вывод в отдельную ячейку - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск всех совпадений и их вывод в отдельную ячейку (Формулы/Formulas)
Поиск всех совпадений и их вывод в отдельную ячейку
Clyde Дата: Вторник, 06.09.2022, 09:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня.
Как можно вывести №Коробки, в которой есть необходимое количество, советующее значению в ячейке «Запрос»?
Проше. Нужно найти все совпадения и вывести их порядковые номера в отдельные ячейки.
К сообщению приложен файл: _____.xlsx(10.8 Kb)
 
Ответить
СообщениеДоброго дня.
Как можно вывести №Коробки, в которой есть необходимое количество, советующее значению в ячейке «Запрос»?
Проше. Нужно найти все совпадения и вывести их порядковые номера в отдельные ячейки.

Автор - Clyde
Дата добавления - 06.09.2022 в 09:51
Serge_007 Дата: Вторник, 06.09.2022, 10:03 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15418
Репутация: 2538 ±
Замечаний: ±

Excel 2016
Здравствуйте

Формула масссива:
Код
=НАИМЕНЬШИЙ(ЕСЛИ($D3=$B$3:$B$19;СТРОКА($1:$17));СТОЛБЕЦ(A1))
К сообщению приложен файл: 20220906_Clyde.xls(61.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула масссива:
Код
=НАИМЕНЬШИЙ(ЕСЛИ($D3=$B$3:$B$19;СТРОКА($1:$17));СТОЛБЕЦ(A1))

Автор - Serge_007
Дата добавления - 06.09.2022 в 10:03
Nic70y Дата: Вторник, 06.09.2022, 10:05 | Сообщение № 3
Группа: Друзья
Ранг: Экселист
Сообщений: 7733
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
формула не массива:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($D3;ИНДЕКС($B:$B;E3+3):$B$9999;)+E3;"")
К сообщению приложен файл: 250.xlsx(11.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениеформула не массива:
Код
=ЕСЛИОШИБКА(ПОИСКПОЗ($D3;ИНДЕКС($B:$B;E3+3):$B$9999;)+E3;"")

Автор - Nic70y
Дата добавления - 06.09.2022 в 10:05
Clyde Дата: Вторник, 06.09.2022, 11:41 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Спасибо. Оба решения подходят.
 
Ответить
СообщениеСпасибо. Оба решения подходят.

Автор - Clyde
Дата добавления - 06.09.2022 в 11:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск всех совпадений и их вывод в отдельную ячейку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!