Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как отождествить критерии при расчете суммы - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отождествить критерии при расчете суммы (Формулы/Formulas)
Как отождествить критерии при расчете суммы
Agap Дата: Вторник, 06.09.2022, 14:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Привет, ребят. Использую СУММЕСЛИ для расчета общего количества по заданным критериям. Столбец А вводимые данные, в D их расчет. Например, в Товар 1 в столбец D подтягиваются данные из столбца А только по критерию Товар 1. А как сделать, чтобы к нему подтягивались значения по другим критериям, например по схеме в столбце F?
К сообщению приложен файл: 1779726.xlsx(14.5 Kb)
 
Ответить
СообщениеПривет, ребят. Использую СУММЕСЛИ для расчета общего количества по заданным критериям. Столбец А вводимые данные, в D их расчет. Например, в Товар 1 в столбец D подтягиваются данные из столбца А только по критерию Товар 1. А как сделать, чтобы к нему подтягивались значения по другим критериям, например по схеме в столбце F?

Автор - Agap
Дата добавления - 06.09.2022 в 14:46
Pelena Дата: Вторник, 06.09.2022, 16:27 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Сделайте ещё один столбец (Группа) и суммируйте по нему


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Сделайте ещё один столбец (Группа) и суммируйте по нему

Автор - Pelena
Дата добавления - 06.09.2022 в 16:27
Agap Дата: Вторник, 06.09.2022, 16:39 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Цитата
Сделайте ещё один столбец (Группа) и суммируйте по нему


Не пойдет. В реале 500+ товаров и у каждого 2-3 разных артикула.
 
Ответить
Сообщение
Цитата
Сделайте ещё один столбец (Группа) и суммируйте по нему


Не пойдет. В реале 500+ товаров и у каждого 2-3 разных артикула.

Автор - Agap
Дата добавления - 06.09.2022 в 16:39
Pelena Дата: Вторник, 06.09.2022, 16:59 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
если артикулы записать не через +, а в доп. табличку, то можно так
Код
=СУММ(СУММЕСЛИ($A$2:$A$100;ИНДЕКС($F$2:$H$4;ПОИСКПОЗ(C2;$F$2:$F$4;0);0);$B$2:$B$100))
К сообщению приложен файл: 3142573.xlsx(15.2 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщениеесли артикулы записать не через +, а в доп. табличку, то можно так
Код
=СУММ(СУММЕСЛИ($A$2:$A$100;ИНДЕКС($F$2:$H$4;ПОИСКПОЗ(C2;$F$2:$F$4;0);0);$B$2:$B$100))

Автор - Pelena
Дата добавления - 06.09.2022 в 16:59
Agap Дата: Вторник, 06.09.2022, 18:45 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Цитата
если артикулы записать не через +, а в доп. табличку, то можно так

Спасибо. Т.е. без доп.таблицы никак...

И еще небольшой момент. Этот же файл только с фильтрами в столбцах А-В.
Как заставить меняться значения в столбце D, выключая значения в фильтрах столбцов А-В?
К сообщению приложен файл: 0419330.xlsx(15.4 Kb)
 
Ответить
Сообщение
Цитата
если артикулы записать не через +, а в доп. табличку, то можно так

Спасибо. Т.е. без доп.таблицы никак...

И еще небольшой момент. Этот же файл только с фильтрами в столбцах А-В.
Как заставить меняться значения в столбце D, выключая значения в фильтрах столбцов А-В?

Автор - Agap
Дата добавления - 06.09.2022 в 18:45
Pelena Дата: Вторник, 06.09.2022, 19:42 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
Т.е. без доп.таблицы никак...
ну, в любом случае надо ведь как-то показать какие артикулы суммировать

выключая значения в фильтрах

Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ($B$1;СТРОКА($1:$99);0))*($A$2:$A$100=ИНДЕКС($F$2:$H$4;ПОИСКПОЗ(C2;$F$2:$F$4;0);0)))
К сообщению приложен файл: 4282641.xlsx(15.4 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Т.е. без доп.таблицы никак...
ну, в любом случае надо ведь как-то показать какие артикулы суммировать

выключая значения в фильтрах

Код
=СУММПРОИЗВ(ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ($B$1;СТРОКА($1:$99);0))*($A$2:$A$100=ИНДЕКС($F$2:$H$4;ПОИСКПОЗ(C2;$F$2:$F$4;0);0)))

Автор - Pelena
Дата добавления - 06.09.2022 в 19:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как отождествить критерии при расчете суммы (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!