Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнение данных по нескольким условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение данных по нескольким условиям (Формулы/Formulas)
Заполнение данных по нескольким условиям
elycioo Дата: Вторник, 13.09.2022, 17:01 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Помогите решить задачу, пожалуйста. В первой колонке (артикул) имеется код, который присваивается нескольким строкам, а во второй группировочнный код, который присваивается к нескольким разным артикулам. В 3 колонке указан цвет каждого артикула. Проблема в том, что цвет одинаковый для группировочного кода, но задача в том, чтобы сделать цвет разным для строк с одинаковым групировочным кодом, но разным артикулом. Если в одном группировочном коде встречаются более 1 разных артикулов с одинаковым цветом, то к цвету просто добавляется 1, 2, 3... в зависимости от того, сколько в одной группировки разных артикулов с одним цветом. Надеюсь я понятно объяснил(В файле представлен пример как должно быть. Спасибо!
К сообщению приложен файл: 6969962.xlsx(47.0 Kb)
 
Ответить
СообщениеДобрый день. Помогите решить задачу, пожалуйста. В первой колонке (артикул) имеется код, который присваивается нескольким строкам, а во второй группировочнный код, который присваивается к нескольким разным артикулам. В 3 колонке указан цвет каждого артикула. Проблема в том, что цвет одинаковый для группировочного кода, но задача в том, чтобы сделать цвет разным для строк с одинаковым групировочным кодом, но разным артикулом. Если в одном группировочном коде встречаются более 1 разных артикулов с одинаковым цветом, то к цвету просто добавляется 1, 2, 3... в зависимости от того, сколько в одной группировки разных артикулов с одним цветом. Надеюсь я понятно объяснил(В файле представлен пример как должно быть. Спасибо!

Автор - elycioo
Дата добавления - 13.09.2022 в 17:01
Gustav Дата: Вторник, 13.09.2022, 19:59 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2138
Репутация: 840 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
Сортируете таблицу, начиная со второй строки в таком порядке: B, A, C. Потом в ячейку F2 такую формулу (с протяжкой вниз):
Код
=ЕСЛИ(B2<>B1;C2;ЕСЛИ(A2=A1;F1;C2&(ПОДСТАВИТЬ(F1;C1;"")&"0")/10+1))
К сообщению приложен файл: 3211049.xlsx(50.2 Kb)


Мой tip box - яд 41001663842605
 
Ответить
СообщениеСортируете таблицу, начиная со второй строки в таком порядке: B, A, C. Потом в ячейку F2 такую формулу (с протяжкой вниз):
Код
=ЕСЛИ(B2<>B1;C2;ЕСЛИ(A2=A1;F1;C2&(ПОДСТАВИТЬ(F1;C1;"")&"0")/10+1))

Автор - Gustav
Дата добавления - 13.09.2022 в 19:59
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнение данных по нескольким условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!