Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ПОИСКПОЗ по трем условиям одно из которых вариативность - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПОИСКПОЗ по трем условиям одно из которых вариативность (Формулы/Formulas)
ПОИСКПОЗ по трем условиям одно из которых вариативность
ZOoYa Дата: Четверг, 24.11.2022, 09:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Прошу помочь в исправлении формулы по трем условиям. в cтолбец D возвращает число из блока K L при этом выполняется условие совпадения столбцов А с I и В с J строго, а из столбца С выбиралось "с заливкой" или "Без".
Заранее благодарна.
К сообщению приложен файл: 1234.xlsx(11.4 Kb)
 
Ответить
СообщениеПрошу помочь в исправлении формулы по трем условиям. в cтолбец D возвращает число из блока K L при этом выполняется условие совпадения столбцов А с I и В с J строго, а из столбца С выбиралось "с заливкой" или "Без".
Заранее благодарна.

Автор - ZOoYa
Дата добавления - 24.11.2022 в 09:13
_Boroda_ Дата: Четверг, 24.11.2022, 09:19 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 16510
Репутация: 6426 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ИНДЕКС(K$2:L$11;ПОИСКПОЗ(A2&" "&B2;I$2:I$11&" "&J$2:J$11;);1+(ПРАВБ(C2)="и"))

Код
=СУММЕСЛИМН(ИНДЕКС(K$2:L$11;;1+(ПРАВБ(C2)="и"));I$2:I$11;A2;J$2:J$11;B2)

Первая массивная
К сообщению приложен файл: 1234_1.xlsx(12.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ИНДЕКС(K$2:L$11;ПОИСКПОЗ(A2&" "&B2;I$2:I$11&" "&J$2:J$11;);1+(ПРАВБ(C2)="и"))

Код
=СУММЕСЛИМН(ИНДЕКС(K$2:L$11;;1+(ПРАВБ(C2)="и"));I$2:I$11;A2;J$2:J$11;B2)

Первая массивная

Автор - _Boroda_
Дата добавления - 24.11.2022 в 09:19
Serge_007 Дата: Четверг, 24.11.2022, 09:24 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15574
Репутация: 2559 ±
Замечаний: ±

Excel 2016
Так надо?
Код
=СУММПРОИЗВ((A2=I$2:I$11)*(J$2:J$11=B2)*((ЕЧИСЛО(ПОИСК(" с ";C2))*K$2:K$11)+(ЕОШ(ПОИСК(" с ";C2))*L$2:L$11)))


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеТак надо?
Код
=СУММПРОИЗВ((A2=I$2:I$11)*(J$2:J$11=B2)*((ЕЧИСЛО(ПОИСК(" с ";C2))*K$2:K$11)+(ЕОШ(ПОИСК(" с ";C2))*L$2:L$11)))

Автор - Serge_007
Дата добавления - 24.11.2022 в 09:24
ZOoYa Дата: Четверг, 24.11.2022, 09:33 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

_Boroda_, Serge_007, Всем огромное спасибо за помощь!
 
Ответить
Сообщение_Boroda_, Serge_007, Всем огромное спасибо за помощь!

Автор - ZOoYa
Дата добавления - 24.11.2022 в 09:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ПОИСКПОЗ по трем условиям одно из которых вариативность (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!