Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод предпоследней строки с числами из диапазона данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод предпоследней строки с числами из диапазона данных (Формулы/Formulas)
Вывод предпоследней строки с числами из диапазона данных
stalber Дата: Воскресенье, 27.11.2022, 19:40 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 347
Репутация: 7 ±
Замечаний: 40% ±

Excel 2007
Здравствуйте, помогите пожалуйста.

Нужно вывести:
предпоследнюю строку с числами.
пред предпоследнюю строку с числами
и так далее, скажите пожалуйста что редактировать нужно чтобы выводить пред пред предпоследнюю.

Сложность в том что иногда в строке нет данных, в файле показал пример, и результат который нужен.
К сообщению приложен файл: vopros27112022.xlsx(11.7 Kb)
 
Ответить
СообщениеЗдравствуйте, помогите пожалуйста.

Нужно вывести:
предпоследнюю строку с числами.
пред предпоследнюю строку с числами
и так далее, скажите пожалуйста что редактировать нужно чтобы выводить пред пред предпоследнюю.

Сложность в том что иногда в строке нет данных, в файле показал пример, и результат который нужен.

Автор - stalber
Дата добавления - 27.11.2022 в 19:40
Pelena Дата: Воскресенье, 27.11.2022, 19:59 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18707
Репутация: 4260 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС(C:C;АГРЕГАТ(14;6;СТРОКА(C$1:C$40)/(C$1:C$40<>"");СТРОКА(A1)))
К сообщению приложен файл: 6970542.xlsx(15.1 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(C:C;АГРЕГАТ(14;6;СТРОКА(C$1:C$40)/(C$1:C$40<>"");СТРОКА(A1)))

Автор - Pelena
Дата добавления - 27.11.2022 в 19:59
stalber Дата: Воскресенье, 27.11.2022, 20:18 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 347
Репутация: 7 ±
Замечаний: 40% ±

Excel 2007
Почему у меня не получается потянуть формулу или вниз или вбок, или через ctrl shift enter, появляется ошибка #ИМЯ?
Может ли быть это из за того что у меня эксель старый?
 
Ответить
СообщениеПочему у меня не получается потянуть формулу или вниз или вбок, или через ctrl shift enter, появляется ошибка #ИМЯ?
Может ли быть это из за того что у меня эксель старый?

Автор - stalber
Дата добавления - 27.11.2022 в 20:18
stalber Дата: Воскресенье, 27.11.2022, 20:50 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 347
Репутация: 7 ±
Замечаний: 40% ±

Excel 2007
Добавил ещё одно условие, бывает ситуация что пустая строка сверху.
Пожалуйста предложите ещё формулы.
К сообщению приложен файл: 111vopros271120.xlsx(11.6 Kb)
 
Ответить
СообщениеДобавил ещё одно условие, бывает ситуация что пустая строка сверху.
Пожалуйста предложите ещё формулы.

Автор - stalber
Дата добавления - 27.11.2022 в 20:50
Pelena Дата: Воскресенье, 27.11.2022, 22:14 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18707
Репутация: 4260 ±
Замечаний: ±

Excel 2016 & Mac Excel
появляется ошибка #ИМЯ

не обратила внимание, что Excel 2007. АГРЕГАТ() появилась в 2010-м
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ЕСЛИ(C$1:C$40<>"";СТРОКА(C$1:C$40));СТРОКА(A1)))
К сообщению приложен файл: 8672191.xlsx(14.5 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
появляется ошибка #ИМЯ

не обратила внимание, что Excel 2007. АГРЕГАТ() появилась в 2010-м
Код
=ИНДЕКС(C:C;НАИБОЛЬШИЙ(ЕСЛИ(C$1:C$40<>"";СТРОКА(C$1:C$40));СТРОКА(A1)))

Автор - Pelena
Дата добавления - 27.11.2022 в 22:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод предпоследней строки с числами из диапазона данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!