Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Ссылка на значения в другой книге при добавлении новых строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на значения в другой книге при добавлении новых строк (Формулы/Formulas)
Ссылка на значения в другой книге при добавлении новых строк
Эд85 Дата: Понедельник, 12.12.2022, 20:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 30
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Всем привет!
Есть 3 книги Excel. 1-ая книга - это "931 АU 07 Карточка учета шин", в которой отражается пройденный километраж автобуса Hyundai Universe 931 AU 07. 2-ая книга - это таблица с пробегами автопарка "2023 Пробеги" и 3-ья книга - "443 АN 07 Карточка учета шин" для автобуса Toyota Coaster 443 AN 07. При занесении километража за Январь, Февраль, Март во 2-ую и 3-ью книги по формуле через ссылки на соответствующие ячейки в книге "2023 Пробеги" автоматом добавляются данные (значения) в соответствующие месяца уже их карточки учета (в 931 и 443 соответственно).

Подскажите пожалуйста, можно ли как-то сделать так, чтобы при добавление строк (т.е. при появление новых автобусов и вставке дополнительных строк в таблицу в книге 2, формула не сбивалась.

Например: если вставить дополнительную строку между Hyundai Universe - строка №13 и Toyota Coaster - строка №14, (нужно например при добавление нового автобуса Hyundai Universe, который будет куплен в 2023 и включен в перечень имеющихся уже автобусов данной марки в автопарке) к общему списку данных автобусов, то ссылка на ячейку для Toyota Coaster в книге "443 АN 07 Карточка учета шин" уже не будет пересчитываться автоматом и значения становятся 0, а нужно чтобы они оставались и как-то подтягивались до тех, что указаны в соответствующих месяцах в книге "2023 Пробеги" (в данном случае 15 10 25)
К сообщению приложен файл: 2023_.xlsm (31.9 Kb) · 931_U_07___.xlsx (55.3 Kb) · 443_N_07___.xlsx (16.8 Kb)


Сообщение отредактировал Эд85 - Понедельник, 12.12.2022, 20:44
 
Ответить
СообщениеВсем привет!
Есть 3 книги Excel. 1-ая книга - это "931 АU 07 Карточка учета шин", в которой отражается пройденный километраж автобуса Hyundai Universe 931 AU 07. 2-ая книга - это таблица с пробегами автопарка "2023 Пробеги" и 3-ья книга - "443 АN 07 Карточка учета шин" для автобуса Toyota Coaster 443 AN 07. При занесении километража за Январь, Февраль, Март во 2-ую и 3-ью книги по формуле через ссылки на соответствующие ячейки в книге "2023 Пробеги" автоматом добавляются данные (значения) в соответствующие месяца уже их карточки учета (в 931 и 443 соответственно).

Подскажите пожалуйста, можно ли как-то сделать так, чтобы при добавление строк (т.е. при появление новых автобусов и вставке дополнительных строк в таблицу в книге 2, формула не сбивалась.

Например: если вставить дополнительную строку между Hyundai Universe - строка №13 и Toyota Coaster - строка №14, (нужно например при добавление нового автобуса Hyundai Universe, который будет куплен в 2023 и включен в перечень имеющихся уже автобусов данной марки в автопарке) к общему списку данных автобусов, то ссылка на ячейку для Toyota Coaster в книге "443 АN 07 Карточка учета шин" уже не будет пересчитываться автоматом и значения становятся 0, а нужно чтобы они оставались и как-то подтягивались до тех, что указаны в соответствующих месяцах в книге "2023 Пробеги" (в данном случае 15 10 25)

Автор - Эд85
Дата добавления - 12.12.2022 в 20:33
Nic70y Дата: Вторник, 13.12.2022, 07:41 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 8026
Репутация: 1952 ±
Замечаний: 0% ±

Excel 2010
как-то так
Код
=ВПР(ПРАВБ($C$16;9);'[2023_.xlsm]Сведения по пробегам'!$C:$W;G18+5;)
примерно


ЮMoney 41001841029809
 
Ответить
Сообщениекак-то так
Код
=ВПР(ПРАВБ($C$16;9);'[2023_.xlsm]Сведения по пробегам'!$C:$W;G18+5;)
примерно

Автор - Nic70y
Дата добавления - 13.12.2022 в 07:41
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Ссылка на значения в другой книге при добавлении новых строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!