Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос формулы по ячейкам в строке - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос формулы по ячейкам в строке (Формулы/Formulas)
Перенос формулы по ячейкам в строке
Юрий_Ф Дата: Вторник, 13.12.2022, 21:09 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 563
Репутация: -3 ±
Замечаний: 40% ±

Excel 2010
Господа знатоки!

Теоретический вопрос: как перенести формулу ячейки по строке с тем, чтобы сумма менялась только по столбцу в переносимую ячейку, а начальная оставалась той же?
Пример!
В ячейке Е8 стоит нужная формула:
Код
=ЕСЛИ(E7=0;"Ц";СУММ(C7:E7))

При переносе формулы вправо за нижнюю точку формула меняется в СУММ((D7:F7). А должно быть: СУММ(С7:F7). За месяц пришлось всё менять вручную. Потому как переносы ни с нажатием клавиши Ctrl, ни Shift, ни Ctrl + Shift не копируют формулу один к одному.
Вопрос: возможно ли переносить формулы по ячейкам, чтобы в СУММ начальная ячейка оставалась везде С7, а изменялась бы только конечная ячейка суммы?
К сообщению приложен файл: 1a.xlsx(10.4 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеГоспода знатоки!

Теоретический вопрос: как перенести формулу ячейки по строке с тем, чтобы сумма менялась только по столбцу в переносимую ячейку, а начальная оставалась той же?
Пример!
В ячейке Е8 стоит нужная формула:
Код
=ЕСЛИ(E7=0;"Ц";СУММ(C7:E7))

При переносе формулы вправо за нижнюю точку формула меняется в СУММ((D7:F7). А должно быть: СУММ(С7:F7). За месяц пришлось всё менять вручную. Потому как переносы ни с нажатием клавиши Ctrl, ни Shift, ни Ctrl + Shift не копируют формулу один к одному.
Вопрос: возможно ли переносить формулы по ячейкам, чтобы в СУММ начальная ячейка оставалась везде С7, а изменялась бы только конечная ячейка суммы?

Автор - Юрий_Ф
Дата добавления - 13.12.2022 в 21:09
gling Дата: Вторник, 13.12.2022, 21:25 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2435
Репутация: 644 ±
Замечаний: 0% ±

2010
Попробуйте записать так СУММ($С7:E7) Про ссылки прочитайте здесь
Цитата
начальная ячейка оставалась везде С7
$C$7


ЯД-41001506838083

Сообщение отредактировал gling - Вторник, 13.12.2022, 21:34
 
Ответить
СообщениеПопробуйте записать так СУММ($С7:E7) Про ссылки прочитайте здесь
Цитата
начальная ячейка оставалась везде С7
$C$7

Автор - gling
Дата добавления - 13.12.2022 в 21:25
Юрий_Ф Дата: Вторник, 13.12.2022, 21:32 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 563
Репутация: -3 ±
Замечаний: 40% ±

Excel 2010
gling,

Спасибо, уважаемый! Это то, что нужно! hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеgling,

Спасибо, уважаемый! Это то, что нужно! hands

Автор - Юрий_Ф
Дата добавления - 13.12.2022 в 21:32
Юрий_Ф Дата: Вторник, 13.12.2022, 21:37 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 563
Репутация: -3 ±
Замечаний: 40% ±

Excel 2010
gling,

Интересна и статья, на которую вы дали ссылку!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
Сообщениеgling,

Интересна и статья, на которую вы дали ссылку!

Автор - Юрий_Ф
Дата добавления - 13.12.2022 в 21:37
elovkov Дата: Среда, 14.12.2022, 08:09 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

Про ссылки прочитайте здесь

Вот спасибо, про $$ и F4 знал давно, но то, что можно фиксировать только строку или столбец только узнал)) Спасибо, ценно
 
Ответить
Сообщение
Про ссылки прочитайте здесь

Вот спасибо, про $$ и F4 знал давно, но то, что можно фиксировать только строку или столбец только узнал)) Спасибо, ценно

Автор - elovkov
Дата добавления - 14.12.2022 в 08:09
Gustav Дата: Среда, 14.12.2022, 10:36 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2303
Репутация: 918 ±
Замечаний: 0% ±

начинал с Excel 4.0, видел 2.1
elovkov, видимо, F4 всегда только один раз нажимали ;)


МОИ: Ник, Tip box: 41001663842605
 
Ответить
Сообщениеelovkov, видимо, F4 всегда только один раз нажимали ;)

Автор - Gustav
Дата добавления - 14.12.2022 в 10:36
elovkov Дата: Понедельник, 30.01.2023, 13:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 2 ±
Замечаний: 0% ±

Про ссылки прочитайте здесь

нашел эту тему еще раз сказать спасибо, мне тут эта статья очень сильно пригодилась в части сохранения столбца неизменным, и как я раньше жил без этого знания?)))
 
Ответить
Сообщение
Про ссылки прочитайте здесь

нашел эту тему еще раз сказать спасибо, мне тут эта статья очень сильно пригодилась в части сохранения столбца неизменным, и как я раньше жил без этого знания?)))

Автор - elovkov
Дата добавления - 30.01.2023 в 13:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос формулы по ячейкам в строке (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!