Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как найти значание при нескольких условия? - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти значание при нескольких условия? (Формулы/Formulas)
Как найти значание при нескольких условия?
irinasuhoveewa Дата: Понедельник, 02.01.2023, 01:01 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! подскажите как подтянуть данные по двум критериям, но значения находятся в нестандартной таблице? Есть город и тип транспорта, в зависимости от этого нужно подтянуть тариф из другой таблицы.
К сообщению приложен файл: Book2.xlsx(13.5 Kb)
 
Ответить
СообщениеДобрый день! подскажите как подтянуть данные по двум критериям, но значения находятся в нестандартной таблице? Есть город и тип транспорта, в зависимости от этого нужно подтянуть тариф из другой таблицы.

Автор - irinasuhoveewa
Дата добавления - 02.01.2023 в 01:01
OlehandR Дата: Понедельник, 02.01.2023, 05:16 | Сообщение № 2
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 2 ±
Замечаний: 0% ±

Здравствуйте
Код
=ЕСЛИ(B2="А82";ВПР(A2;тарифы!A:C;2;0);ВПР(A2;тарифы!A:C;3;0))

Ну а по примеру Казани, если не полное совпадение имени, можно вот так попробовать
Код
=ЕСЛИ(B4="А82";ВПР(A4&"*";тарифы!A:C;2;0);ВПР(A4&"*";тарифы!A:C;3;0))
К сообщению приложен файл: 2729311.xlsx(15.1 Kb)


Сообщение отредактировал OlehandR - Понедельник, 02.01.2023, 05:16
 
Ответить
СообщениеЗдравствуйте
Код
=ЕСЛИ(B2="А82";ВПР(A2;тарифы!A:C;2;0);ВПР(A2;тарифы!A:C;3;0))

Ну а по примеру Казани, если не полное совпадение имени, можно вот так попробовать
Код
=ЕСЛИ(B4="А82";ВПР(A4&"*";тарифы!A:C;2;0);ВПР(A4&"*";тарифы!A:C;3;0))

Автор - OlehandR
Дата добавления - 02.01.2023 в 05:16
bigorq Дата: Понедельник, 02.01.2023, 12:39 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 155
Репутация: 31 ±
Замечаний: 0% ±

Нет
Можно так:
Код
=INDEX(тарифы.$B$3:$C$78;MATCH(A2&"*";тарифы.$A$3:$A$78;0);MATCH(RIGHT(B2;2);LEFT(тарифы.$B$2:$C$2;2);0))
 
Ответить
СообщениеМожно так:
Код
=INDEX(тарифы.$B$3:$C$78;MATCH(A2&"*";тарифы.$A$3:$A$78;0);MATCH(RIGHT(B2;2);LEFT(тарифы.$B$2:$C$2;2);0))

Автор - bigorq
Дата добавления - 02.01.2023 в 12:39
irinasuhoveewa Дата: Понедельник, 02.01.2023, 13:04 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

OlehandR, спасибо большое! все работает :D А если будут пустые ячейки в "Тип а/т куб.м" формула будет вот такая?

=IF(B2="А82";VLOOKUP(A2;тарифы!A:C;2;0);IF(B2="А50";VLOOKUP(A2;тарифы!A:C;3;0);""))
К сообщению приложен файл: Book3.xlsx(15.1 Kb)
 
Ответить
СообщениеOlehandR, спасибо большое! все работает :D А если будут пустые ячейки в "Тип а/т куб.м" формула будет вот такая?

=IF(B2="А82";VLOOKUP(A2;тарифы!A:C;2;0);IF(B2="А50";VLOOKUP(A2;тарифы!A:C;3;0);""))

Автор - irinasuhoveewa
Дата добавления - 02.01.2023 в 13:04
irinasuhoveewa Дата: Понедельник, 02.01.2023, 13:23 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

bigorq, класс, тоже работает! Спасибо! :D
 
Ответить
Сообщениеbigorq, класс, тоже работает! Спасибо! :D

Автор - irinasuhoveewa
Дата добавления - 02.01.2023 в 13:23
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как найти значание при нескольких условия? (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2023 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!